www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik OPV Offset Problem


Autor: Kent (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich versuche eine Highside-Strommessung über einen Shunt mit einem 
TL081CP zu realisieren. Nachdem das in der Simulation prima klappte habe 
ich es aufgebaut und die Ergebnisse waren völlig seltsam. Also habe ich 
erstmal eine ganz einfache Versuchsschaltung aufgebaut:

den OPV mit +/-16V gespeist. Invertierender und nichtinvertierender 
Eingang liegen am gleichen Potenzial, welches per Poti aus der 
Versorgungsspannung zwischen -16 und +16V eingestellt wird. Außerdem an 
den Offset-Compensation-Pins noch ein 100K-Poti, dessen "Mitte" an -16V 
liegt.

Nun kriege ich eine konstante Ausgangsspannung von 1.37V egal was die 
Eingangsspannung ist. Nur bei nahe -16V Eingangsspannung springt der 
Ausgang auf +16V (was nachvollziehbar ist).

Durch Drehen am Offset-Poti kann ich den Wert nur "verschlimmern", der 
"beste" Wert sind halt die 1.37V.

Was ich noch erwähnen sollte, die Versorgungsspannungen sind nicht 
stabilisiert (macht das einen Unterschied bei den winzigen Strömen?)

Autor: Kent (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag: Lege ich beide Eingänge auf GND (Mittelpunkt) dann sind am 
Ausgang immer noch 1.37V. Habe bereits mehrere OPV getestet also kaputt 
ist er auch nicht... es müsste doch wenigstens hier möglich sein mit der 
Offset-Kompensation den Ausgang auf Null zu regeln, denn so macht man 
das doch üblicherweise dachte ich...

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schon mal versucht, durch eine Gegenkopplung die Verstärkung des OPV 
entscheidend zu verringern?

Autor: Kent (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja hat nichts gebracht

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kent schrieb:
> Ja hat nichts gebracht

Auf welche Verstärkung?

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der OPV kann nicht (sicher) mit einer Eingangsspannung beaufschlagt 
werden, die gleich der pos. Betriebsspannung entspricht. Ist schließlich 
kein echter Rail-to-Rail-Typ.
Und lt. DB darf ohnehin nur max. +/- 15V an die Eingänge, was bei den 
Abs. Max. Ratings steht. Da Du bereits 16V dran hattest, könnten die 
also schon hinüber sein (was ich aber trotzdem noch nicht glaube).

Autor: Kent (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Der OPV kann nicht (sicher) mit einer Eingangsspannung beaufschlagt
>werden, die gleich der pos. Betriebsspannung entspricht. Ist schließlich
>kein echter Rail-to-Rail-Typ.
>Und lt. DB darf ohnehin nur max. +/- 15V an die Eingänge, was bei den
>Abs. Max. Ratings steht. Da Du bereits 16V dran hattest, könnten die
>also schon hinüber sein (was ich aber trotzdem noch nicht glaube).

Ist mir dann auch aufgefallen, also nochmal einen neuen TL081 rein. 
Wieder das gleiche: GND an beide Eingänge, Ausgang 1.37V. Kann doch 
nicht wahr sein...

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei Dir in der Schaltung scheinen einfach paar Widerstände zu fehlen, 
denn sonst könntest Du keine gleiche Spannung an die Eingänge legen. Wie 
soll da der OPV ohne Gegenkopplung und Serienwiderstände die Differenz 
zwischen seinen Eingängen auf null bekommen?

Autor: Yalu X. (yalu) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mein TL081CN funktioniert wunderbar. Versorgung ±16V, beide Eingänge 0V,
39k + 20k-Poti + 39k zwischen die Offsetanschlüsse, Potischleifer an
-16V, keine Gegenkopplung.

Wie zu erwarten, liegen am Ausgang je nach Potistellung entweder UAmax
(ca. +15.2V) oder UAmin (ca. -14,5V) an. Wenn man ganz feinfühlig am
Poti dreht, sind auch Spannungswerte dazwischen möglich.

Bist du sicher, dass alle Leitungen richtig und mit gutem Kontakt
angeschlossen sind und du nicht zufälligerweise einen TL082 erwischt
hast?

Autor: Kent (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Yalu X.,

heisst das dass der Ausgang ohne Rückkopplung auch bei 2 gleichen 
Eingangspotenzialen nie Null werden kann?

Autor: Klaus De lisson (kolisson)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>> heisst das dass der Ausgang ohne Rückkopplung auch bei 2 gleichen
>> Eingangspotenzialen nie Null werden kann?

Doch, es wird null sein...
aber leider in Bezug auf die Eingänge...  und wenn Gain = open Loop
dann unkontrollierbar!
zusätzlich bei TL 081 .. die Gefahr von Phase Reversal

spar dir die -16V und mach so:
http://www.mikrocontroller.net/attachment/85925/ko...

den ganzen Beitrag gibt es da:

Beitrag "Strom messen mit Shunt und LM358"

Gruss K.

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>aber leider in Bezug auf die Eingänge...  und wenn Gain = open Loop
>dann unkontrollierbar!
>zusätzlich bei TL 081 .. die Gefahr von Phase Reversal

hmm - wenn open loop, dann keine Rückkopplung. Wenn keine Rückkopplung, 
dann geht nix auf den (neg.) Eingang zurück - also was interessiert da 
der/die/das Phase Reversal?

Autor: Ulrich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der TL081 ist kein Rail to Rail OP, aber halt einer bei dem die Eingänge 
auch bis an die positive Versorgung ran dürfen. Mit ein LF356 oder 
ähnlichem könnte man sogar noch etwas über die Versorgungsspannung 
hinaus.

Das Problem mit dem Phase Reversal kommt, wenn man zu nahe an die 
negative Versorgung kommt. Da sind wir hier weit weg.

Ohne Rückkopplung wird der Bereich wo man zwischenwerte am Ausgang hat 
einfach sehr klein. So fein kann dem Poti kaum einstellen und die 
Temperatur beleibt auch kaum so stabil.
Die Rückkopplung ist aber auch nicht trivial, weil der Ausgang des OPs 
nicht bis an die positive Versorgung reicht.

Autor: Name ist Wurscht (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ob Differenzverstärkung, Gleichtaktverstärkung oder 
Gleichtaktunterdrückung - koppel einfach gegen. Und das Problem ist 
gegessen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.