www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Op-Amp schwingt immer nur


Autor: Johannes S. (oberekel)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich versuche jetzt schon einige Zeit, einen TI OPA847 
(http://focus.ti.com/lit/ds/symlink/opa847.pdf) zum laufen zu kriegen. 
Zuerst habe ich ihn in eine selbst entworfene Schaltung eingebaut, am 
Ausgang hatte ich jedoch nur Schwingungen, ohne das ich ein 
Eingangssignal anliegen hatte. Also habe ich überlegt, meine Kenntnisse 
im Layout sind nicht so gut, daran könnte es gut liegen.

Ich habe bei danach TI noch eine Demoplatine (DEM-OPA-SO-1B, 
http://focus.ti.com/lit/ug/sbou026b/sbou026b.pdf) gekauft. Darauf habe 
ich dann den Op-Amp und die restlichen Bauteile nach der 
Beispielschaltung FIGURE 1 aus dem Datenblatt des Op-Amps (Seite 10) 
gelötet. Somit sind jetzt verbaut die Widerstände R1-R4, die 
Kondensatoren C1 und C2 (Conrad 445273), die Kondensatoren C5 und C6 
(Conrad 501175) sowie SMA Einbaubuchsen für Input und Output (Conrad 
730635). Am Disable Pin wurde nicht angeschlossen.

Soweit sollte es dann funktionieren, also habe ich die 
Versorgungsspannung (+/- 5V) angeschlossen sowie am Eingang einmal 
einfach einen 50 Ohm-Abschlusswiderstand und einmal einen 
Signalgenerator. Das Ergebnis war das gleiche wie auf meiner eigenen 
Platine, es ist im Anhang zu sehen.

Jetzt bin ich mit meinen Ideen echt am Ende, eigentlich denke ich sollte 
jetzt alles nach Anleitung aufgebaut sein, aber es klappt einfach nicht. 
Hat jemand von Euch noch irgendwelche Anregungen, was ich sonst noch 
probieren könnte? Vielen Dank schonmal für jegliche Antworten.

Viele Grüße,
Johannes

P.S.: Kann man angehängte Bilder noch irgendwie bearbeiten bzw. löschen?

Autor: Johannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Somit sind jetzt verbaut die Widerstände R1-R4...

Was für Widerstandswerte hast Du denn verbaut? Dir ist schon klar, dass 
der OPV mindestens eine Vestärkung von 12 braucht, damit er stabil 
läuft?

Autor: Johannes S. (oberekel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mich wie schon erwähnt an dem Aufbau FIGURE 1 gehalten. Da ich 
die Werte nicht genau passend da hatte habe ich jetzt verbaut:
R1 47 Ohm (statt 50)
R2 39 Ohm (statt 39,2)
R3 680 Ohm (statt 750)
R4 47 Ohm (statt 50)
Damit sollte er doch bei einer Verstärkung von ca. 17,5 liegen. Wäre es 
wohl besser, erstmal eine höhere Verstärkung zu wählen, ist er dann 
stabiler?

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nur als Idee
-Ob die Abblock-Cs alle funktionieren / Aufbau?
-Mantelwellen auf dem Anschlusskabel?

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ich versuche jetzt schon einige Zeit, einen TI OPA847 zum laufen zu
>kriegen. ... Also habe ich überlegt, meine Kenntnisse im Layout sind
>nicht so gut, daran könnte es gut liegen.

Was Schnelleres als einen 4GHz-OPamp hast du nicht finden können??

Nicht direkt mit dem Tastkopf den Ausgang berühren, sondern immer über 
einen Serienwiderstand, weil sonst die kapazitive Last den OPamp sofort 
zum Schwimgen bringt.

Normalerweise wird am Ausgang in 50R-Technik gearbeitet, d.h. du hast 
einen 50R-Ausgangswiderstand, eine 50R-Leitung und einen 50R-Abschluß. 
So schließt du dann auch das Oszi an, mit seinem 
50R-Eingangs-Widerstand, wenn er hat.

Kai Klaas

Autor: Johannes S. (oberekel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Kai Klaas
Nein, etwas schnelleres habe ich nicht gefunden, sonst hätte ich es auch 
verwendet.

Ich habe das ganze auf dem Demoboard aufgebaut, dort sind auch die 
(halbwegs) passenden Widerstände für 50R-Technik vorhanden (ich hatte 
halt nur 47R, macht das einen so großen Unterschied?). Ansonsten gehe 
ich von der SMA-Anschlussbuchse mit einem Adapter an das Oszi, welches 
auf 50R gestellt ist.

Autor: visitor (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
vielleicht ist das was für
Beitrag "ST ausgenutzt und bis aufs Blut gequält - Wettbewerb"

Dann gibt es eine neue Klasse: OP :-)

Autor: Bierhaubitze (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich bin noch am rätseln was die 4 Kondensatoren zwischen Masse und 
Versorgungsspannung machen, wenn sie zum Glätten der Spannung sind ist 
die frage wieso diese Werte und diese Position, wieso nicht ein 10uF 
ELKO, sondern 6,9uF, vorallem wenn man die 20% Tolleranz mit rechnet 
liegt der Kondensator noch irgendwo unterhalb des Tolleranzwertes..
Außerdem verstehe ich die Anzeige deines Oszis nicht: Wie groß ist ein 
Skalenteil in beide Richtungen?

Autor: Johannes S. (oberekel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Bierhaubitze
Die Kondensatorwerte habe ich direkt so aus dem Beispiel des 
Datenblattes und der Aufbauanleitung für das Demonstrationsboard 
übernommen, da ich möglichst wenig verändern wollte für den Anfang.

Die Skala im Oszi ist 1 ns und 100 mV. Der Op-Amp führt somit eine 
Schwingung mit einer Periodendauer von ca. 3 ns und einer Amplitude von 
550 mV_pp aus.

Autor: Nachtaktiver (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bierhaubitze schrieb:
> ie groß ist ein
> Skalenteil in beide Richtungen?

Steht doch da. 100mV und 1ns.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Die Kondensatorwerte habe ich direkt so aus dem Beispiel des
>Datenblattes und der Aufbauanleitung für das Demonstrationsboard
>übernommen, da ich möglichst wenig verändern wollte für den Anfang.

Ich habe mir jetzt mal das Layout des Demo-Boards genauer angeschaut und 
bin ehrlich gesagt völlig sprachlos. Das ist eines der miserabelsten 
Layouts, die ich je gesehen habe. Alleine die Masseanbindung von C1 ist 
ein Kracher. Und dann die Vias in den SMD-Lötpads. Furchtbar. Die Arbeit 
von einem völligen Dilettanten.

Verwende statt der 1206-100nF-SMD-Kondensatoren und der 6,8µF-Tantals 
lieber zwei einzelne 10µF/X7R-0805-HighCaps, die du direkt vom 
jeweiligen Supply-Pin des OPamp zur Massefläche lötest. An der 
Massefläche kannst du eine kleine Wärmefalle vorsehen, aber nicht so 
einen Lurch wie im Demo-Layout.

Dummerweise hat das Demo-Board weder oben noch unten eine Massefläche. 
Was für ein völliger Schwachsinn. Und die beiden innen liegenden 
"Masseflächen" sind außerdem noch weitgehend von einander isoliert.

Pikanterweise kommt das Demo-Board in der Revision F! Hallelujah, da hat 
sich vielleicht ein Schwachkopf ausgetobt. Beispiellos erbärmlich...

Kai Klaas

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ob die Abblock-Cs HF-mäßig gut positioniert sind, hatte ich oben schon 
Zweifel. Notfalls noch ein paar nF möglichst nahe (zum Test auch 
parallel zu den vorhandenen)?

Autor: Guido C. (guidoanalog)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Kai Klaas schrieb:
> Alleine die Masseanbindung von C1 ist
> ein Kracher.

@Kai
Meinst Du damit die Längsinduktivität/Leitung im Mid-Layer?

Mit freundlichen Grüßen
Guido

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Meinst Du damit die Längsinduktivität/Leitung im Mid-Layer?

Genau. Da hatte jemand offenbar derart panische Angst vor 
Streukapazitäten unter den Bauteilen, daß er die Masseanbindung des 
Entkoppelkondensators ad absurdum geführt hat.

Kai Klaas

Autor: Johannes S. (oberekel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für die Anregungen, dann werde ich mich am Montag einmal 
daran versuchen. Eigentlich hatte ich ja gehofft, TI hätte, wenn sie 
schon ein Demoboard anbieten, sich auch Gedanken dazu gemacht, aber nach 
Euren Aussagen hört es sich ja nicht so an.

Vielen Dank auf jeden Fall schonmal für die zahlreichen Antworten, damit 
habe ich jetzt auf jeden Fall etwas, womit ich weiterarbeiten kann.

Autor: Johannes S. (oberekel)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe jetzt als erstes Mal die Spannungen an den Versorgungspins des 
IC vorgenommen. Die beiden Bilder (+5V und -5V) wurden jeweils mit 
passendem Offset aufgenommen, man sieht ein Schwanken der 
Versorungsspannung um +/- 20 mV jeweils. Ist das für so einen Op-Amp 
generell schon zu viel? Ich werde es jetzt auf jeden Fall noch mit 
zusätzlichen Abblockkondensatoren versuchen, aber es würde mich generell 
interessieren, wie konstant die Spannung für so ein IC gehalten werden 
muss.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Johannes S. schrieb:
> Die beiden Bilder (+5V und -5V) wurden jeweils mit
> passendem Offset aufgenommen
Miss doch bitte auch mal die Masse an verschiedenen Punkten...
(Richtig: Masse gegen Masse ;-)


Ein wenig OT:
Kai Klaas schrieb:
> Ich habe mir jetzt mal das Layout des Demo-Boards genauer angeschaut und
> bin ehrlich gesagt völlig sprachlos. ..... Furchtbar. Die Arbeit
> von einem völligen Dilettanten.
Urigerweise gibt es sowas auch bei anderen:
Beitrag "Re: Quarz Schwingt nur bei berührung"
Das musste ich gleich als abschreckendes Beispiel mit aufnehmen:
http://www.lothar-miller.de/s9y/categories/33-Quarz (unten)

Autor: Johannes S. (oberekel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank nochmal an alle für Ihre Ideen. Aber das Problem hat sich 
doch jetzt sehr trivial gelöst. Die Widerstände hatte ich aus einem 
gerade neu gekauften SMD-Sortiment, und in der 39 Ohm-Kiste waren 39 
kOhm. Und mit R2 = 39 kOhm ist es auch kein besonderes Wunder, dass der 
Verstärker nicht ordentlich arbeiten wollte. Da ich ja jetzt keinerlei 
39 Ohm Widerstände habe (in der 39 kOhm-Kiste sind die richtigen drin), 
habe ich einen 33 Ohm Widerstand eingebaut, und damit funktioniert es 
einwandfrei, auch die zusätzlichen Abblockkondensatoren konnte ich 
wieder ablöten. Ich werde es mir auf jeden Fall für die Zukunft merken, 
jedes Bauteil besser 3-mal zu kontrollieren, auch wenn es gerade frisch 
aus der Verpackung kommt.

Autor: Johannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Die Widerstände hatte ich aus einem gerade neu gekauften SMD-Sortiment,
> und in der 39 Ohm-Kiste waren 39 kOhm.

Das kommt mir irgendwie bekannt vor; wo hast Du denn das Sortiment 
gekauft? Beginnt der Name mit "M"?

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Vielen Dank nochmal an alle für Ihre Ideen. Aber das Problem hat sich
>doch jetzt sehr trivial gelöst.

Das Layout des Demoboards ist trotzdem Murks!

Kai Klaas

Autor: Johannes S. (oberekel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Sortiment war von Reichelt, "Sortiment SMD 3".

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Johannes,

ich habe ein Design mit dem THS3201/THS3202 aufgebaut (2GHz Opamp).
Da war es entscheidend, die parasitären Kapazitäten des Rückkoppelpfades 
zu minimieren - indem alle Innenlagen unterhalb des Pfades von Kupfer 
freigestellt waren.
http://focus.ti.com/lit/ds/slos416c/slos416c.pdf

Jede Kapazität (gegen Masse) am Eingang der Rückkoppelung sorgt für eine 
Erhöhung der Verstärkung und eine Phasendrehung, so dass aus einer 
stabilen Rückkoppelung eine nette Mitkoppelung wird.
Bei 4 GHz haben 1pF parasitäre Kapazität eine Impedanz von 39 Ohm !
Da sind schnell ein paar hunder fF allein mit dem Pad eines 
SMD-Widerstandes auf der Platine zusammen.

Mach doch mal ein Foto von deinem Messaufbau!

Autor: ChristophK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Johannes,
mal 'ne andere Frage: Was für ein Scope ist das, was Du da benutzt und 
von dem man so schöne Bilder abziehen kann? Ist das ein PC-Scope?

Viele Grüße
Christoph

Autor: CADler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sieht nach LeCroy aus :-)

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ChristophK schrieb:
> Ist das ein PC-Scope?
Mit 10 GS/s?
Und offenbar einer analogen Bandbreite im GHz-nahen Bereich?

> Was für ein Scope ist das, was Du da benutzt und
> von dem man so schöne Bilder abziehen kann?
Screenshots kann man heutzutage mit jedem Digitaloszi machen.

Autor: Lukas K. (carrotindustries)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lothar Miller schrieb:
>> Was für ein Scope ist das, was Du da benutzt und
>> von dem man so schöne Bilder abziehen kann?
> Screenshots kann man heutzutage mit jedem Digitaloszi machen.

Auch wenn die QVGA-Briefmarken keineswegs eine Augenweide sind...
Am schönsten ist immer noch ein analoges 'Skop abfotografiert
http://amplifier.cd/Technische_Berichte/Photo_Expe...
Ist zwar ein wenig umständlicher, als den "Print" Knopf zu drücken, 
dafür ist das Ergebnis um Klassen besser.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Luk4s K. schrieb:
> Am schönsten ist immer noch ein analoges 'Skop abfotografiert
Es hat was nostalgisches, ja... ;-)

Autor: Johannes S. (oberekel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist ein LeCroy LC534M, ausgelesen über die Software ScopeExplorer.

Autor: ChristophK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lothar Miller schrieb:
> ChristophK schrieb:
>> Ist das ein PC-Scope?
> Mit 10 GS/s?
> Und offenbar einer analogen Bandbreite im GHz-nahen Bereich?
>
>> Was für ein Scope ist das, was Du da benutzt und
>> von dem man so schöne Bilder abziehen kann?
> Screenshots kann man heutzutage mit jedem Digitaloszi machen.
>
>
PC-Scope:
Es gibt doch sicher auch Scopes, wo nur der Analog- und Signalteil
ausgelagert ist und die Display und Bedienfunktion ganz auf den PC 
verlagert ist, oder?

--
Christoph

Autor: ChristophK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Johannes S. schrieb:
> Ist ein LeCroy LC534M, ausgelesen über die Software ScopeExplorer.

Danke f.d. Info.
--
Christoph

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ChristophK schrieb:
> Es gibt doch sicher auch Scopes, wo nur der Analog- und Signalteil
> ausgelagert ist und die Display und Bedienfunktion ganz auf den PC
> verlagert ist, oder?
Ja, es gibt Scopes, da steckt das Oszi in einem 19" Mainframe und zur 
Visualisierung ist ein PC (über Ethernet) angeschlossen.
http://www.home.agilent.com/agilent/product.jspx?n...
Aber die sterben langsam aus....

Stattdessen gibt es Oszis, an die auch ein externer PC via Ethernet 
angeschlossen werden kann.
http://www.home.agilent.com/agilent/product.jspx?n...

Aber diese kleinen "Messverstärker" wie du sie vermutlich meinst, kommen 
nicht in die GHz Region:
http://www.home.agilent.com/agilent/product.jspx?n...

Autor: Johannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Es gibt doch sicher auch Scopes, wo nur der Analog- und Signalteil
> ausgelagert ist und die Display und Bedienfunktion ganz auf den PC
> verlagert ist, oder?

Es gibt USB-Scopes mit sehr hoher analoger Bandbreite:

http://www.fastsampling.com/Products/DS800/DS800Manual14.pdf

Das wurde vor kurzem hier verwendet: 
Beitrag "Re: Eigenbautastköpfe"

der Screenshot sieht ganz ordentlich aus.

Autor: Lukas K. (carrotindustries)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie schon bereits an anderer Stelle erwähnt, gibt es auch sehr schnelle 
USB-Oszilloskope: http://www.fastsampling.com/

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.