www.mikrocontroller.net

Forum: FPGA, VHDL & Co. Xilinx Webpack 12.4 macht nix


Autor: X- Rocka (x-rocka)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Moin,

habe endlich mal meinen Arbeitsrechner aufgeräumt, um 8GB für die 
aktuelle Xilinx Software freizuräumen. Stunden...
Installiert, und einige Tools arbeiten auch (zum Glück Impact, da Impact 
von 6.3 nicht mit meinen Firmware aktualisierten USB Platform Cables 
läuft - andere Baustelle...).
Nur:

Xilinx ISE Design Suite 12.4: das starten geht, öffnet mir ein Fenster 
namens ClipHost, aber damit kann ich NIX machen: File New / Open macht 
gar nix!

PlanAhead: gibt mir gleich eine Fehlermeldung, siehe jpg.

Das ganze auf einem WinXP SP2 Home (?) System.
Hat jemand eine Ahnung? Bei Xilinx habe ich noch nichts gefunden.

Danke,
X

Autor: Anguel S. (anguel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tut die Datei existieren? Wie groß ist sie? Bist Du sicher, dass Dir 
kein Antivirus (z.B. Norton) etwas während/nach der Install weggelöscht 
hat? Xilinx verwendet Programmiertechniken, die oft als Virus erkannt 
werden.

Autor: X- Rocka (x-rocka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Virus... gute Idee, ich forsche mal!

Danke!

Autor: Anguel S. (anguel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
X- Rocka schrieb:
> Virus... gute Idee, ich forsche mal!

Such mal nach "norton" hier im Forum.

Viel Erfolg!
Anguel

Autor: Frank Buss (foobar)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Also hattest du vor der Installation noch 8 GB auf der Platte frei? 
Keine Ahnung, was du damit genau meinst, aber klingt etwas knapp. Anbei 
ein Screenshot vom \xilinx\12.4-Ordner hier.

Autor: T. M. (xgcfx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wow. Mein MacOS ist kleiner auf der Platte.
Im Notfall musst du halt bei der Installation den Support für einige 
Bauteilefamilien abwählen, das dürfte Einiges an Platz sparen.

Autor: X- Rocka (x-rocka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Frank Buss schrieb:
> Also hattest du vor der Installation noch 8 GB auf der Platte frei?
> Keine Ahnung, was du damit genau meinst, aber klingt etwas knapp. Anbei
> ein Screenshot vom \xilinx\12.4-Ordner hier.

:-)

Nein, ich hatte 20GB frei, habe dann vor der Installation noch weitere 
10GB frei gemacht.

Autor: X- Rocka (x-rocka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Torsten M. schrieb:
> Im Notfall musst du halt bei der Installation den Support für einige
> Bauteilefamilien abwählen, das dürfte Einiges an Platz sparen.

Schön wär's wenn's das noch geben würde - leider nicht, man hat's ja!
Ich leider nicht, mein Arbeits-Laptop ist von 2007 und hat nur ne 100GB 
HD.

Autor: X- Rocka (x-rocka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe heute morgen alles nochmal neu installiert - leider keine 
Veränderung.
Habe meine Antivirus-Software (GData AVK) gecheckt, die meckert nicht.

Liegt's vielleicht daran, dass es auf Laufwerk "D" und nicht "C" 
installiert ist?
Sollte 2011 ja nicht mehr passieren, aber...?

Autor: Anguel S. (anguel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
X- Rocka schrieb:
> Liegt's vielleicht daran, dass es auf Laufwerk "D" und nicht "C"
> installiert ist?
> Sollte 2011 ja nicht mehr passieren, aber...?

Bei Xilinx ist alles möglich...
Check mal, ob die Systemvariablen für die Pfade richtig gesetzt sind. Du 
hast immer noch nicht gesagt, ob die Datei wegen der er meckert 
vorhanden ist und wie groß sie ist.

Autor: X- Rocka (x-rocka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Anguel S. schrieb:

> Bei Xilinx ist alles möglich...
> Check mal, ob die Systemvariablen für die Pfade richtig gesetzt sind.

Äh, wo kucke ich da?
"XInfo" läuft, zeigt mir unter Software alles mit richtigen Pfaden.
Kollidiert es vielleicht doch mit ISE6.3i auf C: ?


> Du hast immer noch nicht gesagt, ob die Datei wegen der er meckert
> vorhanden ist und wie groß sie ist.

Datei vorhanden, aber leer (0kB)! Da sind einige leere dlls. Aha...
Warum?

Danke!

Edit:
Habe gerade "RegSeeker" gestartet, da taucht kein Xilinx 12.4 auf (6.3i 
und Webpack 7 sind zu sehen). Merkwürdig, ein Programm, das nix in die 
registry schreibt?

Autor: flo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
während der Installation braucht ISE sehr viel Temporären Speicher. 
Vielleicht ist dir der ausgegangen.

Autor: X- Rocka (x-rocka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
flo schrieb:
> während der Installation braucht ISE sehr viel Temporären Speicher.
> Vielleicht ist dir der ausgegangen.

Glaube ich nicht, der liegt bei mir auf D, wo noch >20GB frei sind.

Autor: Duke Scarring (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast evtl. Leerzeichen (oder Punkte) im Pfad?
Die machen gern mal Problem ohne darauf hinzuweisen :-/

Duke

Autor: X- Rocka (x-rocka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe nun nochmals 12.4 deinstalliert, dafür 12.3 draufgespielt - und 
läuft! (grob getestet, macht deutlich mehr als 12.4)

Danke,
X

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm, also bei mir macht die 12.4 weder unter XP SP3 noch unter Windows 7 
x64 Probleme. OK, System Edition, aber das ist ja nur eine Lizenzfrage.

Autor: Anguel S. (anguel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
X- Rocka schrieb:
>> Du hast immer noch nicht gesagt, ob die Datei wegen der er meckert
>> vorhanden ist und wie groß sie ist.
>
> Datei vorhanden, aber leer (0kB)! Da sind einige leere dlls. Aha...
> Warum?
>
> Danke!

Bitte, das ist dann des Rätsels Lösung. Aber eigentlich prüft man bei 
einer so konkreten Fehlermeldung sowas bevor man ins Forum postet :(

Hast Du deinen Installer bei Xilinx heruntergeladen oder woanders? Kann 
es sein, dass der unvollständig oder beschädigt ist?

Autor: X- Rocka (x-rocka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Anguel S. schrieb:

> Bitte, das ist dann des Rätsels Lösung. Aber eigentlich prüft man bei
> einer so konkreten Fehlermeldung sowas bevor man ins Forum postet :(

Ich hatte gesehen, dass die Datei da ist, aber nicht die Größe beachtet. 
Mein Fehler


> Hast Du deinen Installer bei Xilinx heruntergeladen oder woanders? Kann
> es sein, dass der unvollständig oder beschädigt ist?

Direkt von Xilinx geladen. Entpacken funktionierte, installieren auch 
ohne Gemecker.

Dann werde ich wohl nochmal irgendwann einen Download starten.

Danke,
X

Autor: df1as (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich sage mal danke für die Warnung und bleibe vorerst bei 12.2. Für 
einige ältere Projekte habe ich parallel sogar noch eine 9er-Version 
laufen (immerhin geht das wenigstens bei ISE). Irgendetwas muss man nach 
einem Update doch immer ändern, neue Attributnamen oder was auch immer. 
Für neue Projekte oder Chips: Update ja, wenn's denn sein muss.

Ich hatte es auch schon, dass bei exzessiver Verwendung der Block-RAMs 
der Chip einfach nicht mehr geroutet werden wollte, aber bei der alten 
Version ging es. Und umgekehrt.

Vielleicht muss man jetzt zur Installation Administrator-Rechte haben, 
damit sich alles richtig installiert. Nur so 'ne Idee.

Autor: X- Rocka (x-rocka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich kriege hier echt noch den Rappel mit diesen riesigen, nicht 
funktionierenden Xilinx Versionen.

12.3 läuft, hatte mir aber das schicke 13.1 PlanAhead Tutorial 
angesehen, wieder gefühlte Tage runtergeladen und installiert - und geht 
wieder nicht.
Echt zum Heulen.
Diesmal startet alles, aber schmiert irgendwann mit Fehlermeldungen ab. 
Xilinx mag micht nicht!

Autor: Duke Scarring (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
X- Rocka schrieb:
> 13.1
Ich warte bei Xilinx immer auf die X.2 Version.

Duke

Autor: X- Rocka (x-rocka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Duke Scarring schrieb:
> X- Rocka schrieb:
>> 13.1
> Ich warte bei Xilinx immer auf die X.2 Version.
>
> Duke

Danke für den Tipp.
Ich hatte bis zum Januar 2011 seit Jahren nur mit 6.3 gearbeitet, 
brauche aber nun was frisches für Spartan 6. Bin also nicht mehr so mit 
dem Stand der Xilinx Tools vertraut.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Duke Scarring schrieb:
> Ich warte bei Xilinx immer auf die X.2 Version.
Tu das besser. So oft wie die 13.1 absemmelt...   :-(
Das tut sie gern beim Anlegen von Projetkten/Testbenches usw.
Zum Glück bisher nie bei der Implementierung... ;-)

Autor: Boris (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei mir läuft die 13.1 auf einem Debian sehr stabil. Und planAhead nutzt 
nun doch mehr als einen Kern der CPU (wenn auch nicht mit 100%). Bei der 
ISE 12.x und XPS 12.x war immer nur ein Kern zu 100% ausgelastet und die 
anderen waren im Leerlauf. In den letzten 2 Wochen kam es nur einmal 
vor, dass planAhead einfach weg war. Und XPS 13.1 tut's auch ohne 
Probleme.

Aber ich gebe zu, dass ich die 12.2 zur Sicherheit auch noch auf der 
Maschine habe;)

Autor: X- Rocka (x-rocka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,

hat schon jemand die 13.2 von Xilinx laufen?
Bekomme bald neuen Win 7 Rechner, arbeite momentan mit 12.3, läuft gut, 
aber irgendwann muss man ja mal wieder...

Danke,
X

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
13.2 System Edition läuft hier unter XP und 7 x64 bisher genauso gut 
oder schlecht wie man es gewohnt ist. Impact schmiert immer mal ab, aber 
ansonsten OK.

Autor: X- Rocka (x-rocka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Christian R. schrieb:
> 13.2 System Edition läuft hier unter XP und 7 x64 bisher genauso gut
> oder schlecht wie man es gewohnt ist. Impact schmiert immer mal ab, aber
> ansonsten OK.

Jau, danke. Ich werde es mal riskieren.
12.3 Impact ist bei mir das stabilste seit langem.
Aber neuer Rechner, neues Glück.

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Prinzipiell läuft ja die ISE seit der Einführung der XML-Projektfiles 
extrem zuverlässiger. Dieses Binärfile Geraffel war aber auch schlimm. 
Die 12er und jetzt 13er laufen alle sehr stabil, klar, Kleinigkeiten 
gibts immer mal. Die 12.x Versionen hatten bei mir immer das Problem, 
dass die beim Erstellen von Testbench Rahmen für vorhandene VHDL Dateien 
abgeschmiert sind, und somit nur noch verstümmelte Dateien produziert 
haben. Das ist zum Glück mit der 13.1 jetzt weg. Auch ist die 13 die 
erste, die Windows x64 vollständig offiziell unterstützt. Und Impact ist 
halt so ein Sorgenkind, prinzipiell gehts ja, aber beim Speichern von 
Projektdateien oder Löschen von Flash aus dem Promgen Interface spinnts 
immer mal rum.

Autor: X- Rocka (x-rocka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe auf meinem neuen Rechner mit Win 7 / 64 ISE 13.2 installiert.
Startet, sieht gut aus, dann neues Projekt und paff, Fehlermeldung.
Mal sehen wie sich 12.3 auf diesem Rechner schlägt.

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
X- Rocka schrieb:
> dann neues Projekt und paff, Fehlermeldung

Eventuell das Projekt in einem Ordner ohne Schreibrechte versucht 
anzulegen? Bei mir läuft die einwandfrei unter Win 7 x64. Man darf 
natürlich nicht in einem von der UAC überwachten Ordner arbeiten...

Autor: X- Rocka (x-rocka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Direkt nach anclicken "new project" kam die Fehlermeldung.
Müsste dann der Default Path sein. Aber so eine Fehlermeldung, ohne 
jegliche Info über die Ursache?

12.3 läuft. Dann bleibt's wohl erstmal dabei.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.