www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Versorgungsvermögen von MC7805C


Autor: Killerawft (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Ich habe mir eine Schaltung aufgebaut, die bei voller Belastung ca 1,8 A 
braucht. Damit dabei die Spannung auch konstant bei 5V bleibt, habe ich 
mir ein 3A, 7,5V Steckernetzteil gekauft und die Spannung mit einem 
MC7805C auf 5V Runtergeregelt. Da er bei den 1,8A Belastungen heiss 
wurde, habe ich einen 45 K/W Kühlkörper mit wärmeleitpaste an ihn 
festgeschraubt. Vor und nach dem MC habe ich jeweils einen 100µF Elko 
geschaltet.
Meine Schaltung sieht wie folgt aus. Ein µC steuert 3 TLC59116 an, die 
Jeweils 16 LED's am ausgang haben.
Wenn ich jetzt den ersten TLC ansteuere leuchten alle 16 LED's. Wenn ich 
jedoch den zweiten TLC ansteuer und somit weitere 16 LED's stürtzt der 
µC ab. Ich habe schon alle kombinationen mit dem Ansteuern ausprobiert 
und kann keinen Spannungseinbruch messen, jedoch kann es auch sein dass 
mein Multimeter zu langsam ist.

Es erschliesst sich für mich auch nicht aus dem Datenblatt, ob der MC 
für meine Schaltung überhaupt geeignet ist.
Könnt ihr mir da ein paar Tips geben, was ich gegen das Phänomen tun 
kann?

Autor: filipp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der MC7805 kann Ausgangsseitug nur 1 A

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

ist an der Grenze: laut Datenblatt braucht der 7805 min 7,2V Input. Ob 
dein Netzteil das liefert mußt du prüfen. Die 100uF am Ausgang würde ich 
durch 100n ersetzen. Die 100uF machen die Regelung langsamer. Die 100n 
brauchst du um die Schwingneigung des Reglers in den Griff zu bekommen.

Meine Aussagen beziehen sich auf das Datenblatt. 7805 anderer Hersteller 
haben andere Daten.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Killerawft schrieb:

> MC7805C auf 5V Runtergeregelt. Da er bei den 1,8A Belastungen heiss
> wurde, habe ich einen 45 K/W Kühlkörper mit wärmeleitpaste an ihn
> festgeschraubt.

Bischen mehr Alu wirst du wohl schon investieren müssen:
2,5V * 1,8A = 4,5W
4,5W * 45K/W = ~200°C über Umgebungstemp.
Limit vom Regler ist 150°C.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was für einer isses wirklich?
MC7805 => 1A (Text)
MC78T05 => 3A (Datasheet)

Autor: Killerawft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es ist der 78T05 mit 3A. Die Spannung vor dem 78T05 ist konstant bei 7,6 
Volt.

einen neuen Kühlkörper müsste ich noch besorgen. Gibts da empfehlungen?

Autor: Killerawft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich würde den FK 237 SA 220 von Conrad nehmen mit 21K/W.

Autor: JojoS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn sowieso ein Steckernetzteil verwendet wird, warum nicht gleich eins 
mit 5V/2A oder etwas mehr?

Autor: U. B. (pasewalker)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Es ist der 78T05 mit 3A. Die Spannung vor dem 78T05 ist konstant bei
> 7,6 Volt.

Das Steckernetzteil hat doch nur Transformator, Gleichrichter, 
Ladekondensator (?).
Vielleicht ist letzterer so klein, dass die Ausgangswelligkeit bis
unter 7 V geht ?

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

bei C Steckernetzteil als Schaltwandler 5V 3A 13,95€.

Autor: Gerd_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie schon geschrieben wurde sehr grenzwertige Drop-Spannung, dazu kommt 
noch das man nicht den typischen Wert hernehmen sollte, sondern den 
maximalen > und der liegt bei 2,5V (bei 3A).
Mit dem Multimeter bekommt man eine kurzzeitige Unterschreitung gar 
nicht mit, da hat der Mikrocontroller schon längst reagiert.

Bei der geringen Spannung muss man schon die Spannungsverluste an den 
Leitungen und vor allem auch vom Steckverbinder (Polklemme?) mit 
berücksichtigen.

@U.B.
Ein Steckernetzteil kann auch eines mit Linearregler oder gar 
getaktetes sein, da wäre schon mehr drin.

Gruß Gerd

Autor: H.Joachim Seifert (crazyhorse)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Gerd_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was ich vergessen hatte:

Ist am Mikrocontroller direkt auch ein Abblock-C?

Autor: Killerawft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte vorher ein steckernetzteil mit 5V und 2A. Da ist aber die 
spannungauf 4,3 V zusammengebrochen laos unbrauchbar. Und jetzt habe ich 
das Dehner Elektronik SYS 1308-1808 Stecker-Netzteil (Best.-Nr.: 511179 
- 62) von Conrad.
Ich hab einen abblock kondensator auf der Platiene des µC ca 5 cm 
entfernt.
Den MC habe ich mal testweise mit einem CPU kühler gekühlt. Wie zu 
erwarten blieb der MC eis kalt, doch der µC stürtzt ab dem zweiten TLC 
immernoch ab.

Autor: Thomas Eckmann (Firma: Thomas Eckmann Informationst.) (thomase)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie wäre es denn mit einem Schaltplan?

mfg.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Killerawft schrieb:

> Ich hab einen abblock kondensator auf der Platiene des µC ca 5 cm
> entfernt.

Aus dem Datasheet des Reglers: "Bypass Capacitors are recommend for 
optimum stability and transient response and should be located as close 
as possible to the regulator". Also einer davor, einer dahinter, direkt 
dran.

Autor: killerawft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die kondensatoren für den regler sind ja diereckt an dem regler dran.

Autor: Killerawft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Testweise habe ich auch mal die Schaltung an ein PC netzteil gehängt, 
das sollte ja schön glatte 5V liefern. auch da stürtzt die Schaltung 
schon bei einem TLC ab. ICh weiss jedoch nicht wieviel watt das NT hat, 
das ist schon etwas älter.

Ich suche mir mal schaltpläne für gute Konstantspannungsquellen raus. 
Habt ihr da vielleicht noch vorschläge ?

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

wenn deine Schaltung abstürzt an einem PC-Netzteil hast du irgendwo 
einen anderen Fehler! Zu lange Kabel, fehlende Blockkondensatoren. Evtl. 
Fehler mit Watchdog?

Deine 2 oder 3A sind eher Unterlast für so ein Netzteil.

Autor: Killerawft (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Also hier ist mal der Schaltplan. Zumindest der wichtige Teil. Nach 
Rechts sind nurnoch die anderen zwei TLC's genauso wie der andere TLC 
angeschlossen.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kondensatoren magst du nicht? Also die 100nF Kerkos zwischen VCC und 
GND, direkt an jedem entsprechenden Pinpaar jedes ICs.

Autor: Killerawft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wird dadurch nicht die gesamtkapazität der Schaltung zu hoch und hebt 
somit die Spannung auf über 5,5V ? oder regelt der MC das dann?

Beitrag #2086420 wurde vom Autor gelöscht.
Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich komm grad nicht mit was du meinst. Welchen Zusammenhang zwischen den 
unverzichtbaren Kerkos und der Höhe von Vcc siehst du da?

Autor: Killerawft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
durch eine hohe kapazität der schaltung und kleinen 
Spannungsschwankungen kann die spannung denke ich auch mal über 5,5v 
steigen. Ich hab aber nicht so das gefühl ab wann das auftritt.
Ich hab mal eine schatung gebaut mit einem AC/AC 230V/12V Trafo und dann 
einen gleichrichter dahinter gesetzt und einen 2200µF elko und die 
Spannung stieg bis 16volt an durch den elko.
Nicht dass ich mir durch die ganzen kondensatoren die Spannung zu hoch 
treibe.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Killerawft schrieb:

> durch eine hohe kapazität der schaltung und kleinen
> Spannungsschwankungen kann die spannung denke ich auch mal über 5,5v
> steigen.

Huh? Du meinst, wenn man genug Kondensatoren zusammenschaltet, dann 
laden die sich selber auf?

Nada, die gehören da rein, sonst ICs instabil.

> Ich hab mal eine schatung gebaut mit einem AC/AC 230V/12V Trafo und dann
> einen gleichrichter dahinter gesetzt und einen 2200µF elko und die
> Spannung stieg bis 16volt an durch den elko.

Jo, völlig normal. Ein 12V-Trafo hat 12V Effektivspannung, das sind 
12*1,4 = knapp 17V Spitzenspannung, abzüglich Gleichrichter, zuzüglich 
Leerlaufspannung vom Trafo, das passt. Das wird durch den Elko aber 
nicht mehr, dein mittelndes Messgerät zeigt damit nur mehr an.

Autor: Killerawft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok ich sollte nochmal etwas genauer etwas über kondensatoren in 
schaltungen lesen.

Müssen die 100nF kondensatoren keramikkondensatoren sein oder kann das 
auch ein folienkondensator oder elko sein? beim Conrad in meiner nähe 
gibts die dinger nicht.

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ein größerer Kühler wäre halt dauerfest, billiger wäre es aber wen du 
einen Lüfter auf deinen vorhandenen Kühlkörper schraubst.

Ansonsten CPU Kühler mit temperaturgeregeltem Lüfter gibt es sehr 
günstig und die können schon einiges mehr an Leistung abführen.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Killerawft schrieb:

> Müssen die 100nF kondensatoren keramikkondensatoren sein

Ja.

> oder kann das auch ein folienkondensator

Folie geht notfalls auch, ist aber netto schlechter geeignet, auch wenn 
so ein Kondensator rein formal besser ist.

> oder elko sein?

Keinesfalls.

> beim Conrad in meiner nähe gibts die dinger nicht.

Ich kann mir nicht vorstellen, dass der Conrad keine 
Vielschicht-Keramikkondensatoren 47-100nF hat. Das ist Standardware.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Killerawft schrieb:

> Ok ich sollte nochmal etwas genauer etwas über kondensatoren in
> schaltungen lesen.

http://www.rn-wissen.de/index.php/Abblockkondensator
Beitrag "Abblockkondensator Kerko oder Folie"

Autor: Killerawft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also die Kondensatoren sind an jedem IC und die drei TLC's können jetzt 
auch gleichzeitig die 16 RGB LED's ansteuern. Jetzt ist nurnoch das 
Problem, dass das LCD aufeinmal nichtmehr initialisiert. Es zeigt 
nurnoch zwei balken an. Auch ein kondensator am LCD konnte da keine 
Abhilfe schaffen.

Das LCD ist ein TC-1604A-01 Display. Vor den Kondensatoren hat das LCD 
einwandfrei mit exakt dem selben Programm funktioniert.

Autor: Killerawft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem mit dem LCD hat sich auch gelöst. Ein kabel auf der platiene 
vom stecker zum µC hat sich gelöst.

Vielen Dank für eure Hilfe.

Autor: Problöse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem ...es wurde gelöst... nämlich von dir, nachdem es sich 
gelöst hatte, ähh, von alleine.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.