mikrocontroller.net

Forum: www.mikrocontroller.net Links gehen nicht und Seitenbreite kaputt


Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
5 lesenswert
nicht lesenswert
Seit heute funktionieren auf meinem SeaMonkey und auch mit IE unter 
Win32 in Beiträge eingebettete Links nicht mehr per Raufklicken und bei 
einigen Beiträgen wird die Seitenbreite so weit aufgerissen, so das ich 
mit 1280*1024er Schirm nicht mehr alles raufkriege.
Beispiele:
Beitrag "Permanente Verbindungen zu Facebook"
Beitrag "5.1 audio wahlweise über boxen oder kopfhöhrer"

Lusitgerweise nicht bei allen Beiträgen - ich kann auch in den 
betroffenen keine überbreiten Zitate, Codeblöcke o.ä. erkennen.

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
6 lesenswert
nicht lesenswert
Danke für den Hinweis. Die Ursache war ein Fehler in der 
Link-Umwandlungsroutine, der nun behoben ist.

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für den schnellen Fix, Andreas :-)

Beitrag #5018737 wurde von einem Moderator gelöscht.
Autor: Magnus M. (magnetus) Benutzerseite
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Andreas S. schrieb:
> Danke für den Hinweis. Die Ursache war ein Fehler in der
> Link-Umwandlungsroutine, der nun behoben ist.

Leider noch nicht (ganz) behoben:

Die Links in den Beiträgen
Beitrag "Permanente Verbindungen zu Facebook"
und
https://www.mikrocontroller.net/topic/goto_post/5004794

Ziehen den Thread übelst in die Breite. Getestet mit IE11 und FF53.0.2

Autor: Frank M. (ukw) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei mir passiert das nicht, alles ganz normal. FF53.0.3

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Magnus M. schrieb:
> und
> https://www.mikrocontroller.net/topic/goto_post/5004794

Zumindest der Link zum Moog Synthi ist im ersten Beitrag auch nicht 
klickbar. Da der Link aber auch ein Monster ist, könnte es da einen 
Bufferüberlauf sein :-P

: Bearbeitet durch User
Autor: Karl B. (gustav)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
in solchen Fällen wäre es äußert informativ, das *.jpg in ein *.png zu 
verwandeln und hier direkt als Dateianhang zu posten.

Will man unbedingt einen überlangen Link posten, kann man das doch auch, 
indem man ihn in "notepad" (ja ja Win XP ok ok ok ) lädt und dann 
Zeilenumbruch wählt. Dann in Notepad alles markieren, kopieren und hier 
ins Textfeld <strg><v>. Fertig ist die Laube.

Ich mach's mal vor:

https://de.wikipedia.org/wiki/Moog-Synthesizer#/me...
i_Dance_Theater_of_NY)_@_Stearns_Collection_(Stearns_2035),_University_o 
f_
Michigan.jpg
Wird dann die Vorschau zu groß, dann mit shift Enter einen Zeilenumbruch 
erzwingen, der Foren-Parser nimmt dann den Link, kürzt ihn in dem 
Textfeld ab, setzt drei Pünktchen dahinter, aber leitet bei Anklicken 
tatsächlich auf die gewünschte Seite.
ciao
gustav

: Bearbeitet durch User
Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Karl B. schrieb:
> in solchen Fällen wäre es äußert informativ, das *.jpg in ein *.png zu
> verwandeln und hier direkt als Dateianhang zu posten.

Nein. Das ist eine Fehlanwendung des PNG-Formates.

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Rufus Τ. F. schrieb:
> Nein. Das ist eine Fehlanwendung des PNG-Formates

Sehe ich auch so, ausserdem ist der kleine Bug ja unabhängig vom Typ des 
HTTP Zieles. Es geht nicht nur um Bilder, sondern generell um überlange 
Hyperlinks.

Karl B. schrieb:
> Ich mach's mal vor:

Nö, funktioniert bei mir nicht, der Link ist dann abgeschnitten und lädt 
bei mir die Moog Grundseite bei Wikipedia.

Autor: Karl B. (gustav)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Matthias S. schrieb:
> lädt
> bei mir die Moog Grundseite bei Wikipedia.

Ja, genau das sollte er ja auch.
Ich hatte ja geschrieben:

Karl B. schrieb:
> aber leitet bei Anklicken
> tatsächlich auf die gewünschte Seite.

Nicht auf das jpg.
Vive la petit différence...


ciao
gustav

P.S.: Quellcode zeigt was Komisches. Quellcode posten ist hier aber ja 
verboten. Deswegen schenke ich mir das. Für den Mod wäre das aber evtl. 
ein Hinweis.

Autor: KASA (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Karl B. schrieb:
> Ja, genau das sollte er ja auch.

Hä? Kurze Links sind ja nicht das Problem, das Problem ist ja dass der 
lange komplette link nicht geht.

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Die Probleme mit den Links sollten jetzt behoben sein. Falls euch doch 
noch ein Link auffallen sollte der nicht funktioniert, sagt bitte 
Bescheid.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.