mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Suche Differenzdrucksensor SM5552-003-D


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Christian S. (solder)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich suche einen Differenzdrucksensor vom Typ SMI SM5552-003-D. Das Teil 
ist abgekündigt. Ich konnte auch im Internet keinen Lieferanten finden. 
Hat jemand zufällig noch so ein Teil?

Hintergrund: Der Sensor ist in meinem Lüftungsgerät Pluggit Avent P300 
eingebaut. Es ist ein Gerät der ersten Serie von 2006. 2 der Sensoren 
sitzen auf einer separaten Platine mit etwas Elektronik. Pluggit scheint 
selbst keine Ersatzteile mehr zu haben, denn die komplette Steuerung 
müsste ausgetauscht werden, was über 650€ (ohne Druckregelung) bzw. über 
800€ (mit Druckregelung) kosten würde (Ein aktuelles Neugerät P310 
kostet im Internet ab ca. 2000€.) - Ich seh' grad: Auf den neueren 
Platinen ist ein Sensirion SDP1000-L05. Die Teile sind auch nicht gerade 
billig. Entsprechend kostet die Platine 270€. Leider funktioniert die 
nicht mit meiner alten Hauptplatine.

Wenn ich mir das Datenblatt ansehe, dann scheinen nur (veränderliche) 
Widerstände im Sensor zu sein. Vielleicht könnte man das (korrekte) 
Druckgefälle einfach auch mit Ersatzwiderständen simulieren, damit die 
Lüftung wenigstens wieder läuft und nicht nur einen Fehler zeigt.

Ich habe mit den Sensoren keine Erfahrung. Vielleicht gibt's ja noch 
andere Lösungen oder Hinweise?

Autor: Christian S. (solder)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Leider hatte keiner etwas beizutragen :-(

Ich habe mal ein Foto der Steuerung gemacht. Die große Platine ist die 
Hauptplatine. Der Controller müsste U13 sein. Ich habe überlegt, dass 
man die Druckplatine einfach  mit heutigen Mitteln nachbauen könnte. 
Ohne Druckplatine geht es jedenfalls nicht, das habe ich probiert. Ich 
müsste mal messen, welche Werte an dem 4-poligen Kabel so erwartet 
werden. Es gibt +12V, GND und die beiden Werte für S1 und S2, 
wahrscheinlich analog. Da sollte sich doch was machen lassen.

Meine Idee ist, auch einen Sensirion-Sensor zu nehmen. Laut Datenblatt 
arbeiten die intern digital. Der SDP1000-L05, der auf den neuen Platinen 
ist, wandelt das Signal dann wieder analog auf den Ausgang. Ich würde 
gleich einen digitalen nehmen, z.B. SDP610. Der ist auch viel günstiger 
(klar, fehlt der D/A-Wandler) und dann mit einem kleinen Controller das 
Signal bearbeiten und am Ende analog ausgeben / umwandeln. Vorteil: Ich 
könnte die Kennlinie über die Programmierung ggf. anpassen.

Was mich wundert: Der SM5552-003-D hat 0,3psi. Das sind rund 2000Pa. Der 
Sensirion hat nur 125Pa. Da haben die wohl vom alten Sensor nur einen 
Bruchteil des Messbereiches ausgenutzt???

Autor: badsoden (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi, ich sitze auch mit einen defekten Platine. Ich hatte im Internet 
folgendes gelesen:
Auf der Sensorplatine sind 4 ansclüsse. 1 und 4 sind für 0 und 12 V
2 und 3 sind die Ausgänge für Sensor 1 und 2 und sollte in ruhestand auf 
2 V abgeregeld werden. Dafür sind die beide Potentiometer auf der 
Platine.

Bei mir hat die S2 ein falschen Wert und lässt sich nicht regeln. Ich 
werde die Komponenten mal durchmessen um zu sehen ob es ein den SMI5552 
Sensor liegt und vielleicht an einem anderen Komponent.

In Ebay.com habe ich übrigens tatsachlich Sensoren für 49 USD pro Stück 
gefunden.
Ebay-Artikel Nr. 122481618023

Am Liebsten würde ich die ganze Schaltung auf einem Raspberry Pi 
umstellen. Vielleicht hat jemand schon mal ein Verscúch gewagt. Problem 
ist wohl die Ansteuerung der Ventilatoren und Druck und Temp. Sensoren 
anzuschließen.

Gruß

Beitrag #5134822 wurde vom Autor gelöscht.
Autor: Pete K. (pete77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht findest Du bei http://www.nxp.com/ einen Ersatztypen. Die 
haben Freescale aufgekauft.

Autor: Oscar J. (badsoden)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn mann die ganze Schaltung nachbauen will brauchte mann folgendes.
Raspberry Pi3.

Dann abhängig von wie scön man es haben will:
1) Keine Druckregelung
- 1 Temp Sensor um einfrieren zu verhindern  (Aussenluft)
- 2 Steuerungen für Vent Motoren, wahrscheinlich mit Controllanschluss

2) Mit Druckregelung
- 1 Temp Sensor um einfrieren zu verhindern (Aussenluft)
- 2 Anschlüsse für den Drucksensoren
- 2 Steuerungen für Vent Motoren, wahrscheinlich mit Controllanschluss

3) Ad 2 mit Bypasssteuerung
- 1 Temp Sensor um einfrieren zu verhindern (Aussenluft)
- 2 Anschlüsse für den Drucksensoren
- 2 Steuerungen für Vent Motoren, wahrscheinlich mit Controllanschluss
- 1 Mal Bypassanschluss

Autor: Pete K. (pete77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
badsoden schrieb:
> Ich
> werde die Komponenten mal durchmessen um zu sehen ob es ein den SMI5552
> Sensor liegt und vielleicht an einem anderen Komponent.

Gute Idee :-)

Autor: Christian S. (solder)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte mir die Platine noch mal genauer angesehen und dann an die 12V 
eines Labonetzteiles angeschlossen. Dann habe ich die Ausgangsspannungen 
gemessen und auch mal vorsichtig in eine Seite des Sensors geblasen um 
zu sehen, was passiert. Da mir bekannt war, welcher Sensor abweichende 
Daten liefert, habe ich mit dem Poti für den Sensor die Spannung so 
eingestellt, dass sie bei normalem Druck für beide Sensoren den gleiche 
Wert liefert (ca. 1,1V). So wieder eingebaut. Läuft wieder.

Der vorher ausgegebene (falsche) Wert von ca. 0,8V hat bedeutet, dass 
auf der Eingangsseite weniger Druck ist, als auf der Ausgangsseite. Das 
kann aber nicht sein, wenn der Ventilator "saugt".

@Oscar: Der Preis für die Sensoren scheint ok, denn die von Sensirion 
sind auch nicht billiger. Ich würde nur die Druckplatine neu machen 
(siehe oben). Die Steuerung insgesamt neu zu machen, hatte ich auch 
überlegt. Aber man kennt nicht die genauen Parameter für Druck zu 
Drehzahl. Ich weiß nicht, ob z.B. die Druckverteilung so ist, dass immer 
mehr raus- als reingeblasen wird (damit keine warme feuchte Luft durch 
Undichtigkeiten nach draußen geht und am Übergang kondensiert und zu 
Feuchteschäden führt). Wenn man ein noch funktionierendes System hat, 
dann könnte man das mal nachmessen. Ansonsten scheint die Steuerung in 
der Tat nicht so komplex. Die Ventilatoren haben ein Relais zum 
Anschalten und offenbar einen Steuereingang für die Drehzahl und einen 
Tachoausgang(?). Der Bypassmotor ist die typische Schaltung wie bei 
einem Rollladenmotor.

Danke für den Hinweis auf die 2V. Ich hatte nur 1,1V gemessen. Geht 
momentan auch. Werde ich aber berücksichtigen, falls es wieder nicht 
geht. Als Nothilfe: Kann man die 2V einfach fest abgeben an den 
Controller? Dann wäre immerhin ein Notbetrieb möglich ohne Druckprüfung.

Autor: Oscar J. (badsoden)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi, Danke für den Hinweise. Ich versuche das auch noch mal.

Die Anlage ist so eingestellt, dass es etwas unterdruck im Haus gibt. 
Ich nehme an, aus dem Grund die du erwähnst.
Ich habe die Platine ausgebaut, werde den auf 12 anschließen und 
nochmals versuchen ob ich S2 auf 2 V einstellen kann. Vielleicht habe 
ich glück.

Die Steuerung nachbauen ist nicht so einfach. Ich glaube, dass die 
Ventilatoren fest mit 220V versorgt werden und über ein PWM Signal und 
10 V Anschluss dann geregelt werden. Das in einer Raspberry-Pi 
umzuwandern könnte etwas problematisch sein. Die Sensoren ließen sich 
schon auslesen mit Standard RB-Pi Komponenten. Die Verhältnissen zu 
Druck und Drehzahl müsste man mal bei einer bestehende Anlage auslesen. 
Im Prinzip habe ich auch noch Drehzahlwerten aus der laufenden Anlage 
aufgeschrieben und könnte damit wieder auf den alten Werten 
zurückregeln. Mit etwas Differentialmessungen könnte man dann die 
automatische Regelung auch wieder herstellen.

Trotzdem, alles zusammen relativ viel Aufwand. Lieber komplett neue 
Steuerung kaufen. Keine Fernbedienung mehr sondern nur noch ein App. 
Frage mal nach bei Pluggit.

Autor: Oscar J. (badsoden)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es läuft wieder.
Habe nur der Drucksensorplatine auf eine Laborstromversorgung mit genau 
12 V angeschlossen. Dann die Ausgänge S1 und S2 mittels die beide 
Potentiometer auf genau 2 V abgeregelt. Alles wieder montiert, 
Kalibrierung laufen lassen und jetzt läuft es wieder.

Autor: Christian S. (solder)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also mir wurde als neue Steuerung dennoch eine vom AP300 angeboten. 
Diese hatte dann auch wieder Fernbedienung. Ich weiß nicht, ob die vom 
aktuellen AP310 auch in den 300er-Geräten funktioniert. Der Aufbau (mit 
Display am Gerät) ist ja komplett anders.

Ich denke, die Sensorplatine kann man leicht mit einem AVR nachbauen, 
ggf. sogar ganz ohne. Auf den neu angebotenen sind die Sensoren von 
Sensirion drauf, habe ich gesehen. Man müsste dann lediglich das 
Ausgangssignal passend machen. Ich hatte Werte von ca. 0,5V bis ca. 
10,5V gemessen. Wenn man die analogen Sensoren von Sensirion nimmt, kann 
man direkt z.B. mit OPV auf die Spannung setzen. Ich hätte das mit einem 
digital auslesbaren Sensor und AVR mit anschließendem D/A-Wandler gelöst 
(kostet nur die Hälfte).

Für die Gesamsteuerung würde ich keinen Raspi* einsetzen. Dann lieber 
einen AVR (Arduino). Das könnte man genauso klein und kompakt bauen, wie 
es jetzt schon ist. Für eine Fernsteuerung könnte man ja einen ESP8266 
mit anschließen. Der stellt dann z.B. den Webserver und schickt die paar 
Daten per serieller an den AVR. Also ganz ähnlich, wie es mit der 
Fernbedienung ist.

Bezüglich der Ansteuerung des Motors kann ich bestätigen, dass dieser 
direkt über ein Relais mit 230V versorgt wird. Es gibt weitere Leitungen 
für die Steuerung. Da bei mir nach der Justage wieder alles ging, habe 
ich nicht nachgemessen, was dort für Signale sind. Ich vermute auch PWM 
für die Drehzahl und ein analoges oder digitales Tachosignal. Wäre aber 
auch keine Hürde für eine neu gebaute Steuerungsplatine. Ich weiß nicht, 
was das für Temperatursensoren sind (wahrscheinlich NTC oder so). Aber 
diese würde ich durch DS18B20 im Edelstahlröhrchen austauschen. Da hat 
man dann gleich ein leicht auswertbares digitales Signal.

*Ich hatte gerade wieder einen Ausfall: Benutze SDCard nur Read Only. 
Für /var einen USB-Stick. Der ist leider kaputt gegangen nach ca. 1 
Jahr. Das wär mir zu riskant. Ich habe einige Steuerungen mit AVR, die 
laufen seit Jahren.

Autor: Christian S. (solder)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oscar J. schrieb:
> Es läuft wieder.
> Habe nur der Drucksensorplatine auf eine Laborstromversorgung mit genau
> 12 V angeschlossen. Dann die Ausgänge S1 und S2 mittels die beide
> Potentiometer auf genau 2 V abgeregelt. Alles wieder montiert,
> Kalibrierung laufen lassen und jetzt läuft es wieder.

Ich vermute, dass die Sensoren einfach altern und sich der Arbeitspunkt 
verschiebt. Solange man das nachregeln kann... Man muss nur wissen, wie 
es geht. Pluggit würde natürlich lieber Geld verdienen.

Autor: Oscar J. (badsoden)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aus den Webseiten von EBM Papst leite ich ab, dass man die Vents 
entweder per PWM oder per Analogspannung (0-10V) regeln kann. Ich 
schätze, dass die PWM Schaltung präziser ist aber die Analogspannung 
sich leicht über z.B. Temperatursensoren ohne weitere Elektronik steuern 
lässt. Da der Pluggit die Drehzahlen ausgibt, vermute ich eine PWM 
Steuerung. Somit lässt sich das eigentlich gut nachbauen. Drücksensoren 
muss man einmal kalibrieren und dann regelt man die Vent Drehzahlen 
dazu. Bei Druckänderungen kann man die Filterzustand ableiten. Die 
Temperatursensoren sind auch leicht anzubinden und dann wäre es fertig. 
Das heisst, Platine mit 4 Drucksensoren, irgendein PWM Steuerung und 4 
Spannungsmessungen für Temperatur. Danach ist es Sache der SW. Klinkt 
einfach, ist aber doch viel Arbeit.

: Bearbeitet durch User
Autor: Solder (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eine neue Steuerung hätte schon ihren Reiz. So ärgert es mich, dass die 
Kalibrierung nur Montags um 10 Uhr ist. Ich stelle die Uhr schon 
absichtlich falsch, damit die Kalibrierung an einem anderen Tag läuft. 
Außerdem kann man die Lüftung nicht abschalten (also auf 0) ohne auch 
die Uhrzeit zu verlieren. Gerade im Winter ist es mit Lüftung immer viel 
zu trocken. Ich schalte die jetzt einfach ganz ab. Inzwischen 
automatisch mit FritzDect200 und im Haus verteilten Feuchtesensoren. 
Steuerung macht mein Server.

M.E. werden die Drucksensoren nur für die Filtererkennung bei der 
Kalibrierung benötigt. Evtl. auch für Vereisung des Wärmetauschers 
(während der Kalibrierung, sonst war da noch nichts vereist bei mir.) 
Denn es gibt die Steuerung auch ohne Drucksensoren. So war mein Angebot 
von Pluggit. Die nötigen Schwellwerte für die Erkennung müsste man bei 
eigener Steuerung/Firmware aus einer funktionierenden Anlage mührsam 
ermitteln.

Autor: Solder (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Noch ein Punkt: Schalte ich die Anlage hart ab im Winter, kommt beim 
Einschalten immer erst die Kalibrierung. So kann man eher nicht mal eben 
für 1h anschalten, wenn es im Bad stinkt.

Autor: Oscar J. (badsoden)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Drucksensoren halten das ausgetauschte Luftvolume konstant und geben 
die Indikation, dass die Filter verschmutzt sind.
Ausschalten im Winter würde ich nicht machen. Man kann das Volume 
runterregeln. Gerade im Winter ist der Gefahr für Schimmel durch 
Kältebrücke/übergänge hoch, deswegen wird gerade dann einen 
ausreichenden Luftaustausch erfordert.
Deswegen habe ich die Anlage nachträglich einbauen lassen.

Autor: Christian S. (solder)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jaja, die Sprüche kenne ich. Luftfeuchtigkeiten im Haus unter 40% sind 
aber ungesund und führen auch zu häufigeren Infektionen. Und mit dauernd 
eingeschalteter Lüftung selbst auf kleinster Stufe, sinkt die 
Luftfeuchtigkeit locker auf unter 20%. Da zeigt die Wetterstation sogar 
nur Lo für die Luftfeuchtigkeit innen. Schau dir mal ein hx-Diagramm an. 
Die Luftfeuchtigkeit muss draußen bei 6° schon 100% betragen, damit sich 
innen noch 40% halten. Im Winter +- ist es locker kälter, und wenn es 
doch mal so warm ist, dann ist die Luftfeuchtigkeit auch niedriger. 
Wäscheaufhängen, Luftbefeuchter etc. bringt nur ganz kurz ein paar %. 
Die Lüftung hat das in Null komma nichts wieder draußen.

Ich lasse jetzt die Lüftung bei unter 40% abschalten. Wärmebrücken gibt 
es im neuen Haus kaum, wenn, dann an den Fenstern. Da bildet sich auch 
bei extrem niedrigen Temperaturen noch Kondenswasser bei niedrigster 
Luftfeuchtigkeit. Einfach mal im hx nachschauen, bei welcher Temperatur 
Taupunkt für verschiedene Luftfeuchtigkeiten ist. Mit der Automatik sind 
wir im letzten Jahr sehr gut gefahren. Es gibt noch einen Push-Button im 
Bad, wo man die Lüftung für 1/2 oder 1h bewusst einschalten kann (falls 
sie aus war).

Autor: Christian S. (solder)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So sah das im Januar aus. Durch die Zusammenschiebung auf einen Monat 
kann man die Details nicht so gut erkennen.

Autor: Oscar J. (badsoden)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Interessanter Ausführung. Habe ich mir gemerkt. Das mit dem 6 C/100% und 
Zimmertemperatur/40% Feuchtigkeit habe ich nie so betrachtet. Ist aber 
ein valider Punkt. Ich muss aber gestehen, ich habe keine Probleme mit 
Trockener Luft gehabt bis jetzt und weil ich eine ältere Holzaufbau 
habe, habe ich mehr Angst für Schimmel als für meine Atemwegen.

Autor: Edelstein (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, auch wir haben defekte Drucksensoren, allerdings welche ohne frei 
zugängliche Potentiometer (siehe Bild). Unsere Anlage AP300 ist von 
2010. Und nur sieben Jahre später sagt mir der Hersteller, es gibt keine 
Ersatzteile mehr ... Sehr unbefriedigend! Ich frage mich, von welcher 
Lebensdauer seiner Anlagen Pluggit eigentlich ausgeht. Kann man die bei 
uns verbauten Sensoren (siehe Bild) denn auch noch einmessen? Vielleicht 
nach dem Öffnen? Ich will nichts unnötig kaputt machen. Wenn das nicht 
geht, bleibt ja nur das Ersatzkit PPS für 800 Euro (ist wohl nicht das 
von AP310). Bei solchen Preisen bin ich nun auch auf die Idee gekommen, 
ob es nicht schon Komplett-Ersatz-Steuerungen auf Raspberry-Basis gibt. 
Aber fündig bin ich bisher nicht geworden - nur auf diese Seite 
gestoßen. Also: Wenn ihr hier mehr oder andere Lösungen kennt, sagt 
bitte bescheid! Denn selbst für einen Notlauf kann man die Ventilatoren 
ja nicht einmal stumpf überbrücken ... Viele Grüße vom Edelstein!

Autor: Solder (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Diese Sensoren gibt es doch noch. Könnte man einfach austauschen. Einer 
kostet ca. 60€-80€. Ich würde aber erst mal am Anschluss nachmessen. 
Läuft die Platine noch mit 12V? Dann diese anschließen (Labornetzteil) 
und den Wert an den Ausgängen messen. Im Ruhezustand müsste die Spannung 
bei beiden Meßausgängen gleich sein. Evtl. kann man so auch den defekten 
Sensor detektieren und nur diesen ersetzen. Weitere Möglichkeit: 
Vorsichtig in die Fühlereingänge blasen bzw. saugen (evtl. Schlauch 
aufstecken) und sehen, wie sich der Meßwert ändert.

Autor: Solder (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die komplette Platine habe ich auch bei Wolf im Onlineshop gefunden. 
Sieht zumindest gleich aus:

https://www.wolf-online-shop.de/Pluggit-Drucksensor-Platine-APDP2::30130.html

Autor: Solder (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zum Thema Notlauf: Unsere Steuerung erwartet um 2V von den Sensoren. 
Wenn das bei Dir auch so ist, könnte man vielleicht einen LM317 nehmen 
und die Ausgangsspannung per Poti einstellbar auf 2V stellen und 
probieren, ob es die Steuerung nicht stört, wenn der Wert immer so 
stehen bleibt.

Soweit ich weiß, werden die Drucksensoren nur für die Erkennung des 
Filterzustands (und Vereisung des Wärmetauschers?) gebraucht. Insofern 
würde das durchaus auch ohne gehen.

Solder

Autor: Oscar J. (badsoden)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
ich habe noch die alten Sensoren wo es einen Poti gibt. Vielleicht ist 
eine unter den Drucksensoren verbaut und sieht man die nicht?

Nichtsdestotrotz, nach meiner Kenntnisstand sind die Drucksensoren dafür 
da, den Volumenstrom zu messen und somit zu regeln. Ohne diese würde man 
nur die Ventilatordrehzahl regeln.
Wenn die Ventilatoren mehr Drehzahl brauchen für den gleichen 
Druckabfall, dann sind die Filtern mehr verschmutzt.
Pluggit biettet eine vereinfachte Steuerungsplatine ohne Drucksensoren 
an, aber dann muss sich selber um die Filterzustand kümmern. Kannst den 
Service danach fragen.
Wenn mann in der Vergangenheit Drehzahl und Volumenstrom ausgelesen und 
aufgeschrieben hat, könnte man damit schon einen ungefähren Volumenstrom 
nur über Drehzahl einstellen. Aber auf gepasst, dass müsste man schon in 
der eigene Anlage gemessen haben. Jeder Anlage ist anders wegen 
unterschiedlicher Rohrverlegung.

Die gezeigte neue Sensoren sind im Netzt bestellbar. Ich würde jedoch 
erst die Spannungsversorgung (12 V) und die Sensorausgabespannung (2 V) 
messen. Messen kann man das alles an der Platinestecker. Ist die 12 Volt 
nicht vorhanden, dann würde ich die Drucksensorplatine mit einem externe 
12 V füttern und Ausgangsspannung messen. Ist diese dann 2 V dann wäre 
wahrscheinlich die Hauptplatine nicht in Ordnung.

Autor: Edelstein (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Drucksensoren habe ich dann auch noch im Netz gefunden, bestellt und 
bereits ausgetauscht. Ergebnis: Statt Error 01 (keine Kalibrierung) 
bekomme ich nun Error 04 (defekter Drucksensor) - also, schlauer bin ich 
jetzt nicht. Außer, dass noch S2 geblinkt hat - damit ist offenbar der 
Sensor am Ausgang gemeint. Nur: Der kann nicht defekt sein, weil neu. 
Nagut, dann werde ich mal durchmessen ...

Autor: Oscar J. (badsoden)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute, nach einem Jahr wieder Drucksensor Fehler. Ich habe den 
alten 2006 Durcksensoren noch. Sie Bild.
Habe den Druckplatine ausgebaut und am 12 Gemssen. S1 genau 2 V, S2 ist 
0v. Drehen am PotMeter hat kein Einfluss, es bleibt null.

Ich werde versuchen raus zu finden ob es an den Sensor liegt oder nicht 
(d.h: eine andere Komponente auf der Druckplatine defekt).

Diese Sensoren gibt es nicht mehr soweit ich weiss.

Weiss jemand, ob es eine Ersatzplatine gibt oder hat jemand es mal 
nachgebaut? Oder muss mann immer auch die Hauptplatine mitaustauschen?

Ohne angeschlossene Drucksensoren lauft die Anlage gar nicht.

Kenn jemand ein Trick um die Anlage doch zu Laufen zu bringen damit 
jedenfalls gelüftet wird?

Autor: Oscar J. (badsoden)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe die Vermutung der Sensor ist defekt.
Ich könnte mich vorstellen eine 310 Platine mit neue Sensoren ein 
zubauen aber weiss nicht ob das geht. Hat jemand damit schon mal 
Erfahrungen gemacht?

@Christian S. : hast du die alte Sensorenplatine noch und ist da 
vielleicht noch einer (von 2) drin der noch funktioniert? Ich würde die 
gerne übernehmen, rauslöten und bei mir reinlöten.

Gruß

Oscar

Autor: Christian S. (solder)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe die Platine noch, aber die werkelt nach wie vor im Gerät. 
Nachdem der Fehler auch bei mir wieder auftrat, habe ich per Poti die 
Spannung nachgestellt und dann war wieder Ruhe. Allerdings befürchte 
ich, dass es nicht lange gut geht. Im Winter, wenn die Luft feucht und 
kalt ist, wird es wohl wieder Probleme geben.

Die Platine vom 310 passt nicht. Man muss dann alles austauschen.

Vielleicht würde es funktionieren, wenn man die Spannung fest auf 2V 
einstellt? Dann hat man zwar keine Messung, aber das Gerät läuft erst 
mal.

Es haben auch schon welche das Gerät auf eine komplett eigene Steuerung 
umgebaut. Das überlege ich auch für den Fall, dass es wieder aussteigt. 
Alternative wäre, einen kompatiblen Drucksensor selbst zu bauen.

Autor: Oscar J. (badsoden)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK, Verstanden.
Es gibt analoge differential Sensoren, häufig als Hybrid (Dig/Ana). Die 
moderne Versionen haben aber 5 V als Versorgungsspannung. Angenommen die 
Empfindlichkeit ist gleich dann könnte man die über einen 
Spannungsabfall Widerstand reinlöten. Ich werde mal eine Email an MSI 
schicken um genau nach so einer Sensor zu fragen, wo man nur die 
Spannungsversorgung anpassen muss und der Rest bleibt gleich. Die 
moderne Sensoren selber kosten nicht viel.
Die Empfindlichkeit wäre schon kritisch, weil wenn unterschiedlich dann 
werden die Ventilatoren unterschiedlich angesteuert und stimmt den 
Unter- oder Überdrück im Haus nicht mehr. Kann man umgehen durch beide 
Sensoren zu ersetzen. Dann könnte man auch gleiche eine neue 
Sensorplatine löten und gleich eine vernünftige 12 auf 5 Volt Umwandler 
rein tun.
Dann sind die Zuluft udn Abluft wieder im korrekten Verhältnis. Für die 
Volumekalibrierung müsste jemand eine Tabelle erstellen. Erst alte 
Platine und Volumestrom und Drehzahl für einige Eckpunkten messen und 
dann mit neuer Platine noch einmal. Das Verhältnis zwischen neue und alt 
könnte dann ungefähr überall gelten.

Was die Homebrew Steuerungen an geht, sie sind alle ohne Drucksensor.
In Prinzip geht das. Muss selber ab und zu die Filter kontrollieren. Bei 
verstopft immer der Lufteinlass in der Außenwand und dann ist die 
Meldung schon praktisch. Ob das Luftvolume bisschen mehr oder weniger 
ist müsste nicht so kritisch sein. Aber schön ist es schon.

: Bearbeitet durch User
Autor: per48or (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So, nun ich auch bei meiner Avent P300 nach ca 12 Jahren auch ein 
Drucksensor (S2) komplett ausgefallen. Hab ihn nachgemessen, an der 
internen Messbrücke liegt ein starker Offset an, Totalschaden.
Da noch ein Sensor funktioniert hab ich mal die Skalierung mittels 
Druckkalibrator ermittelt, siehe Bild.

Ich habe noch einige Sensoren vom Typ SDP510-500Pa (Sensirion, 
I2C-Schnittstelle) rumliegen. Ich werd mal versuchen mit nem 
ArduinoProMini eine passende Schaltung zu entwerfen, evtl mit ner 
Platine. Hat da noch jemand Interesse?

BTW, meine Anlage läuft inzwischen im manuellen Betrieb weiter. Einfach 
an der Hauptplatine den Geläsesignalstecker abziehen und an diesen 
zwischen 10V und PWM/Signal für beide Ventis je nach gewünschter 
Drehzahl ca. 100k- bis 470k-Widerstände einstecken :-)

Autor: Sven Just (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

wir haben mit mehreren Mitstreitern die Steuerung der Pluggit 
Lüftungsanlage (AP300, AP450) durch eine Eigenentwicklung auf Basis 
eines Arduino Mega, LAN Shield und Displays abgelöst. Die Steuerung 
enthält aktuell noch keine Differenzdrucksensoren, diese sind aber 
ergänzbar.

Alle Infos, die Software und die Platinen sind auf Github zu finden: 
https://github.com/svenjust/room-ventilation-system

Diskussion zur Software: 
https://forum.fhem.de/index.php/topic,83242.0.html
Diskussion zur Hardware: 
https://forum.fhem.de/index.php/topic,83025.0.html

VG Sven

Autor: Horst M. (horst_m713)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
SO nun hat es auch mich erwischt.
Meine P300 steigt nach 14 Jahren mit 04 aus. Der S2 Drucksensor macht 
schlapp.
Er funktioniert noch für die Kalibrierung, steigt dann aber nach 10-300 
Minuten aus und fällt am Ausgang auf 0V. S1 läuft hervorragend.
Ich habe die Sensoren auch mal getauscht und damit wandert der Fehler 
nach S1. Die Ausgänge einfach mit 2V belegen hat auch nicht geholfen, 
dann kann die Anlage nicht Kalibrieren und läuft auf Fehler 02.
Pluggit würde das dann mit einem Umbau für €700 fixen. Da ist es doch 
fast besser die ganze Anlage auszutauschen.

Hat vielleicht jemand der seine P300 umgebaut hat noch einen heilen 
Sensor den er min verkaufen würde?

Oder hat jemand einen Vergleichstypen ausfindig machen können?

Vielen Dank für eure Unterstützung.
Gruß Hodde

Autor: Daniel F. (per48or)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie ich oben geschrieben habe entwickle ich grad Ersatzplatinen, das 
Layout ist schon fast fertig. Ich denke Ende August hab ich welche 
fertig.
Die sind dann komplett austauschbar und steckerfertig, Kostenpunkt 
komplett ca 150,-
Die Platinen kann ich dann auch einzeln anbieten für alle Bastler :-)
Als überbrückung kannst du die Ventis mittels Widerstand (siehe oben) 
manuell betrieben.
Wenn die Entwicklung abgeschlossen ist könntest du auch meinen noch 
funktionierenden S1 haben.

Autor: Horst M. (horst_m713)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Daniel,
ich hatte ja noch einen Funken Hoffnung, denn bei glo24 sind die Teile 
noch im Shop und auf Nachfrage auch noch lieferbar. Als ich dann 
bestellt habe waren die dann doch nicht mehr verfügbar.
Ich würde es gerne erst mal mit deinem S1 versuchen, dann als zweite 
deine neue Steuerung.
Wie sieht denn dein Timing aus?
Bevor ich die 700€ für den Umbau von Pluggit latze werde ich eine neue 
Anlage anschaffen, da ich auch gerne einen Sommerbypass hätte.

Hat sich vielleicht jemand hier im Forum schon mit einer Alternative zum 
P300 beschäftigt?

Es muss nicht Pluggit sein, aber leise und Energiesparend mit Bypass.

Gruß
Hodde

Autor: Daniel F. (per48or)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab mein Projekt auf einen neuen Thread ausgelagert, da halte ich 
euch auf dem laufenden :-)
Beitrag "Eigenentwicklung Ersatzplatine Drucksensorboard für Pluggit"

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.