mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Operationsverstärker (OPV) wird heiß als Summierer


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Lukas M. (lukastbt)
Datum:
Angehängte Dateien:

Bewertung
-3 lesenswert
nicht lesenswert
Hallo,

ich habe einen OPV (siehe Datenblatt). Dieser wird mit einer 
Versorgungsspannung von +12V und -12V (wie im Datenblatt unter 'Input 
Voltage Range') zu finden ist. Damit ich diese Spannung habe, verwende 
ich einen DC/DC Wandler (siehe Datenblatt). Da ich mehrere OPV mit der 
selben Spannung versorge, habe ich festgestellt, dass nur die Summierer 
sehr heiß werden. Dagegen der Impedanzwandler hat eine normale 
Betriebstemperatur.
Es macht auch keinen Unterschied, ob ich den -Eingang am Summierer 
beschalte oder nicht.

Deshalb bin ich zur Tendenz gekommen, dass etwas an dem OPV nicht passt 
(wurde auch schon getauscht, um einen Defekt auszuschließen). 
Stützkondensatoren sind ebenfalls von +12V auf GND und von -12V auf GND 
geschalten (100nF).

Wenn ich den TL081 als Summierer beschalte (selbe Spannungsquelle), 
funktioniert es problemlos.

Autor: karadur (Gast)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Schaltung !

Autor: Jörg W. (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
4 lesenswert
nicht lesenswert
Note 2: Differential inputs of ±10V are appropriate for transient operation
only, such as during slewing. Large, sustained differential inputs will cause
excessive power dissipation and may damage the part. See Input
Considerations in the Applications Information section of this data sheet
for more details.

Ist das vielleicht irgendwie dein Problem?

Autor: MaWin (Gast)
Datum:

Bewertung
3 lesenswert
nicht lesenswert
Lukas M. schrieb:
> Deshalb bin ich zur Tendenz gekommen, dass etwas an dem OPV nicht passt

Nö.

Etwas passt bei deinem Aufbau nicht.

Einen 600V/us OpAmp blockt man nicht mit 100nF ab.

Da spielt ein hochfrequenztauglicher Aufbau eine wesentliche Rolle.

Deiner schwingt.

Ein TL081 ist natürlich viel gutmütiger.

Autor: Sven S. (schrecklicher_sven)
Datum:

Bewertung
-2 lesenswert
nicht lesenswert
MaWin schrieb:
> Deiner schwingt.


Davon sollte er aber nicht heiß werden.
Ich bin dafür, daß die Spannung zwischen den Eingängen zu hoch ist. Dem 
TL081 macht das nichts aus.

Autor: hinz (Gast)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Sven S. schrieb:
> MaWin schrieb:
>> Deiner schwingt.
>
> Davon sollte er aber nicht heiß werden.

Doch, und wie!

Autor: Dieter (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Vielleicht heute auch im EC mit Klimaanlagenproblemen? Dann liegt es an 
der Umgebungstemperatur.

Hast Du schon den Stromverbrauch der Problem OP gemessen?

Autor: OpvPapa (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Ein richtig beschalteter Opv in einer nicht übersteuerten Schaltung 
sollte doch die Differenz zwischen seinen Eingangspins auf praktisch 
Null ausregeln. Am Besten mit Zweikanaloszi ansehen.

Autor: Lukas M. (lukastbt)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sven S. schrieb:
> MaWin schrieb:
>> Deiner schwingt.
>
>
> Davon sollte er aber nicht heiß werden.
> Ich bin dafür, daß die Spannung zwischen den Eingängen zu hoch ist. Dem
> TL081 macht das nichts aus.

Die Frage ist doch, warum soll es an der Spannung liegen, wenn der 
gleiche OPV (als Impedanzwandler geschalten) mit der selben Spannung 
nicht heiß wird?

Ich hab auch schon versucht das mit einer geringeren Spannung zu 
versorgen, jedoch ohne Erfolg.

Mit einem anderen Stützkondensator werde ich es mal versuchen, wie es 
MaWin beschrieben hat.

Autor: Christian S. (roehrenvorheizer)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Male doch mal bitte die Schaltung hin. Notfalls mit dem Fuß oder dem 
Bauchnabel als Hilfsmittel.

MfG

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und ein Foto vom Aufbau von oben und von unten ...

Autor: Lukas M. (lukastbt)
Datum:
Angehängte Dateien:

Bewertung
-3 lesenswert
nicht lesenswert
Christian S. schrieb:
> Male doch mal bitte die Schaltung hin. Notfalls mit dem Fuß oder dem
> Bauchnabel als Hilfsmittel.
>
> MfG

Hab ich ihm Anhang. Man siehe links den Impedanzwandler und rechts einen 
Summierer. Die weiteren Summierer sind jetzt erstmal relativ, da schon 
dieser OPV allein heiß geworden ist.
DER WIRD SOGAR HEIß WENN KEIN Mono Poti angeschlossen ist.

VG Lukas

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zumindest der IC2 hat keine Gleichstrompfade an seinen inv. Eingängen. 
Da kann natürlich nix werden - ob er deswegen heis werden muß, sei mal 
dahingestellt ....

Autor: Georg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sven S. schrieb:
> MaWin schrieb:
>> Deiner schwingt.
>
> Davon sollte er aber nicht heiß werden.

Aber sehr wohl tut er das. Ich hatte das Problem bei einem 
Video-Verstärker (ist auch nur ein schneller OpAmp), der extrem 
empfindlich auf Kapazität an den Eingängen reagierte* und wild schwang, 
auch ohne Signal - dabei wurde er so heiss dass man ihn nicht anfassen 
konnte.

* Problem war die GND-Fläche - im Datenblatt stand auch, dass die im 
Bereich der Eingänge ausgespart werden muss. Einer der Fälle, warum 
unqualifiziertes Fluten eine dumme Idee ist.

Georg

Autor: Thomas Z. (Firma: Unaffiliated) (usbman)
Datum:

Bewertung
3 lesenswert
nicht lesenswert
Naja was du da zeigst ist bestenfalls ein Verdrahtungsplan. Glaubst du 
ernsthaft dass man da was erkennen kann? Bei so einem Plan wirst du wohl 
selbst nach dem Fehler suchen müssen

Thomas

Autor: Udo S. (urschmitt)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lukas M. schrieb:
> KEIN Mono Poti

Ist das eine Audio Anwendung?

Autor: Lukas M. (lukastbt)
Datum:

Bewertung
-2 lesenswert
nicht lesenswert
Jens G. schrieb:
> Zumindest der IC2 hat keine Gleichstrompfade an seinen inv. Eingängen.
> Da kann natürlich nix werden - ob er deswegen heis werden muß, sei mal
> dahingestellt ....

Achso meinst du wegen dem Kondensator?
Es kommt am Eingang sowieso kein Gleichspannungssignal rein...
Aber mein Signal am Eingang wird auch nicht größer als +/-12V.
Ob am Eingang ein Signal anliegt oder nicht macht auch kein Unterschied, 
der wird trotzdem heiß.

Autor: Lukas M. (lukastbt)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Udo S. schrieb:
> Lukas M. schrieb:
>> KEIN Mono Poti
>
> Ist das eine Audio Anwendung?

ja ganz genau, es soll über die Potis die mittleren und noch die tiefen 
Töne geregelt werden können.

Autor: Jens G. (jensig)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Lukas M. (lukastbt)

>Achso meinst du wegen dem Kondensator?
>Es kommt am Eingang sowieso kein Gleichspannungssignal rein...

Ist doch egal - der OPV braucht einen Arbeitspunkt, um den herum er 
arbeiten soll, sonst sucht der sich irgendeinen, den ihn seine Eingänge 
vorgeben, und er ist am Anschlag, oder irgendwo ...
Auserdem sehe ich keinerlei Gegenkopplung am IC2, und Abblock-Cs hast Du 
offensichtlich auch keinerlei unmittelbar am IC.
Auch sehe ich - tja, nicht so richtig durch in Deinem "Plan". Dieser 
Plan ist ein Graus, denn wenn man schon mit OPV herumoperiert, dann malt 
man die als Dreiecke, so wie überall, sonst wird einem schwindlig, wenn 
man erst ins DB des OPV reinschauen muß, und man dann auch noch den 
Signalfluß erkennen soll.

: Bearbeitet durch User
Autor: Lothar M. (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Lukas M. schrieb:
> Christian S. schrieb:
>> bitte die Schaltung
> Hab ich ihm Anhang
Wenn ich so verbaut wäre, würde ich auch schwingen. Sieh dir mal andere, 
schön leserliche Schaltpläne an, und überleg dir, warum die so schön 
lesbar sind. Mach es dann genauso.

Und bitte auch noch ein Foto vom Aufbau deines Oszillators. Hast du 
zum Messen ein Oszilloskop zur Hand?

Jens G. schrieb:
> Zumindest der IC2 hat keine Gleichstrompfade an seinen inv. Eingängen.
Sehe ich auch so. Leider ist das Ganze ab dann ein wildes Suchspiel. Und 
man muss sich die dahinterstehende Schaltung irgendwie im Kopf 
vorstellen. Das ist echt umständlich. Mir scheint, das Ganze ist eine 
Art Klangregelung...

EDIT: zu lange in dem grausigen Plan herumgesucht...  ;-)

Lukas M. schrieb:
> ja ganz genau, es soll über die Potis die mittleren und noch die tiefen
> Töne geregelt werden können.
Worauf basiert denn deine Schaltung?

: Bearbeitet durch Moderator
Autor: Stefanus F. (Firma: Äppel) (stefanus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mir ist auch schon mehrmals passiert, dass Operationsverstärker, 
Lautsprecherendstufen und Spannunsgregler ohne Last heiß wurden. Die 
Ursache war immer, dass sie mit einer sehr hohen Frequenz (>100kHz) 
schwungen (schwingten, schwangen - wie schreibt man das? Ich hasse 
deutsch.)

: Bearbeitet durch User
Autor: Lukas M. (lukastbt)
Datum:
Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Hier mal ein übersichtlicher Aufbau, allerdings nur ein OPV und hoffe 
das lässt sich besser erkennen

Autor: Erwin D. (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Lukas M. schrieb:
> Hier mal ein übersichtlicher Aufbau, allerdings nur ein OPV und
> hoffe
> das lässt sich besser erkennen

Ja, in der Tat kann man hier besser erkennen, daß die OPV-Eingänge kein 
definiertes Potential haben. Das heißt, sie floaten in der Gegend herum 
und schwingen mit Sicherheit

Autor: Stefanus F. (Firma: Äppel) (stefanus)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Was mir da sofort auffällt: Die Gegenkoppelung geht durch C1 und C2. Bei 
unendlich niedriger Frequenz hast du also einen unendlich hohen 
Verstärkungsfaktor. Das kann so nicht gewollt sein, oder doch?

Außerdem ist mir nicht klar, wie du an U3 Eingang "+" und U4 Eingang "-" 
sorgst für einen definierten DC Ruhepegel sorgst.

Nachtrag: Erwin hat mich überholt, während ich das DB kontrollierte.

: Bearbeitet durch User
Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich würde dem U3 einfach paar 10k (47k?) gegen Masse spendieren. Und U4 
einen Rückkopplungspfad geben, z.B. 1M vom Ausgang zum -Eingang.
Ob das aber mit dem Heißwerden zu tun hat, kann ich nicht sagen. Die 
Poties sind vermutlich mit einem Drahtverhau angeschlossen, also schöne 
lange Strippen mit viel parasitärem L und C in der Rückkopplungsleitung, 
was dem LT1358 möglicherweise ein gefundenes Fressen fürs Schwingen 
darstellen könnte.

Autor: Thomas Z. (Firma: Unaffiliated) (usbman)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Lukas M. (lukastbt)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jens G. schrieb:
> Ob das aber mit dem Heißwerden zu tun hat, kann ich nicht sagen. Die
> Poties sind vermutlich mit einem Drahtverhau angeschlossen, also schöne
> lange Strippen mit viel parasitärem L und C in der Rückkopplungsleitung,
> was dem LT1358 möglicherweise ein gefundenes Fressen fürs Schwingen
> darstellen könnte.

Die Potis sind mit einer geschirmten Leitung (ca. 10-15cm) verbunden. 
Selbst wenn ich die Potis nicht anschließe, was ja auch die Rückkopplung 
komplett wegnimmt, dann wird der OPV auch schon heiß.

Autor: Lukas M. (lukastbt)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lukas M. schrieb:
> Hier mal ein übersichtlicher Aufbau, allerdings nur ein OPV und hoffe
> das lässt sich besser erkennen

Noch zur Erklärung: Der U3 (Impedanzwandler) wird nicht heiß in der 
Praxis, es ist nur der U4 der heiß wird.

Die Rückkopplung bei U4 war so gedacht, um einen Equalizer hin zu 
bekommen. Ein Prototyp mit dem TL081 (nur U4) hat bewiesen, dass es 
sogar funktioniert.

Autor: Achim S. (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Lukas M. schrieb:
> Noch zur Erklärung: Der U3 (Impedanzwandler) wird nicht heiß in der
> Praxis, es ist nur der U4 der heiß wird.

Dann nochmal wiederholt, was schon beschrieben wurde: U3 ist korrekt als 
Impedanzwandler beschalten - er kann also funktionieren.

U4 ist nicht korrekt als Summierer beschalten. Er kann nicht 
funktionieren. Und du brauchst dich nicht mit der Spurensuche zu 
beschäftigen, warum ein nicht funktionierende Schaltung heiß wird. Mach 
stattdessen eine funktionierende Schaltung daraus.

Lukas M. schrieb:
> Die Rückkopplung bei U4 war so gedacht, um einen Equalizer hin zu
> bekommen. Ein Prototyp mit dem TL081 (nur U4) hat bewiesen, dass es
> sogar funktioniert.

Nein, hat es nicht. Es hat bestenfalls bewiesen, dass es mit TL081 
zufällig mal funktionieren kann (oder zumindest nicht heiß wird). Der 
input bias current des TL081 ist Größenordnungen kleiner als beim 
LT1358. Damit kann es beim TL081 mal ein paar Sekunden länger so 
aussehen, als ob die Schaltung funktionieren würde. Aber trotzdem bleibt 
die Schaltung falsch.

Sobald du eine richtige Schaltung hast lohnt es sich zu suchen, falls 
immer noch was heiß wird. Jetzt lohnt sich diese Suche nicht.

Autor: MaWin (Gast)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Lukas M. schrieb:
> Hier mal ein übersichtlicher Aufbau, allerdings nur ein OPV und
> hoffe das lässt sich besser erkennen

Das ist kein Aufbau, sondern ein Schaltplan.

Grob laienhaft und fehlerhaft.

U3 noninverting input hängt in der Luft, U4 inverting input ebenfalls.

Dir fehlt es an Grundlagenverständnis über OpAmps.

Da es sich offenbar um eine Audio-Klangregler-Schaltung handelt, stellt 
sich die Frage, wieso man einen für dich im Aufbau nicht beherrschbaren 
600V/us fast setteling DAC Frontend-Verstärker wie LT1359 einsetzt statt 
dem TL071 (mit dem die Schaltug mangeld DC Pfad zu den Eingängen 
übrigens auch nicht wirklich funktioniert) oder NE5532 oder wenn es sein 
muss OPA1611.

Autor: Stefanus F. (Firma: Äppel) (stefanus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lukas M. schrieb:
> Selbst wenn ich die Potis nicht anschließe, was ja auch die Rückkopplung
> komplett wegnimmt, dann wird der OPV auch schon heiß.

Dann hängen die negativen Eingänge in der Luft. In diesem Zustand ist 
alles möglich.

Autor: Stefanus F. (Firma: Äppel) (stefanus)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Achim S. schrieb:
> Dann nochmal wiederholt, was schon beschrieben wurde: U3 ist korrekt als
> Impedanzwandler beschalten - er kann also funktionieren.

Nein, er ist auch falsch beschaltet. Sein positiver Eingang hat keinen 
definierten Ruhepegel. Er ist nur AC gekoppelt (durch den Kondensator).

Autor: Achim S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stefanus F. schrieb:
> Nein, er ist auch falsch beschaltet.

Ja, ist in Ordnung. Nachdem Mawin schon zuvor darauf hingewiesen hatte, 
sehe ich es auch.

Ich korrigiere mich: bei U3 ist zwar die Rückkopplung korrekt, aber die 
Gesamtschaltung kann trotzdem nicht als Impedanzwandler funktionieren. 
(In der ersten Skizze des TO war dieser falsche Schaltungsteil nicht 
eingezeichnet).

Autor: Andreas S. (Firma: Schweigstill IT) (schweigstill) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und vermutlich ist die Schaltung auch noch auf einem Steckbrett 
aufgebaut? Und die Abblockkondensatoren befinden sich irgendwo, aber 
nicht elektrisch in der Nähe der Versorgungsspannungen?

Autor: Lukas M. (lukastbt)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas S. schrieb:
> Und vermutlich ist die Schaltung auch noch auf einem Steckbrett
> aufgebaut? Und die Abblockkondensatoren befinden sich irgendwo, aber
> nicht elektrisch in der Nähe der Versorgungsspannungen?

Nein ich habe den Prototyp mit dem TL081 auf einer selbst gefrästen LP 
getestet und mein ganzes Layout bestellt.
Die Stützkondensatoren befinden sich direkt an den OPVs.

So wie ich das hier verstanden habe, muss ich meiner Rückkopplung an U4 
einen definierten Ruhepegel geben? Z.B. mit einem hochohmigen 
Widerstand?

Autor: Stefanus F. (Firma: Äppel) (stefanus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lukas M. schrieb:
> Z.B. mit einem hochohmigen Widerstand?

Ja, und zwar bei U3 von In+ nach COM und bei U4 von In- nach OUT.

Aber du solltest vor allem bei U4 nicht einfach irgendeinen möglichst 
hochohmigen Widerstand verwenden, sonst wird er niedrige Frequenzen sehr 
hoch verstärken, was sicher nicht gewollt ist. Normalerweise will man 
Frequenzen unter 20HZ unterdrücken.

: Bearbeitet durch User
Autor: Udo S. (urschmitt)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
kann mir mal jemand erklären warum man für eine Audiomischer/Equalizer 
einen OP braucht der 600V/µs Slew Rate hat?

Das ist meines Erachtens so sinnvoll, als wollte man für einen E-Scooter 
eine 30kW Drehstrommaschine benutzen.

Autor: Lukas M. (lukastbt)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stefanus F. schrieb:
> Lukas M. schrieb:
>> Z.B. mit einem hochohmigen Widerstand?
>
> Ja, und zwar bei U3 von In+ nach COM und bei U4 von In- nach OUT.
>
> Aber du solltest vor allem bei U4 nicht einfach irgendeinen möglichst
> hochohmigen Widerstand verwenden, sonst wird er niedrige Frequenzen sehr
> hoch verstärken, was sicher nicht gewollt ist. Normalerweise will man
> Frequenzen unter 20HZ unterdrücken.

Danke und ich wäre auch nicht über 10kOhm gegangen... Ich möchte ja 
schließlich keine zu große Verstärkung. Mit der Frequenz gibt es dafür 
eine Möglichkeit dies zu berechnen, dass es bei 20Hz unterdrückt oder 
muss ich das nach meinem OPV über einen Hochpass machen?

Autor: Andreas S. (Firma: Schweigstill IT) (schweigstill) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lukas M. schrieb:
> Danke und ich wäre auch nicht über 10kOhm gegangen... Ich möchte ja
> schließlich keine zu große Verstärkung. Mit der Frequenz gibt es dafür
> eine Möglichkeit dies zu berechnen, dass es bei 20Hz unterdrückt oder
> muss ich das nach meinem OPV über einen Hochpass machen?

C6 stellt man dem neu anzubringenden Widerstand doch schon einen 
Hochpass erster Ordnung dar. Ob dieser für eine Anwendung steil genug 
ist, können wir doch nicht wissen. Und die Grenzfrequenz muss Du 
natürlich auch passend berechnen. Weiterhin hängt es auch von der 
Signalquelle ab, ob die nachfolgende Stufe, d.h. Deine Schaltung, solch 
eine frequenzabhängige Eingangsimpedanz aufweisen darf.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.