Forum: Analoge Elektronik und Schaltungstechnik Wo kommt das "brummen" her? Wie "filtern" ?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Christop (Gast)


Angehängte Dateien:

Bewertung
-4 lesenswert
nicht lesenswert
Hallo,

Ich habe ein paar Schaltungen die so eigentlich Super funktionieren. 
Bisher (viele verschiedene Anwendungsbereiche) hatte ich keinerleit 
Problem...

Bis jetzt..

Also.. Ich habe ein Meanwell SNT. 12V 350Watt

Die Versorgung geht von hier einmal zu einem PCB auf dem ein LM2596 zum 
Einsatz kommt. Dieser Versorgt einen Raspberry. Klappt wunderbar.

Und zum anderen zu einer Platine mit einem TDA7375. (12V)

Vom Raspberry geht nur (Klinke oder DAC, beides probiert) das 
Audiosignal zum TDA7375.

Bis etwa Lautstärke 30/35.. hat man ein extremes Brummen/Störgeräusch im 
Audiosignal.

Danach ist die Audioausgabe lauter als das "Brummen".

Ich habe dann gelesen und gelesen über alles mögliche.

Man soll "die gleiche" Steckdose nehmen... Hhhhmmmm.. Ich nutze ja nur 
eine.. weil nur ein Netzteil.

Also weiter recherchiert...

Mantelstromfilter...

Ebenfalls keine Besserung.


Zu guter letzt.. und weil ich nichts mehr gefunden habe.. habe ich 
einfach.. ich weiss auch nicht wie mir diese Idee kam.. ein zweites 
Netzteil genommen und den LM2596, also den Raspberry an SNT 1 und den 
TDA an SNT 2.

Und siehe da... Kein Brummen nichts mehr... "Sauberer" Audiostream...

Wieso habe ich mit zwei Netzteilen nun KEIN Brummen...

Und mit einem Netzteile eine .... Erd- Masse- what ever Schleife...

Und vor allem. Wie kriege ich diese beseitigt?

: Verschoben durch Moderator
von Jim M. (turboj)


Bewertung
0 lesenswert
nicht lesenswert
Christop schrieb:
> Wieso habe ich mit zwei Netzteilen nun KEIN Brummen...

Weil das Brummen auf den 12V (und GND) durch die RPi Versorgung kam. Der 
zieht halt nicht "Gleichstrom" sondern hat einen stark schwankenden 
Strombedarf, den das NT irgendwie ausregeln muss.

Offenbar ist der Audio Teil nicht gut genug entkoppelt.

von Sebastian S. (amateur)


Bewertung
-2 lesenswert
nicht lesenswert
Netzstecke anders herum einstecken.
Gehäuse öffnen und die dicke Fliege endlich rauslassen.
Fehlerhaftes oder unzureichendes Netzteil.

von Christop (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Und was mache ich nun dagegen?

von Karl B. (gustav)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Christop schrieb:
> Und was mache ich nun dagegen?

Hi,
Brümmer Schaltungstechnik Seite 226.
Jede Baugruppe bekommt ihr eigenes Netzteil spendiert.
Und eine "saubere" Zentral-Erdung.
Quelle:
ISBN 3-8023-0610-4

ciao
gustav

: Bearbeitet durch User
von Sven S. (schrecklicher_sven)


Bewertung
0 lesenswert
nicht lesenswert
Christop schrieb:
> Und mit einem Netzteile eine .... Erd- Masse- what ever Schleife...

Ja genau. An irgendeiner Stelle gehen Betriebsstrom und Signal über die 
gleiche Masseleitung. Finde diese Stelle und überlege Dir, wie Du es 
besser machen könntest. Eine Möglichkeit hast Du schon gefunden.

von Stefan ⛄ F. (stefanus)


Bewertung
1 lesenswert
nicht lesenswert
Das Problem nennt man "Masseschleife". Wenn man nur die GND Leitung 
betrachtet, hast du einen Ringförmigen Verlauf in deinem Aufbau. Den 
muss man unterbrechen.

In deinem Fall wird wohl ein magnetischer Übertrager in der Audioleitung 
die einfachste Lösung sein. So etwas bekommt man relativ günstig im KFZ 
Zubehör, weil man das dort zwischen Autoradio und externen Endstufen 
verwendet.

von Ingo K. (ingo_k2)


Bewertung
0 lesenswert
nicht lesenswert
Stefan ⛄ F. schrieb:
> So etwas bekommt man relativ günstig im KFZ
> Zubehör, weil man das dort zwischen Autoradio und externen Endstufen
> verwendet.

https://www.reichelt.de/nf-entstoerfilter-masseentkoppler-1-1-kfz-nf-filter-p48085.html?search=kfz+nf+f

von Veit D. (devil-elec)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

es sollte ausreichend sein wenn die Spannungsversorgung zu allen Geräten 
vom Netzteil aus gesehen Sternförmig verläuft. Die Masse im/vom 
Audiokabel sollte dann nur einseitig angeschlossen werden. Sollte doch 
funktionieren?
Oder du machst die Audioverbindung S/PDIF optisch, falls möglich.

von Percy N. (vox_bovi)


Bewertung
-2 lesenswert
nicht lesenswert
Hast Du schon probiert, den Schirm des Klinkenkabels nur einseitig 
anzuschließen?

von Günni (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Wenn alles nichts genützt hat und die Masseschleife nach wie vor stört, 
ist die brutale Lösung das Einfügen eines Notch-Filters (mit 50 Hz 
Sperrfrequenz) in den Signalweg. Dann sind zwar auch Töne mit 50 Hz 
verschwunden, aber das Brummen ist deutlich reduziert. Das Filter 
möglichst schmalbandig machen, damit die Einbußen im "echten" Signal 
gering bleiben.

von Günni (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Die Schaltung, die als "Basis Zwilling-T Kerbfilter Design" in
https://www.electronics-tutorials.ws/de/filtern/bandsperrfilter.html 
beschrieben ist, hat eine gute Dämpfung und eine sehr geringe 
Bandbreite. Für die Anwendung der Brummvermeidung ist diese Schaltung 
nach meiner Meinung optimal.

von Jacko (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ja, ein Kerbfilter kann die Grundwelle 50 Hz vom Netzbrumm
gut ausbügeln.

Leider nur die 50 Hz. WENN Netzbrumm durchkommt, kommen aber auch
seine Oberwellen: 100 Hz, 150 Hz, 200 Hz, ... 550 Hz und mehr durch.
Die sind zwar zunehmend schwächer, ABER bis etwa 3000 Hz steigt
auch die Empfindlichkeit unseres Hörsinns.

Somit ist es fast immer viel besser, die Einstreuung zu vermeiden!
Masse-Sternpunkt usw...

von Old P. (Firma: nix) (old-papa)


Bewertung
0 lesenswert
nicht lesenswert
In Deinem ersten Bild lass GND der "Tonleitung" am Raspi weg. Die 
Abschirmung derselben nur am Endverstärker "erden"
Ergebnis: kein Brummen mehr.

Old-Papa

von Georg A. (georga)


Bewertung
0 lesenswert
nicht lesenswert
Old P. schrieb:
> Ergebnis: kein Brummen mehr.

Je nach Abstand vermutlich aber unzählige andere lustige Nebengeräusche 
;)

Der Trenntrafo von oben wäre schon das Beste. Wenn das nicht geht, wird 
das Brummen auch weniger, wenn man GND zwischen Raspi und Amp nicht nur 
über so dünnes Audiokabel führt, sondern zusätzlich noch über eine dicke 
(1.5/2.5qmm) Leitung.

von Percy N. (vox_bovi)


Bewertung
0 lesenswert
nicht lesenswert
Old P. schrieb:
> Die Abschirmung derselben nur am Endverstärker "erden"

Wow! Du hast nicht einmal eine Stunde gebraucht, um meinen Vorschlag 
auszuformulieren. Respekt!

von Old P. (Firma: nix) (old-papa)


Bewertung
1 lesenswert
nicht lesenswert
Percy N. schrieb:
> Old P. schrieb:
>> Die Abschirmung derselben nur am Endverstärker "erden"
>
> Wow! Du hast nicht einmal eine Stunde gebraucht, um meinen Vorschlag
> auszuformulieren. Respekt!

Nö, schlicht übersehen....

Aber wenn zwei das sagen glaubt es hoffentlich der erste ;-)
Und ja, wenn die Baugruppen ein paar Meter auseinander stehen, dann 
bekommt man andere Probleme. Dann werde sie aber sehr wahrscheinlich 
nicht aus dem gleichen Netzteil versorgt.

So richtig lustig wird das erst bei Bühnenverkabelungen. Natürlich 
fliegende und jede Band bringt zusätzlich noch eigenes Zeug mit ("hat 
doch gerstern noch funktioniert..."). Da möchte man manchmal auswandern! 
Oder man klemmt in höchster Not schonmal den "Gelb-grünen" irgendwo 
ab.... (nein, ich "natürlich nie") ;-)

Old-Papa

von Karl B. (gustav)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
zwei Dinge.
Einmal NF-Spannung vom Ausgang eines Geräts zum Eingang eines anderen.
Die NF-Spannung braucht zwei Pole. Ein Pol in der Luft reicht nicht.
Also: Ein geschlossener Stromkreis ist nötig von der Quelle zur Senke.
Die Ausführung der NF-Leitungen erfolgt nun einmal asymmetrisch, zum 
andern symmetrisch.
Wobei beim asymmetrischen Weg meistens die Abschirmung den Rückleiter 
darstellt.
Wenn jetzt irgendein anderer Strom noch über den Schirm läuft, geht der 
mit in das Signal ein. Das ist dann besonders stark, wenn es sich um 
empfindliche Eingangsschaltungen handelt oder um hochverstärkende 
Vorverstärker.
Da reichen schon ein paar µV aus, um mit hörbar zu werden.
Dann Masseschleife:
Das ist vom Prinzip her was ganz anderes, wird aber mit obiger Sache oft 
in einen Topf geworfen, weil die Effekte und Ursachen kombiniert 
auftreten können.
Bei der Masseschleife entsteht eine Induktionsschleife, wie eine 
Spulenwindung, die das reininduzierte Feld aufnimmt. Meistens stammt das 
von Netztrafos.
Beides zu vermeiden gilt es.
Doppelte GND-Verbindung vermeiden, unterbricht Masseschleifen.

Old P. schrieb:
> Abschirmung derselben nur am Endverstärker "erden"

Aber wo bekommt jetzt die Rückleitung ihren Anschluss?
Von irgendeiner anderen Verbindung. Das kann genauso problematisch 
werden.

Old P. schrieb:
> Und ja, wenn die Baugruppen ein paar Meter auseinander stehen, dann
> bekommt man andere Probleme.

Stefan ⛄ F. schrieb:
> In deinem Fall wird wohl ein magnetischer Übertrager in der Audioleitung
> die einfachste Lösung sein.
Der Vorschlag mit dem galvanischen Trennen ist auch nicht überall 
realisierbar. Der Frequenzgang wird beeinflusst und die Dinger, die ich 
kenne, können relativ leicht in die Sättigung gefahren werden.


Günni schrieb:
> ist die brutale Lösung das Einfügen eines Notch-Filters (mit 50 Hz
> Sperrfrequenz) in den Signalweg.
Die Sache mit dem Brummfilter kann jeder mit einem halbwegs geeigneten 
WAV-Editor mal ausprobieren und wird feststellen, dass das Mumpitz ist.
Man hört immer noch ein Störgeräusch. Dann ist Netz 50 Hz nicht immer 50 
Hz. Wenn schon muss man also breitbandiger auslegen. 45-60 Hz 
vielleicht.
Und das fehlt ja dann im Original NF Signal. Vielleicht wichtige Töne im 
Spektrum. Höchstens beim Digitalisieren von alten Bandaufnahmen, wo man 
das Brummen nicht an der Quelle selbst mehr beseitigen kann, benutze ich 
das Feature. Dann bekommt die ganze Sache unter Umständen noch ein 
unangenehmes Einschwingverhalten. Vergiss es.

ciao
gustav

: Bearbeitet durch User
von oszi40 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ein Filter ist immer die schlechteste Variante, weil es nie 100% 
wegfiltert. Masseschleife beseitigen (oder notfalls galvanisch trennen).

von Old P. (Firma: nix) (old-papa)


Bewertung
1 lesenswert
nicht lesenswert
Karl B. schrieb:
> Hi,
> zwei Dinge.
> Einmal NF-Spannung vom Ausgang eines Geräts zum Eingang eines anderen.
> Die NF-Spannung braucht zwei Pole. Ein Pol in der Luft reicht nicht.
> Also: Ein geschlossener Stromkreis ist nötig von der Quelle zur Senke.
> Die Ausführung der NF-Leitungen erfolgt nun einmal asymmetrisch, zum
> andern symmetrisch.
> Wobei beim asymmetrischen Weg meistens die Abschirmung den Rückleiter
> darstellt.

Zustimmung, wobei die Betonung auf "meistens" liegt. In geschlossenen 
Geräten baut man aber häufug einen Sternpunkt (manchmal wirklich ein 
einziger Punkt) für Masse (Rückleiter)

> Wenn jetzt irgendein anderer Strom noch über den Schirm läuft, geht der
> mit in das Signal ein. Das ist dann besonders stark, wenn es sich um
> empfindliche Eingangsschaltungen handelt oder um hochverstärkende
> Vorverstärker.
> Da reichen schon ein paar µV aus, um mit hörbar zu werden.

So ist es, darum Sternpunkt, ideal direkt am Netzteil.

> Dann Masseschleife:
> Das ist vom Prinzip her was ganz anderes, wird aber mit obiger Sache oft
> in einen Topf geworfen, weil die Effekte und Ursachen kombiniert
> auftreten können.
> Bei der Masseschleife entsteht eine Induktionsschleife, wie eine
> Spulenwindung, die das reininduzierte Feld aufnimmt. Meistens stammt das
> von Netztrafos.

Selten der Fall, kann aber auch sein...

> Beides zu vermeiden gilt es.
> Doppelte GND-Verbindung vermeiden, unterbricht Masseschleifen.

Stimmt!

> Aber wo bekommt jetzt die Rückleitung ihren Anschluss?
> Von irgendeiner anderen Verbindung. Das kann genauso problematisch
> werden.

Von einem Sternpunkt, völlig ohne Probleme. Oder man muss peinlichst auf 
die Stromrichtung achten, wie Du oben schon schriebst.

Schau Dir doch mal sein erstes Bild an...
Er legt zwei Stromversorgungsleitungen:
1x Netzteil zum Raspi (ja ist noch ein SNT dazwischen, ist aber wurscht) 
also 1x auch GND
1x vom Netzteil zur Endstufe, also auch GND.
Die Endstufe bekommt 2x GND, einmal direkt vom Netzteil und einml vom 
Raspi über die NF-Leitung. Das MUSS in die Grütze gehen.

Darum hatten Percy N. (und auch ich) vorgeschlagen, GND am NF-Kabel nur 
einseitig aufzulegen. Ich habe vor Urzeiten mal gelernt, dass man dass 
dann nur am Ziel (also Endstufe) macht.

Old-Papa

: Bearbeitet durch User
von Stefan ⛄ F. (stefanus)


Bewertung
1 lesenswert
nicht lesenswert
Stefan ⛄ F. schrieb:
> In deinem Fall wird wohl ein magnetischer Übertrager in der Audioleitung
> die einfachste Lösung sein.

Karl B. schrieb:
> Der Vorschlag mit dem galvanischen Trennen ist auch nicht überall
> realisierbar. Der Frequenzgang wird beeinflusst und die Dinger, die ich
> kenne, können relativ leicht in die Sättigung gefahren werden.

Deswegen gibt es diese Übertrager in beliebigen Preisklassen zwischen 5 
Euro und 500 Euro.

: Bearbeitet durch User
von Klaus R. (klara)


Bewertung
2 lesenswert
nicht lesenswert

von Karl B. (gustav)


Bewertung
0 lesenswert
nicht lesenswert
Klaus R. schrieb:
> Karl B. schrieb:
>> Und eine "saubere" Zentral-Erdung.

...setzt voraus, dass die Baugruppen als solche intern den Anforderungen 
entsprechend gelayoutet wurden.
Hier ging es um die Verbindungen nicht innerhalb der Leiterplatten, 
sondern
um die Anschlussverbindungen, die bei den Baugruppen als Verbindungen zu 
anderen Baugruppen definiert wurden.
Ich kann natürlich auch irgendwo am Radiochassis (Masse) was 
anschließen, dann an ein anderes Gerät gehen. Kann gutgehen. Aber man 
sollte die Buchsen etc. verwenden, die der Hersteller dafür vorgesehen 
hat.
Darum ging es im Thread hier.

Den Begriff "saubere" Erdung wollte ich in dem Sinne verstanden wissen:
Beitrag "Re: PE Schutzleiter missbrauchen"

ciao
gustav

von Günni (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Bei Steckernetzteilen wird die Masse durch die Y-Entstörkondensatoren 
verseucht. Wenn dann auch noch Geräte angeschlossen sind, deren Gehäuse 
an die Schutzerde angeschlossen ist, sind Brummeinstreuungen 
unvermeidlich, da der Ausgleichsstrom über die Masseverbindung fließt. 
Da helfen auch einseitig  angeschlossene Abschirmungen oft nicht weiter. 
Man kann natürlich die Versorgung über ein "sauberes" Netzgerät machen. 
Das wäre die beste aber auch aufwändigste Lösung. Aber für den Fall dass 
das Brummen diese Ursache hat, hilft ein 50 Hz Kerbfilter, da hier der 
reine Sinus der Netzfrequenz zu der Störung führt. Oberwellen sind da 
selten ein Problem. (Natürlich weiß ich, dass die Netzfrequenz durch 
Schaltnetzteile und andere nichtlineare Lasten kein reiner Sinus mehr 
ist, aber im Vergleich zur Grundwelle sind da die Oberwellenanteile noch 
recht gering.)

von Karl B. (gustav)


Bewertung
0 lesenswert
nicht lesenswert
Günni schrieb:
> Aber für den Fall dass
> das Brummen diese Ursache hat, hilft ein 50 Hz Kerbfilter, da hier der
> reine Sinus der Netzfrequenz zu der Störung führt.

Hi,
bei Einstreuungen von der Netzfrequenz überlagerten Rundsteuersignalen

Beitrag "Netzfilter gegen 1350Hz Rundsteuersignale bauen"

würde ich der Filterlösung noch zustimmen können, aber wenn irgendetwas 
aus dem NF-Spektrum schon rausgefiltert werden muss, dann ist das schon 
von Hause aus Murks.
Die praktikableren Lösungen wurden schon vorgestellt.

ciao
gustav

: Bearbeitet durch User
von Old P. (Firma: nix) (old-papa)


Bewertung
0 lesenswert
nicht lesenswert
Karl B. schrieb:

> ...setzt voraus, dass die Baugruppen als solche intern den Anforderungen
> entsprechend gelayoutet wurden.

Und auch extern nach den gleichen Anforderungen zu verdrahten sind.

> Hier ging es um die Verbindungen nicht innerhalb der Leiterplatten,
> sondern
> um die Anschlussverbindungen, die bei den Baugruppen als Verbindungen zu
> anderen Baugruppen definiert wurden.

Das ist wohl jedem klar. Doch auch dann verdrahtet man vernünftig. Nicht 
überall wo GND drauf steht, muss man GND auch anstöpseln. Der Hersteller 
der Baugruppen kann das ja nicht wissen, deshalb sieht er 
selbstverständlich auch GND überall vor.

> Ich kann natürlich auch irgendwo am Radiochassis (Masse) was
> anschließen, dann an ein anderes Gerät gehen. Kann gutgehen. Aber man
> sollte die Buchsen etc. verwenden, die der Hersteller dafür vorgesehen
> hat.

Nö, man verbindet die Baugruppen funktionsgerecht.
In dem Fall alle Massepunkte gemeinsam am Minus vom Netzteil und gut 
ist. Oder man lässt an der NF-Leitung einseitig GND offen (wiederhole 
mich)

> Darum ging es im Thread hier.

Nö, genau darum ging es nicht, es BRUUUUUMMMMMMMT, darum geht es ;-)

> Den Begriff "saubere" Erdung wollte ich in dem Sinne verstanden wissen:
> Beitrag "Re: PE Schutzleiter missbrauchen"

Das Massepotential in einer NF-Verdrahtung hat erstmal nichts mit PE 
(dem pöhsen "gelb-grünen") zu tun.

Old-papa

von Günni (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Karl B. schrieb:
> aber wenn irgendetwas
> aus dem NF-Spektrum schon rausgefiltert werden muss, dann ist das schon
> von Hause aus Murks.
Dem kann ich nur voll und ganz zustimmen. Deshalb hatte ich ja auch von 
einer "brutalen" Lösung als letzte Rettung geschrieben.
Günni schrieb:
> Wenn alles nichts genützt hat und die Masseschleife nach wie vor stört,
> ist die brutale Lösung das Einfügen eines Notch-Filters
Das Problem ist, dass viele der heute käuflichen Steckernetzteile intern 
keinen herkömmlichen Trafo mehr haben, sondern Schaltnetzteile sind. 
Diese erzeugen prinzipbedingt einen höheren Störnebel. Aber da sie 
kleiner, leichter und billiger sind, haben sie sich auf dem Markt 
durchgesetzt. Für sensible Aufbauten habe ich deshalb noch einige 
Netzteile mit "richtigem" Transformator, die ich dann einsetze. Und wenn 
es darauf ankommt, nehme ich mir einen Trafo und baue Gleichrichtung und 
lineare Regelung dazu. Den Aufwand für die nötige Kühlung nehme ich in 
Kauf und habe dafür eine wirklich ruhige Versorgungsspannung.

von Old P. (Firma: nix) (old-papa)


Bewertung
1 lesenswert
nicht lesenswert
Günni schrieb:
> Bei Steckernetzteilen wird die Masse durch die Y-Entstörkondensatoren
> verseucht. Wenn dann auch noch Geräte angeschlossen sind, deren Gehäuse
> an die Schutzerde angeschlossen ist, sind Brummeinstreuungen
> unvermeidlich, da der Ausgleichsstrom über die Masseverbindung fließt.
> Da helfen auch einseitig  angeschlossene Abschirmungen oft nicht weiter.

Der TO hat doch seinen Aufbau gezeichnet, das ist doch wohl EIN Gerät.

> Man kann natürlich die Versorgung über ein "sauberes" Netzgerät machen.
> Das wäre die beste aber auch aufwändigste Lösung.

Nö, das ist der Normalfall in einem Gerät.

> Aber für den Fall dass
> das Brummen diese Ursache hat, hilft ein 50 Hz Kerbfilter, da hier der
> reine Sinus der Netzfrequenz zu der Störung führt.

Nö, bei konventionellen Netzteilen hast Du eher 100Hz-Probleme. Hierbei 
weniger durch Ripple, eher durch steile Elko-Aufladeimpulse, erzeugt 
durch die Dioden. Doch der TO hat offenbar ein SNT (weil Manwell)

>.... (Natürlich weiß ich, dass die Netzfrequenz durch
> Schaltnetzteile und andere nichtlineare Lasten kein reiner Sinus mehr
> ist, aber im Vergleich zur Grundwelle sind da die Oberwellenanteile noch
> recht gering.)

Das ja.

Dennoch: (induktive) Trafoeinstreuungen können das beim TO ja nicht sein 
(weil SNT). Was bleibt noch?
Störnebel brummt nicht! Der rauscht, knarrt oder bringt einen anders zum 
Wahnsinn.

Old-papa

: Bearbeitet durch User
von Christop (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sooo...

ich hatte nun Zeit und habe das ein oder andere getestet... Habe ich das 
Brummen weg bekommen Nein..

Es bleibt nur die Möglichkeit von ZWEI Netzteilen. Das kann doch nicht 
wahr sein.

Ich habe GND weggelassen ( nur einseitig) und und und...

Weil ich langsam verzweifel... habe ich dann einfach mal einen 470 nF 
und einen 100nF Elko genommen und zwischen GND und R gesetzt...

Das brummen war zwar noch da.. aber EXTREM Leiser.. aber es ist noch 
da...

Wie zwei Netzteile genommen und alles ist BESTENS.

Ich habe nun versucht das Brummen irgendwie zu simulieren...

Also habe ich die TDA Platine genommen. An ein Netzteil angeschlossen 
(Meanwell SNT) und versucht das Brummen zu erzeugen.. Erfolglos...

Es "knartscht" (sehr komischen Geräusch) nur mit z.b. R oder L... kommt 
GND dazu.. Tada alles bestens...

Ich habe weiter getestet und gemacht und getan...

Kein Erfolg..

Zuletzt habe ich dann mein Handy genommen => Klinkenstecker => TDA... 
Auch wunderbarer Klang (oh mein Akku geht leer, Ladegerät angeschlossen) 
und man hörte ein Brummen... zwar nicht so extrem, aber ein Brummen

Weiter getestet...

Raspberry ran geholt... Raspbery über 5V Steckernetzteil versorgt und 
den TDA über das Meanwell..

Und? Kein Brummen...

Also meine Platine mit dem lm2596 zurück.. Raspberry dran.. Brummen..

An dem Raspberry ist auch das offizielle 7Zoll Touch Screen.

Wenn der Touch an ist.. hört man zudem noch ein "piepen".. Als ob man 
den inverter von dem Display "hört"...

Also langsam verzweifel ich echt.

Das Raspberry kann doch nicht so anfällig sein!?

Selbst ein CLC Filter brachte keine abhilfe...

von Karl B. (gustav)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Günni schrieb:
> Für sensible Aufbauten habe ich deshalb noch einige
> Netzteile mit "richtigem" Transformator, die ich dann einsetze. Und wenn
> es darauf ankommt, nehme ich mir einen Trafo und baue Gleichrichtung und
> lineare Regelung dazu.

Einige Gerätehersteller weisen sogar explizit auf die Verwendung eines 
Trafonetzteils hin.
Siehe Bild.
Wenn die Wetterstation trotzdem "spinnt", hat das auch einmal zu 
bestimmten Zeiten ausnahmsweise einmal senderseitige Gründe:
BTW:
"...Laut Wartungsplan der MEDIA BROADCAST GmbH sind die Wartungsarbeiten 
für folgenden Zeitraum geplant: 23.09.2020 / 15:00 - 18:00 Uhr.
DCF49..." (vielleicht auch DCF77 betroffen, wer weiß?)
Quelle:
https://www.hkw-elektronik.de/unternehmen/neuigkeiten/details/news/wartungsarbeiten-am-sender-dcf49-in-mainflingen/

Old P. schrieb:
> Nö, bei konventionellen Netzteilen hast Du eher 100Hz-Probleme. Hierbei
> weniger durch Ripple, eher durch steile Elko-Aufladeimpulse,

Ein zufällig herausgegriffener Thread dazu:
Beitrag "Re: Ringkerntrafo knurrt unter Last"

ciao
gustav

von Christop (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Mir wurde nun geraten Masse mit der "Erdung" als PE zu verbinden....

Kann das eine möglichkeit sein?

von Old P. (Firma: nix) (old-papa)


Bewertung
1 lesenswert
nicht lesenswert
Christop schrieb:
> Mir wurde nun geraten Masse mit der "Erdung" als PE zu verbinden....
>
> Kann das eine möglichkeit sein?

Versuch macht kluch ;-)

Ich vermute allerdings, dass das Manwell eh schon den Minusanschluss 
(GND) an PE hat. Eigentlich sollte da ein Y-Kondensator zwischen sein, 
doch leider habe ich bei Chinamöppeln oft auch hart auf PE geshen.

Old-Papa

von Christop (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Wo / Wie kann man das sehen?

Ähm...

Und.. reicht es dann einfach eine Brücke zwischen Masse und PE am 
Meanwell zu erstellen oder muss ich ein Kabel von der Schaltungsmasse 
zum PE ziehen?

Ich habe ein paar der Netzteile hier...

Ich öffne mal ein.. Vielleicht könnt ihr ja sehen was / wie das dort 
beschaltet ist...

von Joachim B. (jar)


Bewertung
0 lesenswert
nicht lesenswert
Old P. schrieb:
> Christop schrieb:
>> Mir wurde nun geraten Masse mit der "Erdung" als PE zu verbinden....
>>
>> Kann das eine möglichkeit sein?
>
> Versuch macht kluch ;-)

könnte es aber auch schlimmer machen, üblicherweise sind Netzteile 
potenzialfrei und nach PE nur bei Bedarf gebrückt!

von Christop (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ok...

Also ich habe jetz tmal mit einem Multimeter auf "durchgang" geprüft... 
Und PE und GND haben keinen durchgang...

von Karl B. (gustav)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Joachim B. schrieb:
> üblicherweise sind Netzteile
> potenzialfrei und nach PE nur bei Bedarf gebrückt!
Christop schrieb:
> Wo / Wie kann man das sehen?

Hi,
müsste auf dem Typenschild vermerkt sein.
Funktionserde.

Christop schrieb:
> Mir wurde nun geraten Masse mit der "Erdung" als PE zu verbinden....
Dann hast Du ja erst die Schleife.

Da nur ein Netzteil angeschlossen ist, fällt ja die Möglichkeit der 
Schleife über den gemeinsamen PE mit anderen Geräten aus.

Wenn es hier brummt, ist das der "Müll" vom SNT.
Kann auch sein, dass das eben nicht nur NF ist, sondern HF und alle 
möglichen Intermodulationsmischprodukte, die man dann wie ein Brummen
identifiziert. Das wird dann reininduziert noch in den NF-Verstärker.

ciao
gustav

von udok (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Das Übel dürfte der LM2596 sein.  Der hebt durch hohe
Pulsströme den GND vom Raspberry an.
Der Spannungsunterschied zwischen GND vom Rp und vom Meanwell Netzteil
führt dann zu Ausgleichsströmen über das Klinkenkabel.

Wenn du zwei Meanwell Netzteile verwendest, dann kann kein
nennenswerter Strom fliessen, da beide Meanwell
galvanisch durch kleine Y Kondensatoren getrennt sind.

Du kannst versuchen den GND vom Rp durch einen breiten
Draht mit dem GND vom Meanwell zu verbinden.

Oder hänge 10 uF Kerkos an den Eingang vom LM2596 und an
den Ausgang, mit möglichst kurzen Anschlüssen.

Oder du versorgst den Rp mit einem kleinen 5 Volt USB Steckernetzteil.

von Christop (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich habe jetzt einfach mal einen Kupferdraht genommen und PE mit GND 
direkt am Netzteil verbunden....

Das Brummen ist KOMPLETT weg.. KOMPLETT...

Am Raspberry hängt noch das offizielle 7Zoll TFT dran...

ja.. solange wie das Display an ist...

Hat man nun noch ein Pfeifen/Piepsen in den Lautsprechern.. Sobald das 
Display aus ist.. ist dieser Ton auch weg...

Was ist das denn nun schon wieder?

von RobPi (Gast)


Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Christop schrieb:
> Das Raspberry kann doch nicht so anfällig sein!?

Ist er. Wo hast du den deine Musik gelagert? Auf einer Festplatte/Stick?

Wenn man sich die Platine genau anschaut, sieht man wie behindert es 
geroutet ist. Mit die größten Verbraucher (USB) sind am weitesten von 
dem Versorgungsstecker angebracht. Da fließen die großen Ströme samt 
Störungen quer über den PI zusammen mit der analogen und digitalen Masse 
und verbinden diese Kreuz- und Quer. Der audiophile Teil in mir weint 
ein wenig.

Was ist den für ein DAC verbaut?
Kannst du mal ein Foto von deinem Aufbau zeigen?
Welches Board für den TDA7375V oder DIY?
Fliegende Verdrahtung?

Hast du einen vernünftigen Sternpunkt? Schon mal versucht die Masse 
nicht durch die LM2596 Platine zu senden? Dort wird ein input und output 
GND suggeriert, ist aber nur unnötig durch die Platine geschoben. Schau 
mal im Anhang.

von Christop (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Alle Schaltungen sind komplett DIY....

Ich denke wirklich eine Schlechte Masseführung.. WIe gesagt.. eine 
weitere Masseleitung... ja hat das "brummen" komplett beseitigt...

Solange das Display aus ist.. ist es auch komplett Stumm.. also alles 
korrekt...

Nur eben sobald das Display eingeschaltet ist... ja.. EMV EMV EMV

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.