www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik [How-To] Seagate Dockstar als 300mbit Draft-N Access Point


Autor: Marco .. (tuding)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe meinen Seagate Dockstar

(http://www.mikrocontroller.net/articles/Dockstar
und
Beitrag "20Euro Embedded System mit ARM, 128MB ram und 256MB Flash")
erfolgreich zum 300mbit WLAN Access Point / Router erweitert. In 
diesem How-To möchte ich erklären, was man dazu tun muss.

Auf der Seite
http://wireless.kernel.org/en/users/Drivers
kann man nachsehen, welche WLAN Geräte in der Lage sind, als AP zu 
fungieren (die Hardware ist Master Mode kompatibel und der Treiber 
unterstützt dies). Da wir an die Dockstar nur USB-Geräte anschließen 
können, reduziert sich diese Liste auf wenige Konfigurationen:

carl9170 (Atheros ar9170)
libertas_tf (Marvell 88W8388, eingesetzt in Guruplug)
p54usb (Intersil Prism54)
rt73usb (Ralink RT2571W, RT2573 & RT2671)
rt2500usb (RT2571 & RT2572)

Von all den genannten unterstützt nur der erste 802.11n, und zwar _bis 
zu 300mbit/s mit zwei Antennen und spatial streams_. Auf der Seite
http://wireless.kernel.org/en/users/Drivers/carl9170
ist eine Liste mit bekannten USB-Sticks, die den Atheros Chip enthalten. 
Ein Preisvergleich hat ergeben, dass der TP-Link TL-WN821N mit unter 
15€ der günstigste Kandidat ist, die Preisspanne liegt bei den sonstigen 
Sticks bei 20-45€. Ich habe mich für den TP-Link entschieden und soviel 
sei vorweggenommen, das Preis-Leistungs-Verhältnis ist sehr gut, der 
Stick funktioniert bisher tadellos und erreicht problemlos 10MB/s bei 
300MBit/s. Der Stick wird nicht sehr warm, obwohl die Powersaving 
Funktionen vom Treiber noch nicht unterstützt werden. Von der Größe 
mutet der Stick gigantisch an, ausgepackt ist er aber relativ flach und 
lässt sich sogar im Dockstar-Gehäuse unterbringen (der USB-Stecker muss 
abgelötet werden - ich habe den Stick an den internen USB-Header 
gehängt).

Um den Stick zum laufen zu bringen, musste ich die für WLAN benötigten 
obligatorischen Pakete installieren, Firmware downloaden, Treiber und 
Hostapd kompilieren und für die Router-Konfiguration iptables setzen. 
Als DNS/DHCP nutze ich dnsmasq.

Was man nach diesem How-To hat: Dockstar als AP mit WPA/WPA2 (PSK). Ab 
da muss man dann entweder noch eine Netzwerkbrücke einrichten oder falls 
gewünscht mit z.b. dnsmasq oder dhcpd einen DHCP aufsetzen. Für NAT, 
also soll das Dockstar als Router fungieren, müssen dann noch 
masquerading und IP-forwarding sowie iptables (z.b. mit shorewall) 
eingestellt werden, siehe dazu weiterführende Quellen.

Mein How-To basiert auf dem 2.6.32-5-Kernel, der original mit dem Jeff 
Doozan Installerskript mitkommt. Wer den Kernel ebenfalls nutzt, kann 
auch direkt die von mir verlinkten Pakete installieren und muss nur noch 
firmware downloaden und config Files anpassen.

Es geht los (switch to english):

Prerequisites: We install the required packages for WiFi environment
apt-get install wpasupplicant iw wireless-tools 

If you need to troubleshoot whether your Wifi-Adapter is working 
properly, you can install the following tools:
apt-get install hwinfo usbutils

Since we need to use carl9170 module rather than the ar9170usb module 
which the kernel will load if the adapter is plugged in, we blacklist 
the ar9170usb module in /etc/modprobe.d/blacklist.conf (alternatively, 
compile your kernel without that):
# blacklist ar9170usb: we want to load carl9170 for AP capabilities
blacklist ar9170usb

We download the firmware for our Atheros chip which is used by the 
driver we will compile:
cd /lib/firmware
wget http://www.kernel.org/pub/linux/kernel/people/chr/carl9170/fw/1.8.8.3/carl9170-1.fw

For building the carl9170 driver, you will need your linux-headers 
installed:
apt-get install linux-headers

We head over to a location we want to build our stuff and download and 
extract the compat wireless tarball from the testing repository. You can 
also use git for that. I used the 2010-10-11 tarball, there are nearly 
dayly updates on that, so feel free to use newer archives and report 
that to the community.
cd /usr/src
wget http://wireless.kernel.org/download/compat-wireless-2.6/compat-wireless-2010-10-11.tar.bz2
tar jxvf compat-wireless-2010-10-11.tar.bz2
cd cd compat-wireless-2010-10-11

In order to save some time, we will select to only compile the carl9170 
driver.
./scripts/driver-select carl9170

Build and install that thing. If you got errors, check your 
linux-headers and if you have build-essential installed.
make
make install

Now reboot the Dockstar and plug in the WLAN adapter. Watch the kernel 
messages. Should look like this (make sure carl9170 driver is used):
[  119.525886] usb 1-1.3: new high speed USB device using orion-ehci and address 4
[  119.693603] usb 1-1.3: New USB device found, idVendor=0cf3, idProduct=1002
[  119.700527] usb 1-1.3: New USB device strings: Mfr=16, Product=32, SerialNumber=48
[  119.708162] usb 1-1.3: Product: USB2.0 WLAN
[  119.712362] usb 1-1.3: Manufacturer: ATHER
[  119.716486] usb 1-1.3: SerialNumber: 12345
[  119.722582] usb 1-1.3: configuration #1 chosen from 1 choice
[  119.754841] Compat-wireless backport release: compat-wireless-2010-10-01-10-gb9b0a4f
[  119.762666] Backport based on linux-next.git next-20101011
[  119.853160] cfg80211: Calling CRDA to update world regulatory domain
[  120.065868] usb 1-1.3: reset high speed USB device using orion-ehci and address 4
[  120.222296] usbcore: registered new interface driver carl9170
[  120.240172] usb 1-1.3: driver   API: 1.8.8.3 2010-09-28 [1-1]
[  120.246007] usb 1-1.3: firmware API: 1.8.8.1 2010-08-30
[  121.543450] cfg80211: Calling CRDA for country: CN
[  121.556029] Registered led device: carl9170-phy0::tx
[  121.561022] usb 1-1.3: Atheros AR9170 is registered as 'phy0'

Now you can use your Dockstar as a WLAN client :-) Check your device's 
capabilities:
iw list

You should see a lot of features and stuff including the following for 
300mbit speed and AP mode. If that doesn't show up, check with lsmod if 
carl9170 is properly loaded.
HT20/HT40
HT TX/RX MCS rate indexes supported: 0-15, 32
AP

If this is fine, we are ready to build hostapd incl. 802.11n support to 
make our device a nice AP.

Install required source packages:
apt-get install libssl-dev libnl-dev

Download and set up hostapd sources for build:
cd /usr/src
wget http://w1.fi/releases/hostapd-0.6.9.tar.gz
tar jxvf hostapd-0.6.9.tar.gz
cd hostapd-0.6.9/hostapd
cp defconfig ./.config

We need to edit .config and uncomment following lines:
CONFIG_DRIVER_NL80211=y
CONFIG_IEEE80211N=y

Build and install hostapd as usual:
make
make install

Copy over hostapd's config file:
mkdir -p /etc/hostapd
cp hostapd.conf /etc/hostapd

Edit your /etc/hostapd/hostapd.conf and set desired options. Take your 
time, as the config is well-documented, to get the most out of your AP. 
Besides others, you will set following options if you want your Dockstar 
AP to be WPA+WPA2 encrypted supporting HT with 40MHz gap (two channels, 
300mbit/s):
interface=wlan0
driver=nl80211
ssid=YOUR_SSID
hw_mode=g
channel=7
ieee80211n=1
ht_capab=[HT40-][SHORT-GI-40]
wpa=3
wpa_passphrase=YOURWPAPASSPHRASE
wpa_key_mgmt=WPA-PSK WPA-EAP
wpa_pairwise=TKIP CCMP
rsn_pairwise=CCMP

We want our Dockstar AP to have a static IP and the AP to be brought up 
once the device is plugged in. We need to edit /etc/network/interfaces 
file. First we backup this file.
cp /etc/network/interfaces /etc/network/interfaces.bak

Setup the interface and define the IP of your AP and the range of your 
WLAN. If you want to use the Dockstar as a bridge, this looks a little 
bit different here, you need to add some brctl commands in pre-up and 
post-down to fire up and shut down the bridge with your WLAN interface. 
My file looks like that:
auto lo eth0 wlan0

# Loopback Interface
iface lo inet loopback

# Internet Interface
iface eth0 inet dhcp

# Wireless Interface
iface wlan0 inet static
        address 192.168.80.1
        network 192.168.80.0
        netmask 255.255.255.0
        broadcast 192.168.80.255
        pre-up /usr/local/bin/hostapd -B /etc/hostapd/hostapd.conf
        up /sbin/ifconfig wlan0 up

Finally, we restart the networking or reboot the Dockstar and you should 
be all set:
service networking restart

Watch out for your new Wifi SSID appearing on your clients Wifi list. If 
it appears, the hostapd is loaded and you got your AP running.

Have fun!

If you have any questions, I will be glad to help.


---------------------

If you use the 2.6.32-5-kirkwood Kernel (check with uname -r), here are 
pre-built .deb Packages so you neither need the sources mentioned above 
nor build yourself.

You will need the firmware step, the blacklist step as well as modifying 
the interfaces file and the hostapd.conf.

Viele Grüße,

Marco

Autor: Michl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi
Habe heute versucht den Treiber selbst zu kompilieren und auch mit 
deinen Paketen. Leider bekomme ich immer diese Fehlermeldung. Hattest du 
die auch schonmal?

root@debian:/# service networking restart
Running /etc/init.d/networking restart is deprecated because it may not 
enable again some interfaces ... (warning).
Reconfiguring network interfaces...dhcpcd.sh: interface eth0 has been 
configured with new IP=192.168.0.52
Configuration file: /etc/hostapd/hostapd.conf
Line 17: unknown configuration item ' driver'
1 errors found in configuration file '/etc/hostapd/hostapd.conf'
Failed to bring up wlan0.
done.

Viele Grüße
Michl

Autor: Marco .. (tuding)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was steht denn in deiner /etc/hostapd/hostapd.conf als driver drin? 
Sieht in der message so aus, als hättest du ein Space vor "driver"...

Müsste driver=nl80211 sein. Falls das so ist, hast du in den configs vor 
dem Kompilieren was falsch gemacht. Wird carl als Treiber angenommen? 
Was zeigt iw list?

Bitte mehr Infos geben.

Autor: Michl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi
In der hostapd.conf steht driver=n180211
lsmod mod git dies hier aus:
Module                  Size  Used by
arc4                    1064  2
ecb                     1739  2
carl9170               68153  0
mac80211              183587  1 carl9170
compat_firmware_class     5609  1 carl9170
ath                    12044  1 carl9170
cfg80211              125687  3 carl9170,mac80211,ath
rfkill                 14296  1 cfg80211
compat                  2740  2 carl9170,cfg80211
ipv6                  253653  10
hmac                    2475  0
sha1_generic            1717  0
mv_cesa                 9262  0
aes_generic            32820  1 mv_cesa
ext2                   55411  1
mbcache                 4860  1 ext2
sd_mod                 31224  3
crc_t10dif              1106  1 sd_mod
usb_storage            34879  2
scsi_mod              119212  2 sd_mod,usb_storage
ehci_hcd               35579  0
mvsdio                  5318  0
usbcore               122115  5 carl9170,compat,usb_storage,ehci_hcd
mv643xx_eth            22562  0
nls_base                5367  1 usbcore
mmc_core               49992  1 mvsdio
libphy                 14836  1 mv643xx_eth
inet_lro                5060  1 mv643xx_eth

Bei iw list bekomme ich diese Ausgabe:
Wiphy phy0
        Band 1:
                Capabilities: 0x184e
                        HT20/HT40
                        SM Power Save disabled
                        RX HT40 SGI
                        No RX STBC
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-15, 32
                Frequencies:
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (disabled)
                        * 2472 MHz [13] (disabled)
                        * 2484 MHz [14] (disabled)
                Bitrates (non-HT):
                        * 1.0 Mbps
                        * 2.0 Mbps (short preamble supported)
                        * 5.5 Mbps (short preamble supported)
                        * 11.0 Mbps (short preamble supported)
                        * 6.0 Mbps
                        * 9.0 Mbps
                        * 12.0 Mbps
                        * 18.0 Mbps
                        * 24.0 Mbps
                        * 36.0 Mbps
                        * 48.0 Mbps
                        * 54.0 Mbps
        max # scan SSIDs: 4
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
        Supported commands:
                 * new_interface
                 * set_interface
                 * new_key
                 * new_beacon
                 * new_station
                 * new_mpath
                 * set_mesh_params
                 * set_bss
                 * authenticate
                 * associate
                 * deauthenticate
                 * disassociate
                 * join_ibss
                 * Unknown command (55)
                 * Unknown command (57)
                 * Unknown command (59)
                 * set_wiphy_netns
                 * Unknown command (65)
                 * Unknown command (66)
                 * connect
                 * disconnect


Viele Grüße
Michl

Autor: Marco .. (tuding)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das sieht sonst ja alles in Ordnung aus.
Ich glaube ich sehe, wo sich der Fehler eingeschlichen hat:

Bei dir steht driver=n180211 
[n-"eins"-"acht"-"null"-"zwei"-"eins"-"eins"]

es müsste aber mit kleinem L statt 1 sein: driver=nl80211 
[n-l-"acht"-"null"-"zwei"-"eins"-"eins"]

Das korrigieren und dann müsste es eigentlich laufen. Schönen Sonntag.

Autor: Michl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke
Es läuft jetzt. Ich glaube das wäre mir so schnell nie aufgefallen ;-)
Ach ja und Danke das du hier dieses HowTo online gestellt hast.

Viele Grüße
Michl

Autor: Marco .. (tuding)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schön, dann freue ich mich, dass ich dir helfen konnte. Würdest du uns 
noch verraten, welchen Stick du genommen hast?

Autor: Michl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
TP-Link WN821N

Ich hatte zufällig noch den selben wie du hier rumliegen.

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Abend
Super Howto das du da geschrieben hast. Ich war schon seit längerem 
dabei diesen Stick ans laufen zu bekommen und nun hat es endlich 
geklappt.

Im Moment versuche ich einen AP zu basteln. Dazu habe ich bridge-utils 
installiert.
In /etc/hostapd/hostapd.conf habe ich bridge=bridge0 eingestellt.

/etc/network/interfaces sieht bei mir so aus:
auto lo
# Loopback Interface
iface lo inet loopback

# Internet Interface
auto eth0
iface eth0 inet dhcp

# Wireless Interface
auto wlan0
iface wlan0 inet manual
        pre-up /usr/local/bin/hostapd -B /etc/hostapd/hostapd.conf
        up /sbin/ifconfig wlan0 up
        /sbin/iwconfig wlan0 mode Master

auto bridge0
iface bridge0 inet static
        adress 192.168.0.53
        network 192.168.0.0
        netmask 255.255.255.0
        broadcast 192.168.0.255
        gateway 192.168.0.1
        bridge-ports eth0 wlan0


Ich bekomme immer diese Fehlermeldung:

root@debian:~# service networking restart
Running /etc/init.d/networking restart is deprecated because it may not 
enable again some interfaces ... (warning).
Reconfiguring network interfaces...[  221.692951] ADDRCONF(NETDEV_UP): 
eth0: link is not ready
[  224.737541] eth0: link up, 1000 Mb/s, full duplex, flow control 
disabled
[  224.744360] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
dhcpcd.sh: interface eth0 has been configured with new IP=192.168.0.52
Configuration file: /etc/hostapd/hostapd.conf
Using interface wlan0 with hwaddr 94:0c:6d:e3:bc:92 and ssid 'dockstar'
Don't seem to have all the variables for bridge0/inet.
Failed to bring up bridge0.
done.

Hat schonmal jemand die Brücke ans laufen bekommen und kann mir sagen wo 
der Fehler ist?

Schonmal Danke und Gute Nacht

Autor: Marco .. (tuding)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab bisher noch keine Brücke mit dem Stick aufgesetzt und es gibt 
sicher mehrere Möglichkeiten. Mir ist es lieber die Brücke selber 
aufzusetzen, als das hostapd machen zu lassen (zentral in der interfaces 
einstellen, damit kann man bei umkonfiguration Zeit sparen). Ich hab 
also folgende Tipps:

In der hostapd.conf die Brücke wieder auskommentieren und 
interface=wlan0 setzen. (Wir wollen die Brücke selber machen)

In deiner interfaces noch ein bisschen was ändern:

- Du musst wlan0 nicht hochziehen
- hostapd startest du mit der Brücke
- master mode musst du nicht per Hand setzen
- bridge-ports brauchst du nicht, wir machen alles mit brctl
- eth0 solltest du auch auf manual stellen (bekommt ja die range von der 
brücke)

Der Ablauf in bridge0 sieht so aus:

1. Interface bridge0 wird initialisiert
2. Brücke wird erstellt
3. eth0 wird der Brücke hinzugefügt
4. hostapd zieht den AP mode hoch
5. wlan0 wird zur Brücke hinzugefügt
6. Die Brücke wird hochgezogen

Beim Runterfahren der Bridge werden die gebridgeten interfaces wieder 
freigegeben und die Brücke gelöscht.

interfaces also folgendermaßen:

auto lo
# Loopback Interface
iface lo inet loopback

# Internet Interface
auto eth0
iface eth0 inet manual

# Wireless Interface
auto wlan0
iface wlan0 inet manual

# Bridge       
auto bridge0
iface bridge0 inet static
        adress 192.168.0.53
        network 192.168.0.0
        netmask 255.255.255.0
        broadcast 192.168.0.255
        gateway 192.168.0.1
        pre-up /usr/sbin/brctl addbr bridge0
  pre-up /usr/sbin/brctl addif bridge0 eth0
  pre-up /usr/local/bin/hostapd -B /etc/hostapd/hostapd.conf
  pre-up /usr/sbin/brctl addif bridge0 wlan0
  up /sbin/ifconfig bridge0 up
  post-down /usr/sbin/brctl delif bridge0 eth0
  post-down /usr/sbin/brctl delif bridge0 wlan0
  post-down /usr/sbin/brctl delbr bridge0


PS: Nenne doch bridge0 einfach br0 wie man das üblicherweise macht... 
;-)

Autor: Falcon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

mein Stick TL-WN821N funktioniert problemlos mit dem Treiber ar9170usb.

Würde lieber den carl9170 mutzen.
Nutze den 2.6.32-5-kirkwood Kernel von Jeff
Habe den Treiber von oben (driver-carl9170_20101011-1_armel.deb) 
herunter geladen und mit dpkg -i installiert.
Blacklist Eintrag gesetzt.
Wenn ich den Stick einstecke wird er erkannt, aber keinerlei Treiber 
geladen.

Muss man den Treiber noch einbinden (ich bin Linux Anfänger)?
Unter Windows gibt es eine .inf-Datei mit PCI-Strings und 
Treiberverweisen.
Wie funktioniert das unter Linux? Konnte so etwas nicht in dem deb-Paket 
finden.

Falcon

Autor: Marco .. (tuding)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Soweit ja alles richtig gemacht, du bist aber noch nicht fertig. Du hast 
vergessen, die carl firmware herunterzuladen. Dass sollte

dmesg | tail

dir nach dem Einstecken des Sticks anzeigen.

Die Firmware lädst du wie im Tutorial oben steht per:
cd /lib/firmware
wget http://www.kernel.org/pub/linux/kernel/people/chr/carl9170/fw/1.8.8.3/carl9170-1.fw

Dann sollte es eigentlich gehen.

Autor: Falcon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Rückmeldung.
Doch die Firmware habe ich in dem Verzeichnis.
Liegt da friedlich neben der Firmware ar9170.fw für den ar9170usb 
Treiber.
Wenn ich den Stick einstecke kommen nur diese Meldungen:

[   82.870781] usb 1-1.4: new high speed USB device using orion-ehci and 
address 4
[   83.038498] usb 1-1.4: New USB device found, idVendor=0cf3, 
idProduct=1002
[   83.045422] usb 1-1.4: New USB device strings: Mfr=16, Product=32, 
SerialNumber=48
[   83.053055] usb 1-1.4: Product: USB2.0 WLAN
[   83.057256] usb 1-1.4: Manufacturer: ATHER
[   83.061381] usb 1-1.4: SerialNumber: 12345
[   83.067497] usb 1-1.4: configuration #1 chosen from 1 choice

Dann ist Ende.
Sieht so aus, als ob sich kein Treiber dafür 'zuständig fühlt'.
Nach welchen Mechanismen läuft das ab?

Falcon

Autor: Marco .. (tuding)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du mal nach der Installation des Packages neu gebootet?
Hmm, hab da jetzt auch nicht sofort ne Idee. Bei mir lief das .deb gut 
und sonst habe ich noch keine andere Rückmeldung bekommen.

Du kannst ja einfach mal in dem Tutorial nach dem Schritt mit der 
Firmware weitermachen (den Treiber selbst kompilieren), das dauert 
höchstens 10 Minuten und nach dem make install sollte alles rennen.

Autor: Falcon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mir das noch mal genau angesehen.
Und meinen Fehler gefunden (ich bin blöd..).
Ich nutze den 2.6.32-dockstar Kernel mit LED Support.
Dazu passt natürlich nicht das Treiber-Paket von hier.

Hatte dann versucht den Treiber selber zu kompilieren.
Nach Installation div. Pakete hatte ich das Ziel vor Augen.
Make ist aber abgebrochen, weil einige Voraussetzungen nicht passten.
Fehlermeldung muss ich noch mal suchen.

Hier gibt es Hinweise auf fehlende/falsche linux-headers:
http://forum.doozan.com/read.php?2,524,page=2
Vermute das ist die Ursache.

Werde erst einmal mit dem ar9170usb Treiber leben.
Im Forum von Jeff hat jemand den Treiber für einen Dockstar heavy Kernel 
kompiliert.
http://forum.doozan.com/read.php?2,582,page=7
Habe gefragt ob der Treiber zur Verfügung gestellt werden kann.

In einem anderen Artikel gibt es Hinweise, dass der TL-WN821N Stick 
besser mit doppelter Stromversorgung über Y-Kabel läuft.
http://forum.doozan.com/read.php?2,563,page=3

Oder ist NanoBot auch hier vertreten?

Falcon

Autor: Micha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Anleitung funktioniert sehr gut, auch mit neuerem Kernel 3.6.35.7.
Danke dafür!
Bei Kerneln von sheeva.with-linux.com muss man leider den Kernel selbst 
kompilieren, da zwei Treiber nicht als Modul geladen werden, vom Compat 
aber überschrieben werden.
Anleitung zum Kernel kompilieren über den Cross-Compiler gibt es hier:
http://computingplugs.com/index.php/Building_a_cus...

Gruß
Micha

Autor: Robert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Anleitung.

Habe das Ganze hingekriegt (Selbes OS, Selbe HW), jedoch ist die 
Regulatory Domain auf CN gesetzt (kommt wohl aus dem EEPROM, EEPROM vor 
allem).


--
[ 1315.664904] Compat-wireless backport release: 
compat-wireless-2010-10-01-10-gb9b0a4f
[ 1315.672725] Backport based on linux-next.git next-20101011
[ 1315.754549] cfg80211: Calling CRDA to update world regulatory domain
[ 1315.767593] cfg80211: Calling CRDA for country: DE
[ 1315.961992] usb 1-1.4: reset high speed USB device using orion-ehci 
and address 6
[ 1317.131283] usbcore: registered new interface driver carl9170
[ 1317.149630] usb 1-1.4: driver   API: 1.8.8.3 2010-09-28 [1-1]
[ 1317.155471] usb 1-1.4: firmware API: 1.9.0 2010-10-12
[ 1317.522983] ath: EEPROM regdomain: 0x809c
[ 1317.522994] ath: EEPROM indicates we should expect a country code
[ 1317.523004] ath: doing EEPROM country->regdmn map search
[ 1317.523013] ath: country maps to regdmn code: 0x52
[ 1317.523022] ath: Country alpha2 being used: CN
[ 1317.523029] ath: Regpair used: 0x52
[ 1317.526183] ieee80211 phy0: Selected rate control algorithm 
'minstrel_ht'
[ 1317.530641] cfg80211: Calling CRDA for country: CN
[ 1317.544075] Registered led device: carl9170-phy0::tx
[ 1317.549068] usb 1-1.4: Atheros AR9170 is registered as 'phy0'
[ 1317.594017] udev[1313]: renamed network interface wlan0 to wlan1

--

Ich habe die Regulatory Domain auf DE gesetzt

root@dockstar:/usr/src/crda-1.1.1# cat /etc/modprobe.d/cfg80221.conf
options cfg80211 ieee80211_regdom=DE

, jedoch wird das Ganze ignoriert.

Damit habe ich auch keine 300 Mbit:

--
root@dockstar:/usr/src/crda-1.1.1# iw list
Wiphy phy0
        Band 1:
                Capabilities: 0x184e
                        HT20/HT40
                        SM Power Save disabled
                        RX HT40 SGI
                        No RX STBC
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-15, 32
                Frequencies:
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (disabled)
                        * 2472 MHz [13] (disabled)
                        * 2484 MHz [14] (disabled)
                Bitrates (non-HT):
                        * 1.0 Mbps
                        * 2.0 Mbps (short preamble supported)
                        * 5.5 Mbps (short preamble supported)
                        * 11.0 Mbps (short preamble supported)
                        * 6.0 Mbps
                        * 9.0 Mbps
                        * 12.0 Mbps
                        * 18.0 Mbps
                        * 24.0 Mbps
                        * 36.0 Mbps
                        * 48.0 Mbps
                        * 54.0 Mbps
        max # scan SSIDs: 4
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
        Supported commands:
                 * new_interface
                 * set_interface
                 * new_key
                 * new_beacon
                 * new_station
                 * new_mpath
                 * set_mesh_params
                 * set_bss
                 * authenticate
                 * associate
                 * deauthenticate
                 * disassociate
                 * join_ibss
                 * Unknown command (55)
                 * Unknown command (57)
                 * Unknown command (59)
                 * set_wiphy_netns
                 * Unknown command (65)
                 * Unknown command (66)
                 * connect
                 * disconnect

---

Hast du eine Idee wie man die Regulatory Domain (DE) hinkriegt oder die 
im BIOS anders setzt ?

Robert

Autor: robert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi, habs hingekriegt mit dem regulatory tools über udev und crda.

Autor: __tom (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Robert schrieb:
> Hast du eine Idee wie man die Regulatory Domain (DE) hinkriegt oder die
> im BIOS anders setzt ?

iw reg set DE

allerdings muss man aufpassen, je nachdem wie der treiber kompiliert ist 
erzeugt das einen schnitt aus der eeprom regulary domain und der ziel 
domain, d.h. wenn der eeprom nicht erlaubt auf kanal 14 mit 40mhz zu 
senden, bringt das umstellen auf DE auch nichts. allerdings kann man 
beim treiber compilieren auch angeben das die domain aus dem eeprom 
ruhig ignoriert werden kann, das bringt dann aber andere probleme mit 
sich, z.b. sind in der regel nur kalibrierungsdaten für die erlaubten 
kanäle im eeprom drin.

Autor: tuding (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und was sagt bei euch der Langzeittest? Alles stabil? Auch im HT40 mode?

Autor: thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
tuding schrieb:
> Und was sagt bei euch der Langzeittest? Alles stabil? Auch im HT40 mode?

Bei mir bricht die Verbindung im n-Modus regelmäßig ab. Allerdings 
verwende ich OpenWrt und nicht Debian. Die Treiber sind mittlerweile 
auch ein paar mal aktualisiert worden. Vielleicht hat sich das 
mittlerweile schon gebessert...

Autor: nur_so (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich spiele auch mit dem Gedanken, die Dockstar zu einem Wlan Accesspoint 
zu konfigurieren, jedoch habe ich da noch eine Frage:
Ist das konfigurieren zu einem Wlan Accesspoint stark systemlastig?

Wäre natürlich super, wenn man dann ein Wlan Accesspoint hätte.
Unteranderem bräuchte man dann nur noch das paket pppoeconf zu 
installieren und das Netzwerkkabel an ein Modem anschließen und fertig 
ist der Lack.

mit pon dsl-provider wird glaube ich die PPPOE Verbindung aufgebaut und 
mit poff die PPPOE Verbindung unterbrochen.

Da habe ich auch noch eine Frage....wenn man pon dsl-provider ausführt, 
bleibt die Verbindung immer bestehen, oder muß ich, nachdem man nach 24 
disconnected wird ein reconnect ausführen, oder macht das Programm es 
selbst?

Jo und wenn man auf die Dockstar zugreifen will "über ssh", geht es ganz 
einfach mit einem Rechner, der eine Wlan Karte besitzt.

Danke im Voraus schon für Eure Hilfe.

Autor: Marco .. (tuding)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich habe vielleicht 1-2% CPU wenn der Dockstar komplett übers 
54mbit WLAN routet. In dem carl Treiber soll ja auch HW-Crypto supportet 
werden, sieht mir so aus als ob das auch funktioniert.

Weitere Daten muss ich auch für mich noch sammeln.

Autor: Marco .. (tuding)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
thomas schrieb:
> tuding schrieb:
>> Und was sagt bei euch der Langzeittest? Alles stabil? Auch im HT40 mode?
>
> Bei mir bricht die Verbindung im n-Modus regelmäßig ab. Allerdings
> verwende ich OpenWrt und nicht Debian. Die Treiber sind mittlerweile
> auch ein paar mal aktualisiert worden. Vielleicht hat sich das
> mittlerweile schon gebessert...

Ja, ist bei mir genauso. Bei b/g ist die Verbindung eigentlich stabil, 
ich bekomme real life TCP Datenraten von ca. 20mbit/s. Bei 
eingeschaltetem N modus (hostapd.conf: wmm_enabled=1 und ieee80211n=1, 
natürlich muss auch WPA/WPA2 mit AES eingeschaltet sein) bekomme ich bei 
20mhz Betrieb (130mbit Signal) ne wackelige Verbindung, die immer wieder 
stottert.

Schalte ich noch HT40 ein (hostapd.conf: ht_capab=[HT40-][SHORT-GI-40]) 
bekomme ich zwar gute Speeds (300mbit Signal) um die 70-100mbit/s real 
life TCP, allerdings geht die Verbindung fast dauernd komplett in die 
Knie für 5-15 Sekunden.

Aktuell begnüge ich mich also mit 54mbit (besser als garnichts am 
Dockstar), hoffe aber, dass der Treiber den n-modus AP bald stabiler 
unterstützt.

Autor: Nico (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marco G. schrieb:
> thomas schrieb:
>> tuding schrieb:
>>> Und was sagt bei euch der Langzeittest? Alles stabil? Auch im HT40 mode?
>>
>> Bei mir bricht die Verbindung im n-Modus regelmäßig ab. Allerdings
>> verwende ich OpenWrt und nicht Debian. Die Treiber sind mittlerweile
>> auch ein paar mal aktualisiert worden. Vielleicht hat sich das
>> mittlerweile schon gebessert...
>
> Ja, ist bei mir genauso. Bei b/g ist die Verbindung eigentlich stabil,
> ich bekomme real life TCP Datenraten von ca. 20mbit/s. Bei
> eingeschaltetem N modus (hostapd.conf: wmm_enabled=1 und ieee80211n=1,
> natürlich muss auch WPA/WPA2 mit AES eingeschaltet sein) bekomme ich bei
> 20mhz Betrieb (130mbit Signal) ne wackelige Verbindung, die immer wieder
> stottert.
>
> Schalte ich noch HT40 ein (hostapd.conf: ht_capab=[HT40-][SHORT-GI-40])
> bekomme ich zwar gute Speeds (300mbit Signal) um die 70-100mbit/s real
> life TCP, allerdings geht die Verbindung fast dauernd komplett in die
> Knie für 5-15 Sekunden.
>
> Aktuell begnüge ich mich also mit 54mbit (besser als garnichts am
> Dockstar), hoffe aber, dass der Treiber den n-modus AP bald stabiler
> unterstützt.

Ich zitiere

http://wireless.kernel.org/en/users/Drivers/carl9170

Bei "Working" steht so:
 * 802.11 a/b/g/draft-n
 * legacy (802.11bg) accesspoint, ad-hoc operation mode
 * 802.11n station mode, monitor (with injection)

Bei "not supported steht":
 * real 802.11n AP

wer sieht hier den kleinen, aber feinen Unterschied?
Richtig, der Treiber/das Gerät unterstützte "nie" den
richtigen 802.11n AP Modus, wohl aus dem Grund das Atheros
das nicht vorgesehen hatte und das nötige Silizium einfach fehlt.
(Siehe AR9271, da wurde sogar noch auf mehr verzichtet)

Wenn also 802.11n-draft, dann nur als station.
Noch ein kleiner Tipp: Es lohnt sich den Crypto Accelerator für AES
(Ein Flaschenhals und Fehlerquelle des Designs) abzuschalten.
Auch sollte man um Interferenzen (Sei es durch viele Geräte in der 
Gegend, oder auch Radaranlagen) einen Bogen machen. Laut Atheros selbst
kann ein bestimmer Pulse den Chip "völlig" lahmlegen (Der selbe
Fehler steckt übrigens auch im AR9160 (Also im der PCI Lösung)).

Autor: thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nico schrieb:
>
> Ich zitiere
>
> http://wireless.kernel.org/en/users/Drivers/carl9170
>
> Bei "Working" steht so:
>  * 802.11 a/b/g/draft-n
>  * legacy (802.11bg) accesspoint, ad-hoc operation mode
>  * 802.11n station mode, monitor (with injection)
>
> Bei "not supported steht":
>  * real 802.11n AP

Der Punkt ist erst irgendwann in letzten zwei Monaten hinzugekommen.
Ich gehe davon aus, dass damit eher die fehlende Unterstützung des 5 GHz 
Bandes gemeint ist.
Die Abstürze im n-Modus scheinen mir eher Softwareprobleme zu sein, oder 
weiß jemand genau, wie diese entstehen?

Autor: Unbekannt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm, ich programmiere etwas Hardware, aber irgendwas scheint bei 
folgendem nicht zu stimmen:

PC -> USB -> Controller Netzwerkkarte
Controller Netzwerkkarte -> USB -> PC

Ich meine die Datenübermittelung.
Entweder stimmt was bei der Datenübermittelung nicht, aber wenn man 
etwas weiter im Netz recherchiert, findet man sehr schnell 
Anhaltepunkte, dass die 300 mbit "n" unter WIN XP und WIN 7 
funktionieren.

Merkwürdig.......

Ich glaube man muß den Entwicklern der Treiber für die Netzwerkkarte 
"unter Linux" noch etwas Zeit geben "kann aber auch sein, dass es zu 
schwer ist umzusetzen".

Naja... ich find es nur komisch, das dort steht:

"not supported steht":
* real 802.11n AP

krass

Cu Unbekannt

Autor: Marco .. (tuding)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Unbekannt: Ich verstehe deinen Post nicht. Der Carl Linux Treiber hat 
nicht das geringste zu tun mit dem offiziellen Windows-Treiber. Dieser 
unterstützt, genauso wie der carl9170 Treiber 802.11n (also bis zu 
300mbit/s). Das gilt aber für den "client" Mode.

Mit AP (=Access Point) hat das nichts zu tun. Was auf der carl Seite 
steht heißt nichts anderes, als dass der Stick nicht als "echter" N mode 
AP betrieben werden kann. Was "echt" genau heißt, darüber können wir 
wohl nur spekulieren.

Fakt ist, der Stick geht in den Master Mode auch bei 300mbit/s. Nur wenn 
die Verbindung belastet wird, gibt es halt Probleme, die das ganze 
unnutzbar machen. Ich im übrigen glaube auch eher daran, dass die 
Probleme von der Software herkommen. Wenn das von der Hardware kommen 
würde, dann ginge der 300mbit AP Modus wohl überhaupt nicht erst.

Vielleicht werden wir ja noch erleuchtet.

PS: Der carl9170 Treiber an sich wurde seit 29.10. nicht mehr verändert

Autor: Unbekannt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Marco G. jepp da haste vollkommen Recht.

Ich hatte gerade noch dran gedacht, das eventuell der Wlan Stick zu warm 
wird, ein interner Temperatursensor drinne ist und der Stick erst wieder 
funktioniert, wenn die Temperatur runter geht.

Was meinst du dazu?

Aber das würde auch nicht erklären, weshalb man im Client Mode die 
vollen 300 mbit ausschöpfen kann.

Oder bricht er dort auch ab und zu ab?

Wenn ja, dann müsste man das gute Stück ordentlich kühlen.

Ich hab mir nun trotzdem den Wlan Stick gekauft.

Cu Unbekannt

Autor: thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Unbekannt: Raterei bringt uns hier jetzt nicht weiter.

Marco G. schrieb:
> PS: Der carl9170 Treiber an sich wurde seit 29.10. nicht mehr verändert

Doch es wird schon noch was getan. Hier zb ein etwas kurzer Patch vom 
15.11
https://patchwork.kernel.org/patch/324992/

Es müsste sich wohl mal jemand die Arbeit machen, sich in der 
Mailingliste einzutragen, dort die Probleme schildern und auch darum 
bitten den Punkt "real real 802.11n AP" genauer zu erläutern.

Autor: Unbekannt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok.....
Heute kam zum Glück schonmal die USB WlanKarte TP-LINK TL-WN821N.
Läuft zumindest der Accespoint Modus bei 54 Mbit ohne Probleme auf der 
Dockstar?

Muß noch etwas warten, bis die Dockstar, als auch ein 16 Gig USB Stick 
da ist. Diese Teile sollten dann aber am Montag bei mir sein..

Gruß Unbekannt

Autor: thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So ich hab jetzt das Problem in der Linux Wireless Mailinglist 
geschildert.
Leider ist der zuständige Entwickler im Moment krank.

@Marco: Verwendest du als Client zufällig auch eine Intel Wilink Karte? 
Weil mit denen soll es zu "aggregation stalls"  kommen. Vielleicht ist 
das das Problem. Es gibt angeblich einen Workaround dafür, hab aber 
nichts gefunden.

Autor: Marco .. (tuding)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich nutze eine Intel Advanced-N 6200 Karte als Client.

Autor: thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm weiß nicht, ob die ebenfalls betroffen ist.
Ich habe aber noch einen zweiten WN821n-Stick. Damit kann ich morgen mal 
Testen ob es wirklich an der Intel Karte liegt.

Autor: tja (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und was sagt der Test?

Autor: thomas (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Leider nichts Positives. Hängt wohl doch nicht mit der Intel Karte 
zusammen.
Anbei könnt ihr euch ja mal die Fehlermeldung anschauen.

Autor: Andreas Bos (andy_help)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi @all,
wollte Fragen, ob man die Dockstar mit dem Wlan Stick "TP-LINK 
TL-WN821N" non stop als 54 mbit ap mode einsetzen kann....Nicht das der 
Stick zu heiß wird und seine Arbeit verweigert.

Cu Andy_help

Autor: thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Meiner läuft seit zwei Monaten durchgehend. Mit 54Mbit gab es keine 
Probleme.

Autor: Andreas Bos (andy_help)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke Dir, dann kann ich ja schon mal beruhigt schlafen :D

Autor: Marco .. (tuding)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Meiner läuft auf 54mbit auch wie ne 1, man muss aber dazu sagen, dass 
ein paar kleinere Treiber Bugs schon noch da sind:

[ 8843.408020] ieee80211 phy0: invalid plcp cck rate (0).
[18002.699306] ieee80211 phy0: FW: MAC RESET
[18540.765028] ieee80211 phy0: FW: MAC RESET
[19697.074811] ieee80211 phy0: FW: MAC RESET
[19838.522863] ieee80211 phy0: FW: MAC RESET
[21098.099820] ieee80211 phy0: FW: MAC RESET

Autor: Andreas Bos (andy_help)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
[21098.099820] ieee80211 phy0: FW: MAC RESET

ieee80211 = 802.11
FW = Firmware

MAC RESET

In der Firmware wird die Mac Adresse zurückgesetzt?

Wenn ja, dann juckt es mich nicht, solange ich ja immer die selben IP 
Adressen habe.

Oder wird bei einer MAc Adressen Rücksetzung, gleichzeitig auch die IP 
Adresse resetet?
Dann könnte die 54 Mbit Verbindung ein wenig "wirklich sau wenig" mal 
unterbrochen sein.

Wäre schön, wenn mir einer das erklären könnte.

Autor: Nico (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
thomas schrieb:
> Nico schrieb:
>>
>> Ich zitiere
>>
>> http://wireless.kernel.org/en/users/Drivers/carl9170
>>
>> Bei "Working" steht so:
>>  * 802.11 a/b/g/draft-n
>>  * legacy (802.11bg) accesspoint, ad-hoc operation mode
>>  * 802.11n station mode, monitor (with injection)
>>
>> Bei "not supported steht":
>>  * real 802.11n AP
>
> Der Punkt ist erst irgendwann in letzten zwei Monaten hinzugekommen.
Und? Der Treiber ist auch erst in den letzten Monaten hinzugekommen,
ich denke eher das ist noch Work-In-Progress.
Mehr noch, es gibt auch noch eine Section für "Not Working Yet".
Demnach müsste "real 802.11n AP" dort stehen und nicht unter "Not 
Supported", oder?

> Ich gehe davon aus, dass damit eher die fehlende Unterstützung des 5 GHz
> Bandes gemeint ist.
Hast du nen Link dazu? dnr Atheros/ZyDAS (und auch der Autor)
halten sich jedenfalls sehr bedeckt zu den Problemen. Der AR9170
scheint (wie der AR9160) wohl echt ein einziges Fehldesign zu sein.

> Die Abstürze im n-Modus scheinen mir eher Softwareprobleme zu sein, oder
> weiß jemand genau, wie diese entstehen?
Ich fand den Link ganz krass:

http://bugzilla.intellinuxwireless.org/show_bug.cg...

Und von Intels offizieller Seite war das zu hören:
http://comments.gmane.org/gmane.linux.kernel.wirel...

"I thought about that and I even have the patch for it, but it works
sometime and not the other and it is not stable, that is why I did not
push upstream, I might need to spend more time to figure out what is
going on there. Just don't have much time in the past few weeks/months."

Ich für meinen Teil, habe die IWL 5300 endgültig beerdigt und durch eine 
SR71-E (AR9280) ersetzt. Nach einem Update auf die neuste 
compat-wireless [die in diesem Thread angehängte Version ist auch schon 
zu alter] + 1.9.1 firmware läuft das Teil anständig... (Komischerweise 
funktioniert auch
mein MAC, obwohl der eine Broadcom?)

---

Die "MAC RESET"s sind nach der Wikipage
http://wireless.kernel.org/en/users/Drivers/carl9170 (Recovery FAQ)

Nur Meldungen des TX/RX (wohl Sende-/Empfang-) Watchdogs und nichts
ungewöhnliches/schlimmes. Denn so gut wie alle Netzwerkgeräte besitzen 
sowas inzwischen.

Autor: thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nico schrieb:
> Und? Der Treiber ist auch erst in den letzten Monaten hinzugekommen,
> ich denke eher das ist noch Work-In-Progress.
> Mehr noch, es gibt auch noch eine Section für "Not Working Yet".
> Demnach müsste "real 802.11n AP" dort stehen und nicht unter "Not
> Supported", oder?

Was und? Das Ganze war vor nicht allzulanger Zeit noch nicht ersichtlich 
und damit hat sich's ^^

> Hast du nen Link dazu? dnr Atheros/ZyDAS (und auch der Autor)
> halten sich jedenfalls sehr bedeckt zu den Problemen. Der AR9170
> scheint (wie der AR9160) wohl echt ein einziges Fehldesign zu sein.

Nein, wie angedeutet nur eine Vermutung. Was sich der Autor dabei 
gedacht hat, weiß wohl nur er selbst.

Autor: Andy_help (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen...
wollte Fragen, ob mir jemand die Datei hostapd.conf in /etc/hostapd/ 
geben könnte.
Bei mir folgt, nach obriger Anleitung "wie man das Netzwerk 
konfigurieren sollte", folgendes:

service networking restart
Running /etc/init.d/networking restart is deprecated because it may not 
enable again some interfaces ... (warning).
Reconfiguring network interfaces...dhcpcd.sh: interface eth0 has been 
configured with new IP=192.168.2.6
Configuration file: /etc/hostapd/hostapd.conf
Failed to create interface mon.wlan0: -23 (Too many open files in 
system)
Try to remove and re-create mon.wlan0
done.


Tjo...ich dachte, verwendest de halt neuere Pakete

compat-wireless-2010-12-23.tar.bz2

und die

carl9170-1.fw

kann es daran liegen?

lsmod:

Module                  Size  Used by
bridge                 43760  0
stp                     1378  1 bridge
ipv6                  253826  10
arc4                    1064  2
ecb                     1739  2
carl9170               68328  0
mac80211              187592  1 carl9170
compat_firmware_class     5621  1 carl9170
ath                    13295  1 carl9170
hmac                    2475  0
cfg80211              131812  3 carl9170,mac80211,ath
rfkill                 14296  1 cfg80211
sha1_generic            1717  0
compat                  4560  3 carl9170,mac80211,cfg80211
mv_cesa                 9262  0
aes_generic            32820  1 mv_cesa
ext2                   55411  1
mbcache                 4860  1 ext2
sd_mod                 31312  3
crc_t10dif              1106  1 sd_mod
usb_storage            34879  2
scsi_mod              119252  2 sd_mod,usb_storage
ehci_hcd               35579  0
usbcore               122183  5 carl9170,compat,usb_storage,ehci_hcd
mvsdio                  5318  0
nls_base                5367  1 usbcore
mv643xx_eth            22562  0
mmc_core               50206  1 mvsdio
libphy                 14836  1 mv643xx_eth
inet_lro                5060  1 mv643xx_eth

und iw list:

Wiphy phy0
        Band 1:
                Capabilities: 0x184e
                        HT20/HT40
                        SM Power Save disabled
                        RX HT40 SGI
                        No RX STBC
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-15, 32
                Frequencies:
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (disabled)
                        * 2472 MHz [13] (disabled)
                        * 2484 MHz [14] (disabled)
                Bitrates (non-HT):
                        * 1.0 Mbps
                        * 2.0 Mbps (short preamble supported)
                        * 5.5 Mbps (short preamble supported)
                        * 11.0 Mbps (short preamble supported)
                        * 6.0 Mbps
                        * 9.0 Mbps
                        * 12.0 Mbps
                        * 18.0 Mbps
                        * 24.0 Mbps
                        * 36.0 Mbps
                        * 48.0 Mbps
                        * 54.0 Mbps
        max # scan SSIDs: 4
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * Unknown mode (8)
                 * Unknown mode (9)
        Supported commands:
                 * new_interface
                 * set_interface
                 * new_key
                 * new_beacon
                 * new_station
                 * new_mpath
                 * set_mesh_params
                 * set_bss
                 * authenticate
                 * associate
                 * deauthenticate
                 * disassociate
                 * join_ibss
                 * Unknown command (68)
                 * Unknown command (55)
                 * Unknown command (57)
                 * Unknown command (59)
                 * Unknown command (67)
                 * set_wiphy_netns
                 * Unknown command (65)
                 * Unknown command (66)
                 * connect
                 * disconnect


Naja, wünsche Euch noch schöne Weihnachten ;)

Autor: Andy_help (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm....schöne wäre es, wenn mir jemand die Datei für 54 Mbit u.300 Mbit 
AP Mode geben könnte.

Autor: Andy_help (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Super....also bei mir klappt die obrige Anleitung von Dir nicht.

Ich denke mal, das es an der /etc/hostapd/hostapd.conf liegt.

Könnte mir jemand mitteilen, was ich dort für ein 54 Mbit AP Modus 
abändern muss oder könnte mir netterweise diese jemand geben?

Cu Andy

Autor: jörg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fehlermeldungen, richtig kompiliert, deine hostapd.conf?

Geht nicht ist leicht gesagt, meistens sitzt der fehler 50cm vorm 
bildschirm.

Autor: Andy_help (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok,
hab alles als index.html auf meinen Webserver gestellt.

Vielleicht weis jemand, weshalb es nicht geht.

Achso, bei meinen PCs, wird das Accesspoint zwar gefunden.
Wenn ich mich aber connecten möchte, bekomme ich keine Daten, wie IP, 
Netzmaske etc.

Also auf gut deutsch....eine Verbindung kommt nicht zustande :-(

http://andreasbos.dyndns.org/

Help please

Autor: tuding (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
dann leg mal ne statische ip am rechner fest oder installier nen dhcp 
server auf der dockstar, z.b. dnsmasq. dann sollte es gehn. für routing 
brauchst du dann noch forwarding.

Autor: Andy_help (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi @all,
erstmal ein gutes neues Jahr wünsche ich Euch.

@tuding Ich hab dnsmasq als dhcp Server eingesetzt und folgendes in die 
dnsmasq.conf geschrieben.

interface=wlan0
dhcp-range=192.168.0.2,192.168.0.255,255.255.255.0,12h

es läuft jetzt zuverlässig :D

Ich wollte jedoch die Dockstar "sprich jedem Wlan Clienten, der sich auf 
das Dockstar Accespoint befindet", auch ans Internet bringen".

Ich nehme die eth0 Schnittstelle, verbinde diese mit meinem DSL Modem 
und folge der Anleitung beim installieren des pppoeconf.

Hm....ich hab hier mal alles niedergeschrieben....ist eine etwas lange 
Geschichte http://andreasbos.dyndns.org/accesspoint.html

Vielleicht kann mir ja einer helfen.

Cu Andy_help

Autor: Andy_help (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hatte sich mit folgenden Konsolebefehle gelöst:

iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE
sysctl -w net.ipv4.ip_forward=1

So, weg mit dem Netgear Router

Autor: Andy_help (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein neuer Carl Treiber kam am Ende des Jahres raus :D

http://www.kernel.org/pub/linux/kernel/people/chr/...

Autor: Andy_help (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es steht zwar auf deren Hompage immer noch unter no supported "N Modus 
AP", kann aber sein, das die Hompage noch nicht aktualisiert wurde.

Wer will kann testen ;)

Autor: Burner XT (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Tag,

ich habe nun wirklich alles mögliche versucht um den WLAN-Stick 
TL-WN821N unter der Dockstar zum laufen zu kriegen. Ich habe bestimmt 
die Dockstar 10 mal neu aufsetzen müssen.
Ich habe immer diese Anleitung genutzt:
http://jeff.doozan.com/debian/

Also habe ich den selben kernel wie hier im Howto

Es klappt weder mit dem Selbstkompilieren noch mit den .deb Paketen von 
hier.
Eigentlich scheint alles soweit perfekt zu laufen alles wird kompiliert 
(es kommen keine Errors aber Warnungen die automatisch übersprungen 
werden).
Wenn ich die Dockstar neuboote und den WLAN-Stick reinhänge kommt nur 
(dmesg | tail):
[   16.593842] eth0: link up, 100 Mb/s, full duplex, flow control disabled
[   16.600681] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   27.335619] eth0: no IPv6 routers present
[   57.555943] usb 1-1.3: new high speed USB device using orion-ehci and address 4
[   57.676533] usb 1-1.3: New USB device found, idVendor=0cf3, idProduct=7015
[   57.683445] usb 1-1.3: New USB device strings: Mfr=16, Product=32, SerialNumber=48
[   57.691061] usb 1-1.3: Product: UB95
[   57.694649] usb 1-1.3: Manufacturer: ATHEROS
[   57.698975] usb 1-1.3: SerialNumber: 12345
[   57.705143] usb 1-1.3: configuration #1 chosen from 1 choice

lsmod gibt das hier aus:
Module                  Size  Used by
ipv6                  253826  10
hmac                    2475  0
sha1_generic            1717  0
mv_cesa                 9262  0
aes_generic            32820  1 mv_cesa
ext2                   55411  1
mbcache                 4860  1 ext2
sd_mod                 31312  3
crc_t10dif              1106  1 sd_mod
usb_storage            34879  2
scsi_mod              119252  2 sd_mod,usb_storage
ehci_hcd               35579  0
mvsdio                  5318  0
usbcore               122183  3 usb_storage,ehci_hcd
mv643xx_eth            22562  0
nls_base                5367  1 usbcore
mmc_core               50206  1 mvsdio
libphy                 14836  1 mv643xx_eth
inet_lro                5060  1 mv643xx_eth

Das heißt der Treiber carl9170 wird gar nicht aufgenommen, warum auch 
immer. Wenn ich das Modul manuell hinzufüge mit modprobe carl9170 ändert 
sich die dmes | tail auf:
[   57.676533] usb 1-1.3: New USB device found, idVendor=0cf3, idProduct=7015
[   57.683445] usb 1-1.3: New USB device strings: Mfr=16, Product=32, SerialNumber=48
[   57.691061] usb 1-1.3: Product: UB95
[   57.694649] usb 1-1.3: Manufacturer: ATHEROS
[   57.698975] usb 1-1.3: SerialNumber: 12345
[   57.705143] usb 1-1.3: configuration #1 chosen from 1 choice
[  421.486938] Compat-wireless backport release: compat-wireless-2011-01-06
[  421.493676] Backport based on linux-next.git next-20110112
[  421.586034] cfg80211: Calling CRDA to update world regulatory domain
[  421.727826] usbcore: registered new interface driver carl9170

Der WLAN-Stick leuchtet auch nicht.
iw list gibt gar nichts aus.

Erst dachte ich es könnte an der Festplatte liegen an der ich es 
ursprünglich installieren wollte. Die hat 7200rpm und daher dachte ich 
das der Strom von USB nicht ausreichen würde aber nun funktioniert der 
USB-Stick genauso wenig und mit dem selben Fehlern. Ich bitte dringendst 
um Hilfe!

Vielen Dank!
Burner XT

Autor: nico (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Burner XT schrieb:
> Es klappt weder mit dem Selbstkompilieren noch mit den .deb Paketen von
> hier.
> Eigentlich scheint alles soweit perfekt zu laufen alles wird kompiliert
> (es kommen keine Errors aber Warnungen die automatisch übersprungen
> werden).
> Wenn ich die Dockstar neuboote und den WLAN-Stick reinhänge kommt nur

> [   57.676533] usb 1-1.3: New USB device found, idVendor=0cf3, idProduct=7015
> [   57.683445] usb 1-1.3: New USB device strings: Mfr=16, Product=32, 
SerialNumber=48
> [   57.691061] usb 1-1.3: Product: UB95

Schau mal genau auf deinen Stick. Ich wette es ist ein WN821Nv3!

Folglich bringt dir carl9170 gar nix. Stattdessen solltest du
dein Glück mit ath9k_htc versuchen. Doch sei gewarnt, ath9k_htc
unterstütz momentan den AP-Mode nicht. Doch das könnte sich
auch bald wieder ändern, zumindest hat Atheros versprochen das
fehlende Feature "Anfang" Januar freizuschalten.

Grüße,
   Nico

Autor: Burner XT (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke Nico für den Hinweis, da wäre ich nie drauf gekommen. Ich dachte 
es gäbe nur v1 und v2. Woran sehe ich denn das es sich hierbei um v3 
handelt & wo gibt es die Info das Atheros auch für den v3 die 
AP-Funktion bereitstellen will?
Kann mir jemand sagen woher ich einen TL-WN821Nv2 herkriege und wie ich 
das beim Kauf erkenne?

Vielen Dank!
Burner XT

Autor: HellG (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
ich habe hier einen TL-WN822N (lsusb: ID 0cf3:1002 Atheros 
Communications, Inc. TP-Link TL-WN821N v2 [Atheros AR9001U-(2)NG]) der 
leider die gleichen Probleme mit dem Betrieb als 802.11N AccessPoint 
hat. Was ich noch nicht ausprobiert habe ist die zusätzliche 
Stromversorgung für den USB HUB (meine GoFlex Net hat halt nur einen 
USB-Port). Da der Hub (LevelOne USB-0501) aber auch noch einen zweiten 
Netzwerkport hat wirds mit der Festplatte vielleicht ein bischen viel 
für die kleine Box. Geplant ist der Einsatz zusammen mit einem 20x4 LCD 
Display, einem Gamepad als Input und den LAN und WLAN Schnittstellen als 
All-In-One DSL-Router-NAS fürs heimische Netzwerk. Wäre halt schön, wenn 
802.11n gehen würde da 54Mbit für Fotobearbeitung halt doch ein bischen 
lahm ist.

Gruß HellG.

Autor: HellG (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja, der zusätzliche Strom hat leider auch nichts gebracht... Schade 
eigentlich.

Autor: HellG (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, es scheint tatsächlich so zu sein, dass der AR9170 keinen schnelle 
AP Modus kann. Die Hardware gibt es leider nicht her. Damit gibt es 
glaube ich keine Möglichkeit aus der Dockstar einen 802.11n AP zu bauen, 
weil es schlicht keine Hardware gibt, die man anschließen könnte. Ich 
werde jetzt erstmal den Adapter im g-Modus betreiben und vielleicht mal 
aufrüsten, wenn es einen USB Adapter gibt der den AP Modus unterstützt.

Gruß HellG

Autor: tuding (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Quelle?

Tatsächlich funktioniert der AP auch bei 2x2 MIMO mit dem Stick nur 
leider ist das instabil. Ich bin nach wie vor der Meinung, dass das am 
Treiber und nicht an der Hardware liegt.

Autor: HellG (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab einfach nochmal auf der mailingliste nachgefragt:

--- Frage:
Any news about this issue?
--- Antwort vom zuständigen Entwickler:
no news, unless you have news about a new generation of ar9170 chip.
The current one has serve problems with 802.11e - which has become
mandatory for 802.11n - and aggregation. So going for full 802.11n
support [including AP] is sort of pointless...

If you are looking for a 802.11n AP, so why not start with one?
---

Wie gesagt, klingt nicht sehr vielversprechend.

Bei mir habe ich zusätzlich das Problem, dass sich Festplatte und WLan 
Adapter am gleichen USB Hub stören. Dem Wlan macht das nicht so viel 
aus, aber die Platte mag das gar nicht.

Gruß Darkstar.

Autor: Burner XT (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Tag,

endlich habe ich den Stick! (gepriesen sei eBay :D)

Bin jetzt aber an dem Punkt gekommen, wo ich ich das WLAN zum LAN 
forwarden möchte und genau das wird hier leider nicht mehr erläutert.
Wie in den oberen Post's könnte man es bridgen aber das ist mir nix dann 
lieber nat'en ;)

Hat jemand das passende HowTo dafür oder kann er am besten gleich seine 
Konfig schicken?
Die Ausgaben von:
--> /etc/network/interfaces
--> route -L
--> /etc/dnsmasq.conf
--> /etc/hostapd.conf
+
--> iptables-Einstellungen

wären mir sehr hilfreich.


Vielen Dank!

MfG
Burner XT

Autor: blubb (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Komisch, Amazon [Amazon selbst, nicht ein Marketplaceverkäufer] lieferte 
mir vergangene Woche die V2[.8].


Für IPv4 brauchst du eigentlich nur:

iptables -A FORWARD -j ACCEPT (oder -P FORWARD ACCEPT)
iptables -t nat -A POSTROUTING -j MASQUERADE

echo 1 > /proc/sys/net/ipv4/ip_forward

und natürlich den ethX[oder pppX] und wlanX eine statische Adresse 
zuweisen. Dem sei noch angemerkt, dass der kurze Regelsatz nur für 
Accesspoint
und nicht für "Internet-Router" taugt. Solltest du dementsprechende 
Ambitionen besitzten wärest du mit Shorewall wohl besser bedient...

Beziehungsweise, dann gleich "OpenWRT", dort gibt es nämlich tausende 
Kochrezepte und alles geht mehr oder weniger -outofthebox- (dhcp, 
dnsmasq, rdate, hostapd, etc... sind da nämlich inklusive)

Autor: Burner XT (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo blubb,

ich habe die Regeln nun so eingetragen und komme immernoch nicht ins 
Internet :/
Habe meine Konfigdateien mal hier hochgeladen, vllt. versteckt sich dort 
der Fehler.
Wenn ich z.B. web.de anpinge, dann wird zwar der Name aufgelöst aber 
dann kommt es zur Zeitüberschreitung.
Komisch ist das iwlist wlan0 scanning einen Fehler ausspuckt:
wlan0     Interface doesn't support scanning : Operation not supported



iwconfig scheint korrekt zu sein:
wlan0     IEEE 802.11bgn  Mode:Master  Frequency:2.442 GHz  Tx-Power=20 
dBm
          Retry  long limit:7   RTS thr=2347 B   Fragment thr=2346 B
          Power Management:off

mon.wlan0  IEEE 802.11bgn  Mode:Monitor  Tx-Power=20 dBm
          Retry  long limit:7   RTS thr=2347 B   Fragment thr=2346 B
          Power Management:off


Habe echt keine Ahnung, warum ich nicht durchkomme. :(

Autor: Burner XT (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich kann mir meine Frage selber beantworten. Es lag an der Firmware...
Ich habe nun die 1.8.3 genommen und nun gehts. Halleluja :D

Autor: Shingiskahn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Tag,

in diesem Howto wird auf das Tool wpasupplicant verwiesen. Wofür brauche 
ich das Tool wenn ich in der hostapd.conf schon das Passwort gesetzt 
habe?

z.B. mit
wpa_passphrase=c/.T_]6iOQ.I]BGf-{x)22&xwa]-]mvBz&u[b,E2[QY:r"~~{x)/+.(#m 
c/LR'l  ## so ungefähr

Gibt es eine Möglichkeit das Passwort in der hostapd.conf zu 
verschlüsseln oder ist gerade das der Sinn von wpasupplicant, welches ja 
das Tool wpa_passphrase erhält und mir eine PSK ausgibt?

Bin sehr gespannt auf eure Antworten.

Vielen Dank!

Autor: nico (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie du schon sagst, den wpasupplicant bräuchte man für den AP Betrieb
per-se eigentlich nicht.

Es kann aber trotzdem recht interessant sein, da der Stick mit der 
Standard Firmware gleich 2 Netzwerke handhaben kann. Klar, man könnte 
den zweiten "Slot" auch als Gast-AP anbieten. Aber interessanter ist die 
Möglichkeit
dem Stick als Universal-Repeater laufen zu lassen [und hier ist der 
wpasupplicant auch nötig] um so die Reichweite "seines" LANs etwas zu 
erhöhen... z.b.: In den Garten oder die Garage.

Autor: Franz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Ich will mit meiner wlan-karte SR71-USB (Atheros AR9170 chipsatz), zu 
Testzwecken, viele SSID's simulieren. Dazu möchte ich fakeap benutzen, 
aber ich bekomm meine wlan-karte nicht ohne weiteres in den master mode.
Bei der suche bin ich auf dieses Tutorial gestoßen und es funktioniert 
bei mir, nach einigem hin und her, wunderbar. ^^
Nur leider bekomm ich es nicht auf die reihe, meine wlan karte ohne 
hostapd in den master mode zu versetzten, damit ich fakeap nutzen kann. 
Sobald ich die karte mit hostapd in den master mode versetzt, bekomm ich 
von fakeap Fehlermeldungen ala "SET failed on device wlan0".

Hat vielleicht jemand eine Idee, wie ich fakeap mit der wlan karte zum 
laufen bekomme? Ich bin leider auch im Linux gebiet noch nicht 
sonderlich bewandert, was die Sache etwas erschwert.

Hoffe ihr könnt mir weiterhelfen.

Schöne Grüße

Autor: nico (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"The mac80211 subsystem moves all aspects of master mode into user 
space. It depends on hostapd to handle authenticating clients, setting 
encryption keys, establishing key rotation policy, and other aspects of 
the wireless infrastructure. Due to this, the old method of issuing 
'iwconfig <wireless interface> mode master' no longer works. Userspace 
programs like hostapd now use netlink (the nl80211 driver) to create a 
master mode interface for your traffic and a monitor mode interface for 
receiving and transmitting management frames."

http://linuxwireless.org/en/users/Documentation/hostapd

Autor: Druff (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
300 Mbit DRAFT N Accesspoint wird ja immer noch nicht unterstüzt.
Wie sieht es aber mit dem 150 Mbit Accesspoint Mode aus?

Autor: Druff (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
? keiner eine Ahnung=?

Autor: keine_ahnung_auch_eine_ahnung (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mal eine Frage....dieser USB Wlan Adapter läuft doch nur im AP Modus mit 
300 mbit instabil......?
Dann könnte man diesen doch im ADHOC Modus laufen lassen oder?

z.B. so

USB Wlan Adapter = wlan0

dann macht man wlan0,0, wlan0,1, wlan0,2 usw. drauß, vergibt halt denen 
jeweils eine andere ip adresse, subnetmaske und ssid mit verschlüsselung 
und man kann auch über nur einen usb wlan adapter im 300 mbit modus 
surfen, die auf die netzwerkteilnehmer "clienten" verteilt wird.

man müsste dann doch nur die wlan0,0, wlan0,1, wlan0,2 nach wlan 
weiterleiten und von wlan nach z.B. eth0.

sehe ich das so richtig?

Autor: alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hello,

unfortunately I get the following error when I try to compile compat. 
Since I am quite new to Linux, I don't know what to do?

Any help would be greatly appreciated!!!

/usr/src/compat-wireless-2010-10-11/include/linux/compat-2.6.34.h:22: 
error: redefinition of 'netdev_name'
/usr/src/linux-headers-2.6.32-5-common/include/linux/netdevice.h:2032: 
error: previous definition of 'netdev_name' was here
make[5]: *** [/usr/src/compat-wireless-2010-10-11/compat/main.o] Error 1
make[4]: *** [/usr/src/compat-wireless-2010-10-11/compat] Error 2
make[3]: *** [_module_/usr/src/compat-wireless-2010-10-11] Error 2
make[2]: *** [sub-make] Error 2
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.32-5-kirkwood'
make: *** [modules] Error 2

Thanks a lot
Alex

Autor: joachim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

WN821Nv3 geht jetzt auch - habe es mit ath9k_htc aus bleeding edge 
compat-wireless und hostapd 0.7.3 zum Fliegen gebracht.

Geschwindigkeit ist nicht ueberragend aber deutlich ueber g - bekomme 
mit netio so 55-60MBit netto rum bei 4m durch den Raum, was aber auch am 
ziemlich dichten 2.4GHz Band hier liegen koennte. Jedenfalls mault 
hostap rum, dass sein 40 MHz Band von Channel 1 nach oben nicht ganz 
frei waere - am Rand auch Channel 6 ist nen Nachbar und auf Channel 1 
selbst findet meine Fritzbox auch noch nen schwachen Stoerer. Aber oben 
raus ist alles dicht... Weiss jemand nen Stick der 5GHz kann?

Stabil scheint es zu sein, jedenfalls habe ich auch nach laengerem 
Testen keine Aussetzer bemerkt. Muss mal die Bridge bauen, dann kann ich 
das dauernd zum Surfen benutzen...

Gruss,

Joachim

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
joachim schrieb:
> Geschwindigkeit ist nicht ueberragend aber deutlich ueber g - bekomme
> mit netio so 55-60MBit netto rum bei 4m durch den Raum, was aber auch am
> ziemlich dichten 2.4GHz Band hier liegen koennte. Jedenfalls mault
> hostap rum, dass sein 40 MHz Band von Channel 1 nach oben nicht ganz
> frei waere - am Rand auch Channel 6 ist nen Nachbar und auf Channel 1
> selbst findet meine Fritzbox auch noch nen schwachen Stoerer. Aber oben
> raus ist alles dicht... Weiss jemand nen Stick der 5GHz kann?

Ich hab jetzt auch mal nen v3 geholt. Allerdings bin ich von dem Teil 
nicht wirklich überzeugt, ist nämlich genauso problematisch bei HT40 und 
funktioniert nur mit HT20 anständig. Dazu kommt noch das die die Anzahl 
der Geräte begrenzt ist, nach 6 war Schluss [Und das ist Blöd, bei 3 PC, 
3  Smartphones und einem Printserver]

Autor: boca (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
welcher wlan usb stick ist denn nun am besten als AP geignet?

Autor: Evil (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe den TL-WN821Nv3 nun auch mit Debian Wheezy (Kernel 3.0.0 und 
hostapd 0.7.3) zum Laufen gebracht (allerdings auf x86).
Android Phone geht gut - Netbook leider nicht.
Hab noch nicht viel getestet aber für Internet am Smartphone passt es.

Anleitung:
http://evilx99.ev.funpic.de/linux/ThinClient/serve...

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hat sich da noch was getan? läuft mittlerweile alles stabil?

Autor: Davygravy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thank you for posting this, both original author and responders. It 
inspired me to try to do the same.  I believe I've solved all the 
problems that I stumbled upon.  I now have an access point that is 
stable, robust, and has a range that covers my house and yard/garden.

http://forum.doozan.com/read.php?2,6300,6451

Autor: jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Davygravy schrieb:
> Thank you for posting this, both original author and responders. It
> inspired me to try to do the same.  I believe I've solved all the
> problems that I stumbled upon.  I now have an access point that is
> stable, robust, and has a range that covers my house and yard/garden.
>
> http://forum.doozan.com/read.php?2,6300,6451

https://lists.ath9k.org/pipermail/ath9k-devel/2012...

no it doesn't...

Autor: Thomas (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

nach fast zwei Jahren hab ich nun endlich einen günstigen, 
linuxtauglichen 5GHz USB Stick gefunden um meinen Dockstar zu einem 
vollwertigen 300mbit Access Point zu machen. Es handelt sich um den 
Linksys AE1000  dessen Treiber im OpenWRT Trunk schon enthalten ist 
(wenn jemand will, kann ich fertige Images dazu hochladen). Gekostet hat 
er 17,99Eur

Allerdings hat man bei meinem Stick die Schirmung vergessen (siehe 
Bilder), wodurch die Übertragungsrate beim Senden zum AE1000 oft nur bei 
100-1000kByte/s lag. Nach etwas "Alufolien-Voodoo" (siehe Bilder) komme 
ich nun über Samba stabil auf 10MB/s beim Senden zum Router und 7MB/s 
beim Empfangen (3m Abstand). Insgesammt hab ich die Platine wohl 3-4 mal 
mit der Folie eingewickelt.

Wie man auf den Bilder sieht verfügt der Stick auch über Anschlüsse für 
zwei Antennen. Vielleicht findet diese Info ja noch jemand nützlich.

Viele Grüße,

Thomas

Autor: Burner-XT (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

es geht einfacher wenn ihr einen aktuellen Kernel verwendet. So erkennt 
er selbständig den Treiber. Ich nutze den Kernel von hier: 
http://dev.shyd.de/2013/06/kernel-3-9-5-ready-to-use/
+
hostapd-2.0
+
carl9170-1.fw (v.1.9.7)


Wenn ihr iptables und masquerading einsetzt müsst ihr auf SNAT wechseln, 
da im Kernel das Modul: ipt_masquerade fehlt.

Wenn ihr Fragen habt --> bsz7@gmx.de

MfG
Burner-XT

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.