Forum: www.mikrocontroller.net Problem im Wiki?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Falk B. (falk)


Angehängte Dateien:

Lesenswert?

Irgendwie klemmt es,  es kommen diverse Fehlermeldungen, daß 
Vorschaubilder nicht gespeichert werden können. Auch normale Bilder in 
Artikeln sind defekt. Was ist da los?

von Falk B. (falk)


Angehängte Dateien:

Lesenswert?

Siehe Anhang.

von Falk B. (falk)


Angehängte Dateien:

Lesenswert?

Und noch einer

von Andreas S. (andreas) (Admin) Benutzerseite Flattr this


Lesenswert?

Danke für den Hinweis. Bis spätestens morgen sollte sich das Problem 
erledigt haben, alle hochgeladenen Dateien sollten dann wieder sichtbar 
sein. Falls eine Seite danach noch Fehlermeldungen bei eingebundenen 
Bildern anzeigt, sollte es helfen, einmal auf Bearbeiten und Speichern 
zu klicken, dann sollten sie wieder sichtbar sein.

: Bearbeitet durch Admin
von Uwe D. (monkye)



Lesenswert?

Ja, die Bilder fehlen immer noch...

EDIT: Keine Ahnung warum hier 2x das gleiche Bild drinsteht und sich 
eins nicht löschen lässt...

: Bearbeitet durch User
von Falk B. (falk)


Lesenswert?

Die Bilder funktionieren immer noch nicht, das ZIP-Archiv ist aber jetzt 
ladbar.

von Falk B. (falk)


Lesenswert?

"Fehler beim Erstellen des Vorschaubildes: Die Miniaturansicht konnte 
nicht am vorgesehenen Ort gespeichert werden"

Was soll der Text im Artikel, wenn dort ein Bild direkt ohne Thumb, 
Skalierung und sonstwas eingefügt ist?

von Falk B. (falk)


Lesenswert?

UNd jetzt ist der Artikel durch ein verwirrte Autoformatierung ca. 3 
Bildschirmseiten breit . . . .8-0

Don't fix what ain't broken!

von Falk B. (falk)


Lesenswert?

Ahhhh, die Heinzelmännchen haben das Wiki repariert ;-)
Danke.

von foobar (Gast)


Angehängte Dateien:

Lesenswert?

Seit heute geht bei mir mikrocontroller.net gar nicht mehr[1]. 
Fehlermeldung siehe Screenshot.

Bitte, bitte, bitte (mit viel Zuckerguß): wenn ihr schon meint, https 
unbedingt erzwingen zu müssen, dann doch nicht auch gleich noch 
ausschließlich mit den stärksten Verschlüsselungsalgorithmen, die z.Zt. 
verfügbar sind.  Alte Rechner unterstützen die nicht und bekommen dann 
die o.g. Fehlermeldung.  SSL3, TLS1, TLS1.1, TLS1.2 ohne EC sind für 
Amazon & Co gut genug, aber nicht für mc.net?

Am liebsten wäre mir natürlich ein Wegfall der http->https 
Zwangsumleitung[2].  Und ja, ich bin mir bewußt, dass dann jemand 
mitlesen oder auch die Daten verändern könnte.  Mit dem "Risiko" kann 
ich leben.

Wenn es so bleibt, werd ich mc.net leider nicht mehr nutzen können.


[1] Musste für diese Meldung eine andere Kiste bemühen.
[2] Setze dafür auch gerne ein Cookie.

von 🐧 DPA 🐧 (Gast)


Lesenswert?

foobar schrieb:
> Alte Rechner unterstützen die nicht

Der Hardware dürfte das egal sein, und Software kann man updaten oder 
ersetzen. Mit veralteter Software rumzusurfen ist sowieso grob 
fahrlässig. Finde ich gut, wenn den Ewiggestrigen da mal etwas Feuer 
unterm Arsch gemacht wird,

von Falk B. (falk)


Lesenswert?

foobar schrieb:
> Am liebsten wäre mir natürlich ein Wegfall der http->https
> Zwangsumleitung[2].  Und ja, ich bin mir bewußt, dass dann jemand
> mitlesen oder auch die Daten verändern könnte.  Mit dem "Risiko" kann
> ich leben.

Welches Risiko? Die "Firmen" die das wollen können auch https mitlesen 
und manipulieren, aber die haben mal sicher "besseres" zu tun. Die 
"Hacker" eher auch. Wozu eine Sicherheitsverbindung für den Inhalt von 
uC.net? Paranoia? Zeitgeist?

K.I.S.S.

von Andre (Gast)


Lesenswert?

🐧 DPA 🐧 schrieb:
> Finde ich gut, wenn den Ewiggestrigen da mal etwas Feuer unterm Arsch
> gemacht wird,

Danke, genau das wollte ich auch eben schreiben. Es muss ja nicht das 
neueste xPhone für 1500€ sein, aber ein einigermaßen aktuelles 
Betriebssystem sollte man doch bitte einsetzen. Dann wird die Kiste auch 
nicht zur Spamschleuder, freut die anderen Internet Benutzer :)

von foobar (Gast)


Lesenswert?

>>Mit dem "Risiko" kann ich leben.
>
> Welches Risiko? Die "Firmen" die das wollen [...]

Dashalb ja die Anführungszeichen ;-)

> Wozu eine Sicherheitsverbindung für den Inhalt von uC.net? Paranoia?
> Zeitgeist?

Beides, hat auch noch Züge einer Religion.

Leute, die Risiken nicht einschätzen können (viele sind, gerade im 
technischen Umfeld, hoffnungslos überfordert), neigen zu übertriebener 
Vorsicht.  Man erwartet, dass andere (die "Nannies") sich darum kümmern 
und einem sagen, was das "Beste" für einen ist.  Und das wird dann stur 
befolgt, auch wenn es gar keinen Sinn ergibt.

von Uwe D. (monkye)


Lesenswert?

Uwe D. schrieb:
> Ja, die Bilder fehlen immer noch...
>
> EDIT: Keine Ahnung warum hier 2x das gleiche Bild drinsteht und sich
> eins nicht löschen lässt...

Geht wieder wie gewohnt - DANKE für's beheben

von Falk B. (falk)


Angehängte Dateien:

Lesenswert?

Es schint noch ein paar Probleme zu geben. Siehe Anhang. Ein 
Bearbeiten/Speichern des Artikels hilft nicht.

von Andreas S. (andreas) (Admin) Benutzerseite Flattr this


Lesenswert?

Danke, ist jetzt auch behoben.

von Magnus M. (magnetus) Benutzerseite


Lesenswert?

Andreas S. schrieb:
> Danke für den Hinweis. Bis spätestens morgen sollte sich das
> Problem
> erledigt haben, alle hochgeladenen Dateien sollten dann wieder sichtbar
> sein. Falls eine Seite danach noch Fehlermeldungen bei eingebundenen
> Bildern anzeigt, sollte es helfen, einmal auf Bearbeiten und Speichern
> zu klicken, dann sollten sie wieder sichtbar sein.

Ich habe das gerade mal beim Artikel Statemachine versucht... leider 
ohne Erfolg.

von Uwe D. (monkye)


Lesenswert?

Ja, leider funktionieren die Bilder wieder nicht mehr.

von Matthias S. (dachs)


Lesenswert?

https://www.mikrocontroller.net/articles/Hauptseite

bringt:

[e930f69e45dea90ec89570de] 2020-12-27 11:44:34: Fatal exception of type 
MWException

Matthias

von Mark B. (markbrandis)


Lesenswert?

Matthias S. schrieb:
> https://www.mikrocontroller.net/articles/Hauptseite
>
> bringt:
>
> [e930f69e45dea90ec89570de] 2020-12-27 11:44:34: Fatal exception of type
> MWException

Ist wahrscheinlich eine Fehlkonfiguration im MediaWiki:
https://stackoverflow.com/questions/17824295/fatal-exception-of-type-mwexception

von Helge S. (topflappen)


Lesenswert?

[a68c0b539eb7057599c7b7d4] 2020-12-28 13:29:23: Fatal exception of type 
MWException

von Andreas S. (andreas) (Admin) Benutzerseite Flattr this


Lesenswert?

Danke, die exception ist behoben, Bilder sollten auch wieder alle 
funktionieren. Waren beides Nachwirkungen des Serverumzugs (fehlende 
Schreibrechte auf Verzeichnisse).

von foobar (Gast)


Lesenswert?

HTTPS geht nun auch wieder.

Vielen Dank!

PS: Es scheinen die fehlenden CBC-Modi gewesen zu sein.

von Sebastian C. (scramer)


Lesenswert?

Moin.

Erstmal "ein frohes neues Jahr".

Ich habe gerade gesehen, dass auf 
https://www.mikrocontroller.net/articles/Word_Clock auch einige Dateien 
und Bilder fehlerhaft verknüpft sind. Ändern -> Speichern scheint nichts 
zu bringen...

Grüße
Sebastian

von Falk B. (falk)


Lesenswert?

Wird gerade mal wieder an der Software geschraubt?

Das 90° Drehen von Überschriften funktioniert plötzlich nicht mehr.

https://www.mikrocontroller.net/articles/Standardbauelemente#Shuntregler.2FSpannungsreferenz

Im Quelltext steht die Drehung drin, gestern ging das alles auch noch.

Hmmm . . . .

: Bearbeitet durch User
von mr. mo (Gast)


Lesenswert?

Bei mir ist die Überschrift gedreht.

von Falk B. (falk)


Angehängte Dateien:

Lesenswert?

Hmm, auf der einen Maschine (Win10 mit Edge) sind die Überschriften 
nicht gedreht (siehe Anhang), auf meiner alten Kiste mit WinXP und 
Firefox schon.
Allerdings gibt es auch da einen merkwürdigen Effekt. Wenn die Seite 
geladen wurde, sind die Überschriften schwarz, die eine Spalte ist 
zweizeilig, so wie im Quelltext definiert. Nach ein paar Sekunden werden 
die Überschriften aber grau und die Spalte mit 2 Zeilen ist nun 
einzeilig.

von foobar (Gast)


Lesenswert?

Hmm... der "Fehler beim Erstellen des Vorschaubildes: Die 
Miniaturansicht konnte nicht am vorgesehenen Ort gespeichert werden" ist 
immer noch auf 
https://www.mikrocontroller.net/articles/Relais_mit_Logik_ansteuern

von Schreiberling (Gast)


Lesenswert?

Fehlermeldung:

Wenn man im Wiki als anonymer Benutzer schreibt, speichert das Wiki eine 
falsche IP-Adresse. Meine Bearbeitung vorhin wurde unter der IP 
172.26.13.220 gespeichert, obwohl das eine private IP-Adresse ist, die 
im Netz gar nicht nutzbar ist.

https://www.mikrocontroller.net/articles/Spezial:Beitr%C3%A4ge/172.26.13.220

von Manfred (Gast)


Lesenswert?

Schreiberling schrieb:
> speichert das Wiki eine falsche IP-Adresse.

Finde ich gut.

von Rainer S. (enevile) Benutzerseite


Lesenswert?

Kommen die Artikel unter den Oberbegriffen in der Hauptseite auch 
wieder?

Hauptseite

von Oliver S. (oliver_s)


Lesenswert?

Hallo,

die Verlinkungen auf die Änderungen am Wiki auf der Hauptseite (unter 
letzte Änderungen) stimmen nicht:

Beispiel:
https://www.mikrocontroller.net/wikisoftware/index.php?title=LED&diff=103114&oldid=102960 
-> führt zu "File not found"

wiki statt wikisoftware:
https://www.mikrocontroller.net/wiki/index.php?title=LED&diff=103114&oldid=102960 
-> geht

Gruß
Oliver

von Andreas S. (andreas) (Admin) Benutzerseite Flattr this


Lesenswert?

Rainer S. schrieb:
> Kommen die Artikel unter den Oberbegriffen in der Hauptseite auch
> wieder?

Ja, habe ich soeben wiederhergestellt.

Oliver S. schrieb:
> die Verlinkungen auf die Änderungen am Wiki auf der Hauptseite (unter
> letzte Änderungen) stimmen nicht:

Danke, ist ebenfalls behoben.

von Falk B. (falk)


Angehängte Dateien:

Lesenswert?

Jetzt sind viele Bilder auf die volle Seitenbreite vergrößert, zumindest 
der Rahmen. Der Fließtext fehlt. Siehe Anhang.

von Frank M. (ukw) (Moderator) Benutzerseite


Lesenswert?

Falk B. schrieb:
> Jetzt sind viele Bilder auf die volle Seitenbreite vergrößert,
> zumindest der Rahmen. Der Fließtext fehlt. Siehe Anhang.

Ist mir auch schon in einigen Artikeln aufgefallen. Diese habe 
folgendermaßen gefixed:
1
{|
2
! style="width: 80%;" |
3
! style="width: 20%;" |
4
|- style="vertical-align:top;"
5
|
6
Fließtext Fließtext Fließtext Fließtext ...
7
Fließtext Fließtext Fließtext Fließtext ...
8
...
9
||
10
[[Datei:Bild.png|miniatur||Beschreibung]]
11
...
12
|}

Ja, es sieht ein wenig kryptisch aus. Der Trick ist eine zweispaltige 
Tabelle im Verhältnis 80:20. Der Fließtext kann übrigens auch Tabellen 
beinhalten, d.h. sie sind beliebig schachtelbar.

Beispiel-Artikel: STECCY, IRMP, IRSND, 
WordClock mit WS2812

Ja, es ist ein wenig Arbeit. Aber mir ist schon vor einigen Monaten 
aufgefallen, dass in dem einen oder anderen Artikel die Positionierung 
von Miniatur-Bildern rechts vom Fließtext nicht immer funktioniert. 
Deshalb hatte ich mich vor ein paar Tagen mal drangesetzt und das 
konsequent wie oben beschrieben durchgezogen.

: Bearbeitet durch Moderator
von Andreas S. (andreas) (Admin) Benutzerseite Flattr this


Lesenswert?

Frank M. schrieb:
> Ist mir auch schon in einigen Artikeln aufgefallen. Diese habe
> folgendermaßen gefixed

Davon rate ich ab. Das macht z.B. die Darstellung auf Handys mit 
schmalem Bildschirm kaputt. Am besten möglichst nichts manuell 
formatieren, einfach Bescheid sagen wenn etwas im Layout nicht passt, 
dann suche ich eine CSS-Lösung von der alle Artikel ohne manuelle 
Änderungen profitieren können.

von Falk B. (falk)


Lesenswert?

Frank M. schrieb:
> Ja, es ist ein wenig Arbeit. Aber mir ist schon vor einigen Monaten
> aufgefallen, dass in dem einen oder anderen Artikel die Positionierung
> von Miniatur-Bildern rechts vom Fließtext nicht immer funktioniert.

Das kam erst durch die letzte Softwareumstellung.

Don't fix what aint broken!

von Frank M. (ukw) (Moderator) Benutzerseite


Lesenswert?

Andreas S. schrieb:
> Am besten möglichst nichts manuell formatieren, einfach Bescheid sagen
> wenn etwas im Layout nicht passt, dann suche ich eine CSS-Lösung von der
> alle Artikel ohne manuelle Änderungen profitieren können.

Tut mir leid, ich dachte, das hätte früher nur zufällig funktioniert. 
Wie gesagt, mir ist schon vor einigen Monaten aufgefallen, dass nicht 
immer alle Minitatur-Bilder zu jeder Zeit immer am rechten Rand 
positioniert werden.

von Falk B. (falk)


Lesenswert?

Frank M. schrieb:
> dass nicht
> immer alle Minitatur-Bilder zu jeder Zeit immer am rechten Rand
> positioniert werden.

Wer will schon am rechten Rand stehen . . . Hust ;-)

von Magnus M. (magnetus) Benutzerseite


Lesenswert?

Falk B. schrieb:
> Wer will schon am rechten Rand stehen . . . Hust ;-)

Bei einer Panne auf der Autobahn sehr gerne, politisch ist aus meiner 
Sicht das "rechts stehen" die eigentliche Panne.

;-)

von Falk B. (falk)


Angehängte Dateien:

Lesenswert?

Im Artikel Sleep Mode sind die Fomeln etwas gestört 
(Groß/Kleinschreibung). In der Vorschau beim Bearbeiten ist es aber 
OK?!?

von Frank M. (ukw) (Moderator) Benutzerseite


Lesenswert?

Andreas S. schrieb:
> Frank M. schrieb:
>
>> Ist mir auch schon in einigen Artikeln aufgefallen. Diese habe
>> folgendermaßen gefixed
>
> Davon rate ich ab. Das macht z.B. die Darstellung auf Handys mit
> schmalem Bildschirm kaputt. Am besten möglichst nichts manuell
> formatieren, einfach Bescheid sagen wenn etwas im Layout nicht passt,
> dann suche ich eine CSS-Lösung von der alle Artikel ohne manuelle
> Änderungen profitieren können.

Falk und ich hatten das Problem ja schon geschildert. Heute beim 
Bearbeiten eines Artikels ist mir aufgefallen, dass das Problem immer 
noch besteht.

Zur Erläuterung: Das Zauberwort "miniatur"
1
[[Datei:Steccy-Nunchuk.png|miniatur|Nunchuk Controller]]
funktioniert nicht mehr. Die Bilder werden auf die volle Breite 
aufgezogen (auch wenn sie kleiner sind) statt rechts am Rand zu stehen, 
wobei früher links der größte Platz für den Text blieb.

Wird der Zustand so bleiben? Dann werde ich noch weitere Artikel (von 
mir) umstellen müssen - auch wenn die Mobilversion dann nicht mehr 
funktioniert. Besser als wenn sowohl die Desktop-Ansicht als auch die 
Mobilansicht darunter leiden.

: Bearbeitet durch Moderator
von Frank M. (ukw) (Moderator) Benutzerseite


Lesenswert?

Noch eins ist mir im Wiki aufgefallen:

Tabellen werden seit einiger Zeit auf die volle Breite aufgezogen, statt 
lediglich die maximal notwendige Breite zu nutzen.

Bei Tabellen mit lediglich zwei Spalten sieht das dann 
"gewöhnungsbedürftig" aus: Die Spalten stehen dann viel zu weit 
auseinander. Ich behelfe mich im Moment damit, dass ich eine Prozentzahl 
(z.B. "30%") für die Breite angebe, damit die Tabelle wieder auf das 
nötige Maß zusammengeschoben wird.

Edit:

Dabei kommt noch erschwerend hinzu, dass nun alle Spalten die gleiche 
Breite haben. Eine ganz schmale Spalte verwendet dieselbe Breite wie 
eine breitere Spalte, weil einfach jeder Spalte der gleiche Anteil 
zugewiesen wird.

Dadurch werden dann die Texte in den breiteren Spalten umbrochen, obwohl 
jede Menge Platz wäre, wenn man die Spalten mit kleinerem Platzbedarf 
mit der lediglich nötigen Breite darstellen würde. Früher war das 
jedenfalls so.

Auch hier behelfe ich mich damit, dass ich nun für jede Spalte einen 
eigenen Prozentsatz angebe - ein ziemlich mühseliges Unterfangen.

: Bearbeitet durch Moderator
von Falk B. (falk)


Lesenswert?

Frank M. schrieb:
> Dabei kommt noch erschwerend hinzu, dass nun alle Spalten die gleiche
> Breite haben. Eine ganz schmale Spalte verwendet dieselbe Breite wie
> eine breitere Spalte, weil einfach jeder Spalte der gleiche Anteil
> zugewiesen wird.

Ich habe in den letzten Wochen viele Tabellen formatiert, damit das 
paßt. Siehe Änderungsseite.

von Frank M. (ukw) (Moderator) Benutzerseite


Lesenswert?

Falk B. schrieb:
> Ich habe in den letzten Wochen viele Tabellen formatiert, damit das
> paßt.

Aber eigentlich könnte das Wiki dasselbe automatisch machen. Ging ja 
früher auch.

von Falk B. (falk)


Lesenswert?

Frank M. schrieb:
> Aber eigentlich könnte das Wiki dasselbe automatisch machen. Ging ja
> früher auch.

Nicht ganz. Wenn man unterschiedliche Spaltenbreiten braucht, kann man 
das oft nur sinnvoll manuell vorgeben.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.